gutsy amarok has missing build dependency

Bug #182631 reported by Peter Cherriman on 2008-01-13
10
Affects Status Importance Assigned to Milestone
amarok (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: amarok

There a missing build dependency, the missing package only exists in hardy.

$ sudo apt-get build-dep amarok
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Build-Depends dependency for amarok cannot be satisfied because the package libgpod-nogtk-dev cannot be found

derektorr (derektorr) wrote :

I confirm that. Installing libgpod-nogtk-dev from hardy on gutsy produces conflict with already installed libgpod-dev.

Alf (hubbuntu) wrote :

I just ran into this too. Unable to build amarok because the libgpod-nogtk-dev dependency is missing.

Where did you get this backported package from? It doesn't appear to be in -backports. If you're taking packages from hardy, and rebuilding them for gutsy, please mark this bug as invalid - you need to fiddle and backport any libs that go with it.

Changed in amarok:
status: New → Incomplete
Gert Kulyk (gkulyk) wrote :

Obviously Harald Sitter (the uploader of the mentioned package) did a source-upload not adjusting build-deps in debian/control (here: libgpod-dev instead of libgpod-nogtk-dev). There are no binaries from the mentioned source published, the package has state "dependency wait" on all build-machines.

Harald Sitter (apachelogger) wrote :

Now I am upset :P

The issue is caused by the automatic backport scripts, they usually don't adept dependencies.

Changed in amarok:
importance: Undecided → Medium
status: Incomplete → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package amarok - 2:1.4.8-0ubuntu3~gutsy1

---------------
amarok (2:1.4.8-0ubuntu3~gutsy1) gutsy-backports; urgency=low

  * Backport to Gutsy Gibbon
  * Build-Depend on libgpod-dev not libgpod-nogtk-dev (LP: #182631)

 -- Harald Sitter <email address hidden> Tue, 11 Mar 2008 18:56:29 +0100

Changed in amarok:
status: Triaged → Fix Released

Alf Eaton wrote:
> http://packages.ubuntu.com/gutsy-backports/amarok
>

Which explains why my rmadison never picked it up. Thanks apachelogger
for fixing this.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers