[FFe] Amarok 2.9.0 for Bionic

Bug #1756066 reported by Rik Mills on 2018-03-15
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
amarok (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned

Bug Description

Amarok have released a first non-beta version since 2013.

We currently have 2.8.0 in the archive.

Announcement and changes since the 2015 beta: https://amarok.kde.org/en/node/888

Nearly all bug fixes.

Announcement and changes 2.8.0 -> 2.8.90 (beta) we did not ship: https://amarok.kde.org/en/node/887

The new features seem to work: e.g: ascii analyser https://i.imgur.com/OUC99mi.png

Valorie Zimmerman of KDE's Team Amarok reported successful testing with the staged build in ppa:kubuntu-ppa/staging-misc

Should also fix the current archive FTBFS on s390x

I would note that due to lack of upstream releases and an unfinished Qt5/KF5 port, Kubuntu has switched to the Qt5 app Cantata for our default. The Qt4 Amarok has become an unseeded (iso or meta) leaf package for us at the moment. However it is still very popular, so would be great to get this mostly bugfix release into the bionic repos.

Marco Parillo (marco-parillo) wrote :

https://irclogs.ubuntu.com/2018/03/14/%23kubuntu-devel.html#t17:07

[17:07] <IrcsomeBot> <acheronuk> could people please test amarok 2.9.0 in ppa:kubuntu-ppa/staging-misc please
[17:09] <IrcsomeBot> <acheronuk> not even slighy suggesting shipping that kde4 version as our default, but having the new bugfix release in the repos as a fallback would look good

...

[20:13] <mparillo> I added ppa:kubuntu-ppa/staging-misc please, and successfully installed amarok 2.9.0. It brought in a bunch of dependencies, and when I ran the program, I successfully played Art of Nations.
[20:15] <mparillo> I was able to go to cool streams, and play something, and a Wikipedia link was displayed
[21:56] <acheronuk> mparillo: thanks

description: updated
Marco Parillo (marco-parillo) wrote :

https://irclogs.ubuntu.com/2018/03/14/%23kubuntu-council.txt

[17:07] <IrcsomeBot> <acheronuk> could people please test amarok 2.9.0 in ppa:kubuntu-ppa/staging-misc please
[17:08] <IrcsomeBot> <acheronuk> valorie: ^^^
[20:47] <valorie> oooo
[20:47] <valorie> I probably should purge it if I have it on this machine first though
[20:48] <valorie> right?
[20:48] <valorie> acheronuk: ^^^
[21:56] <acheronuk> It's a new version so upgrade should be ok
[22:09] <valorie> ah, ok
[22:09] <valorie> and yeah I have ppa-purge so it should be find
[22:09] <valorie> in a min
[22:31] <valorie> uh, how do I upgrade amarok and not everything else?
[22:31] <valorie> I specified amarok but it wants to upgrade lots of other stuff which I prefer not to do right now
[22:32] <valorie> ah, only-upgrade
[22:32] <valorie> got it
[22:33] <valorie> hmmm, maybe I need it all
[22:35] <valorie> going for it
[23:36] <valorie> ok, it's running, but it lost track of my music collection -- might not have set that up after I moved my music off the SSD and onto the HD on this machine

Rik Mills (rikmills) wrote :

https://irclogs.ubuntu.com/2018/03/15/%23kubuntu-devel.html#t03:44

[03:44] <valorie> acheronuk: my test was successful

I've tested on bionic. my test was successful

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in amarok (Ubuntu):
status: New → Confirmed

I can confirm that installation was successful, Amarok found and played my music. \o/

Steve Langasek (vorlon) wrote :

Low risk as a non-default leaf application, this appears worth doing. FFe granted.

Changed in amarok (Ubuntu Bionic):
status: Confirmed → Triaged
Rik Mills (rikmills) wrote :

Thank you.

Changed in amarok (Ubuntu Bionic):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package amarok - 2:2.9.0-0ubuntu1

---------------
amarok (2:2.9.0-0ubuntu1) bionic; urgency=medium

  [ Clive Johnston ]
  * New upstream beta release (2.8.90)
  * Move a few dev files to not-installed

  [ Rik Mills ]
  * New upstream release (2.9.0) (LP: #1756066)
  * Drop upstreamed kubuntu_mysqle_myisam_recover_options.diff
  * Build depend on liblz4-dev (LP: #1690637)
  * libav* build deps for ffmpeg
  * Disable build of mp3tunes service. FTBFS on bionic
  * Update install files and wrap-and-sort

 -- Rik Mills <email address hidden> Thu, 15 Mar 2018 23:30:20 +0000

Changed in amarok (Ubuntu Bionic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers