Add last.fm "recommendations" playlist

Bug #103227 reported by Mikael Nilsson on 2007-04-05
12
Affects Status Importance Assigned to Milestone
Amarok
Fix Released
Wishlist
amarok (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: amarok

Amarok does not have an entry under last.fm radio for "recommended radio"

It's easy to add, but an unexperienced user might find it hard to get the right URL which for me (user=m94mni) is

lastfm://user/m94mni/recommended/100

It *does* have Neighborhood radio:

lastfm://user/m94mni/neighbours

which is good.

Changed in amarok:
status: Unknown → Unconfirmed
Andrew Ash (ash211) wrote :

Closed per Mark Kretschmann (Amarok dev)'s request in the upstream bug.

Changed in amarok:
status: Unconfirmed → Rejected
Andrew Ash (ash211) wrote :

As the bug is worked in in kde-bugs #143868, its status will be updated here.

Daniel Hahler (blueyed) wrote :

I've created a patch for it and sent it upstream. From there it was only two commands to create a debdiff, so here you go.

Daniel Holbach (dholbach) wrote :

Daniel: that patch includes a build log. Does this need uploading?

Harald Sitter (apachelogger) wrote :

Please upload, we (as in: the Amarok team) will not include this feature before Amarok 2, since Amarok 1 is in feature and string freeze.

Daniel Hahler (blueyed) on 2008-04-02
Changed in amarok:
assignee: nobody → blueyed
status: Invalid → In Progress
Daniel Holbach (dholbach) wrote :

Can you please fix and update the patch?

Daniel Holbach (dholbach) wrote :

Brandon: can you look at the patch once it's updated?

Daniel Hahler (blueyed) wrote :

   * debian/patches/kubuntu_08_add_lastfm_recommended_radio.diff:
     Add lastfm recommended radio station (LP: #103227)
   * debian/patches/kubuntu_09_audio_mimetypes.diff:
     - Add mimetypes audio/flac and audio/ogg (LP: #201291)
     - Add x-content/audio-player mimetype (LP: #191475)
       I've not added x-content/audio-cdda, because that does not work
       reliably.

Changed in amarok:
importance: Undecided → Wishlist
status: In Progress → Triaged
Daniel Hahler (blueyed) wrote :

Re-diffed against new upload (1.4.9-0ubuntu1)

Harald Sitter (apachelogger) wrote :

About kubuntu_09_audio_mimetypes.diff:
Upstream, Jonathan Riddell and me agreed to not add x-content until it is approved by the freedesktop project. Otherwise the unapproved new oga mimetypes would have to be added as well, and probably a lot more unofficial stuff. Which makes the whole mimetype standards stuff quite pointless.

Daniel Hahler (blueyed) wrote :

Updated debdiff: removed x-content/audio-cdda (bug 191475) and diffed against new source package.

Changed in amarok:
assignee: blueyed → nobody
Changed in amarok:
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package amarok - 2:1.4.9.1-0ubuntu2

---------------
amarok (2:1.4.9.1-0ubuntu2) hardy; urgency=low

  [ Daniel Hahler]
  * debian/patches/kubuntu_08_add_lastfm_recommended_radio.diff:
    Add lastfm recommended radio station (LP: #103227)
  * debian/patches/kubuntu_09_audio_mimetypes.diff:
    - Add mimetypes audio/flac and audio/ogg (LP: #201291)

  [ Harald Sitter ]
  * Unbreak manual media device configuration by enhancing
    kubuntu_08_luks_device_detection.diff (LP: #207704)

 -- Harald Sitter <email address hidden> Sat, 12 Apr 2008 13:47:12 +0200

Changed in amarok:
status: Triaged → Fix Released
Changed in amarok:
importance: Unknown → Wishlist
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.