amanda-server: amreport crashes with segfault in file /usr/lib/amanda/perl/Amanda/Report/human.pm

Bug #1385976 reported by aboaboit on 2014-10-26
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
amanda (Debian)
Fix Released
Unknown
amanda (Ubuntu)
Undecided
Unassigned

Bug Description

The log sent after amdump completes is empty. Turns out this is due to a bug in amreport.
Same as bug https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=760846
Upstream has a patch that works for me: https://github.com/zmanda/amanda/commit/e810e1945909b5a55c3688d0b996a91f526ae1c6

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: amanda-server 1:3.3.6-1ubuntu2
ProcVersionSignature: Ubuntu 3.16.0-23.31-generic 3.16.4
Uname: Linux 3.16.0-23-generic x86_64
NonfreeKernelModules: fglrx
ApportVersion: 2.14.7-0ubuntu8
Architecture: amd64
CurrentDesktop: KDE
Date: Sun Oct 26 22:27:18 2014
EcryptfsInUse: Yes
InstallationDate: Installed on 2013-12-22 (308 days ago)
InstallationMedia: Kubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016.1)
SourcePackage: amanda
UpgradeStatus: Upgraded to utopic on 2014-10-26 (0 days ago)

aboaboit (andrea-borgia) wrote :
Changed in amanda (Debian):
status: Unknown → New
Changed in amanda (Debian):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in amanda (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.