amdump permission denied

Bug #1385883 reported by aboaboit
4
This bug affects 1 person
Affects Status Importance Assigned to Milestone
amanda (Debian)
Confirmed
Unknown
amanda (Fedora)
Fix Released
Critical
amanda (Ubuntu)
Undecided
Unassigned

Bug Description

Just upgraded from Kubuntu 14.04 to 14.10 and I get an error when running amdump, here is the exact error messag ("permesso negato" is the Italian for "permission denied")

-x-x-x-
backup@mononoke:~$ amdump DailySet1
Can't locate Tie/StdHash.pm: Permesso negato at /usr/share/perl/5.20/base.pm line 97.
        ...propagated at /usr/share/perl/5.20/base.pm line 106.
BEGIN failed--compilation aborted at /usr/lib/amanda/perl/Amanda/Config/FoldingHash.pm line 3.
Compilation failed in require at /usr/lib/amanda/perl/Amanda/Config.pm line 753.
BEGIN failed--compilation aborted at /usr/lib/amanda/perl/Amanda/Config.pm line 753.
Compilation failed in require at /usr/sbin/amdump line 29.
BEGIN failed--compilation aborted at /usr/sbin/amdump line 29.
-x-x-x-

cwd was my own home directory.
after changing to /tmp the problem went away.
when backup was done, I saw that there still is a /tmp/amanda directory.

This is quite likely the same as this Debian bug:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=760039

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: amanda-server 1:3.3.6-1ubuntu2
ProcVersionSignature: Ubuntu 3.16.0-23.31-generic 3.16.4
Uname: Linux 3.16.0-23-generic x86_64
NonfreeKernelModules: fglrx
ApportVersion: 2.14.7-0ubuntu8
Architecture: amd64
CurrentDesktop: KDE
Date: Sun Oct 26 15:02:56 2014
EcryptfsInUse: Yes
InstallationDate: Installed on 2013-12-22 (308 days ago)
InstallationMedia: Kubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016.1)
SourcePackage: amanda
UpgradeStatus: Upgraded to utopic on 2014-10-26 (0 days ago)

Revision history for this message
aboaboit (andrea-borgia-deactivatedaccount) wrote :
Revision history for this message
In , Trever (trever-redhat-bugs) wrote :

Description of problem:
bash-4.3$ amdump normal
Can't locate Tie/StdHash.pm: ./Tie/StdHash.pm: Permission denied at /usr/share/perl5/base.pm line 99.
 ...propagated at /usr/share/perl5/base.pm line 108.
BEGIN failed--compilation aborted at /usr/lib64/perl5/vendor_perl/Amanda/Config/FoldingHash.pm line 3.
Compilation failed in require at /usr/lib64/perl5/vendor_perl/Amanda/Config.pm line 753.
BEGIN failed--compilation aborted at /usr/lib64/perl5/vendor_perl/Amanda/Config.pm line 753.
Compilation failed in require at /usr/sbin/amdump line 29.
BEGIN failed--compilation aborted at /usr/sbin/amdump line 29.

bash-4.3$ amcleanup normal
Can't locate Tie/StdHash.pm: ./Tie/StdHash.pm: Permission denied at /usr/share/perl5/base.pm line 99.
 ...propagated at /usr/share/perl5/base.pm line 108.
BEGIN failed--compilation aborted at /usr/lib64/perl5/vendor_perl/Amanda/Config/FoldingHash.pm line 3.
Compilation failed in require at /usr/lib64/perl5/vendor_perl/Amanda/Config.pm line 753.
BEGIN failed--compilation aborted at /usr/lib64/perl5/vendor_perl/Amanda/Config.pm line 753.
Compilation failed in require at /usr/sbin/amcleanup line 26.
BEGIN failed--compilation aborted at /usr/sbin/amcleanup line 26.

Version-Release number of selected component (if applicable):
amanda-3.3.7p1-1.fc22.x86_64
amanda-client-3.3.7p1-1.fc22.x86_64
amanda-libs-3.3.7p1-1.fc22.x86_64
amanda-server-3.3.7p1-1.fc22.x86_64

Revision history for this message
In , Petr (petr-redhat-bugs) wrote :

There is a bug with the latest upstream version 3.3.8.
Could you please verify whether the bug is fixed?

Relevant scm-commit is http://pkgs.fedoraproject.org/cgit/rpms/amanda.git/commit/?h=f22&id=c6e090ceb846020b43893aaac1779faf3551a60e

If the bug is fixed, close the bug please.

Revision history for this message
In , Trever (trever-redhat-bugs) wrote :

This is a no go still.

bash-4.3$ amdump normal
Can't locate Tie/StdHash.pm: ./Tie/StdHash.pm: Permission denied at /usr/share/perl5/base.pm line 99.
 ...propagated at /usr/share/perl5/base.pm line 108.
BEGIN failed--compilation aborted at /usr/lib64/perl5/vendor_perl/Amanda/Config/FoldingHash.pm line 3.
Compilation failed in require at /usr/lib64/perl5/vendor_perl/Amanda/Config.pm line 753.
BEGIN failed--compilation aborted at /usr/lib64/perl5/vendor_perl/Amanda/Config.pm line 753.
Compilation failed in require at /usr/sbin/amdump line 29.
BEGIN failed--compilation aborted at /usr/sbin/amdump line 29.
bash-4.3$ exit
exit
[root@ ~]# rpm -qa | grep amanda | sort
amanda-3.3.8-1.fc23.x86_64
amanda-client-3.3.8-1.fc23.x86_64
amanda-libs-3.3.8-1.fc23.x86_64
amanda-server-3.3.8-1.fc23.x86_64

Revision history for this message
In , Fedora (fedora-redhat-bugs) wrote :

This package has changed ownership in the Fedora Package Database. Reassigning to the new owner of this component.

Revision history for this message
In , Josef (josef-redhat-bugs) wrote :

New upstream version of amanda (3.3.9) has been released.
Could you please verify whether the bug is fixed?

Relevant scm-commit is http://pkgs.fedoraproject.org/cgit/rpms/amanda.git/commit/?h=f23&id=007ffffec08a253feccd096f25a82000f5fd1a39

If the bug is fixed, close the bug please.

Revision history for this message
In , Trever (trever-redhat-bugs) wrote :
Download full text (4.2 KiB)

# dnf --enablerepo=updates-testing upgrade 'amanda*'
y
Fedora 24 - x86_64 - Test Updates 724 kB/s | 2.8 MB 00:03
Fedora 24 - x86_64 - Updates 1.3 MB/s | 13 MB 00:09
Last metadata expiration check: 0:00:23 ago on Mon Aug 1 17:54:10 2016.
Dependencies resolved.
=====================================================================================
 Package Arch Version Repository Size
=====================================================================================
Upgrading:
 amanda x86_64 3.3.9-1.fc24 updates-testing 253 k
 amanda-client x86_64 3.3.9-1.fc24 updates-testing 279 k
 amanda-libs x86_64 3.3.9-1.fc24 updates-testing 753 k
 amanda-server x86_64 3.3.9-1.fc24 updates-testing 574 k

Transaction Summary
=====================================================================================
Upgrade 4 Packages

Total download size: 1.8 M
Is this ok [y/N]: Downloading Packages:
(1/4): amanda-3.3.8-1.fc24_3.3.9-1.fc24.x86_64.drpm 105 kB/s | 115 kB 00:01
(2/4): amanda-libs-3.3.8-1.fc24_3.3.9-1.fc24.x86_64. 185 kB/s | 225 kB 00:01
(3/4): amanda-server-3.3.8-1.fc24_3.3.9-1.fc24.x86_6 136 kB/s | 264 kB 00:01
(4/4): amanda-client-3.3.9-1.fc24.x86_64.rpm 325 kB/s | 279 kB 00:00
[DRPM] amanda-3.3.8-1.fc24_3.3.9-1.fc24.x86_64.drpm: done
[DRPM] amanda-libs-3.3.8-1.fc24_3.3.9-1.fc24.x86_64.drpm: done
[DRPM] amanda-server-3.3.8-1.fc24_3.3.9-1.fc24.x86_64.drpm: done
-------------------------------------------------------------------------------------
Total 184 kB/s | 882 kB 00:04
Delta RPMs reduced 1.8 MB of updates to 0.9 MB (52.1% saved)
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Upgrading : amanda-libs-3.3.9-1.fc24.x86_64 1/8
  Upgrading : amanda-3.3.9-1.fc24.x86_64 2/8
  Upgrading : amanda-server-3.3.9-1.fc24.x86_64 3/8
  Upgrading : amanda-client-3.3.9-1.fc24.x86_64 4/8
  Cleanup : amanda-client-3.3.8-1.fc24.x86_64 5/8
  Cleanup : amanda-server-3.3.8-1.fc24.x86_64 6/8
  Cleanup : amanda-3.3.8-1.fc24.x86_64 7/8
  Cleanup : amanda-libs-3.3.8-1.fc24.x86_64 8/8
  Verifying : amanda-3.3.9-1.fc24.x86_64 1/8
  Verifying : amanda-libs-3.3.9-1.fc24.x86_64 2/8
  Verifying : amanda-server-3.3.9-1.fc24.x86_64 3/8
  Verifying : amanda-client-3.3.9-1.fc24.x86_64 4/8
  Verifying : amanda-3.3.8-1.fc24.x86_64 5/8
 ...

Read more...

Revision history for this message
In , Trever (trever-redhat-bugs) wrote :

Additionally, amdump now complains "'/usr/bin/tar' binary is not secure".

This appears to be an incorrect.

Revision history for this message
In , Fedora (fedora-redhat-bugs) wrote :

amanda-3.3.9-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-7b6f54ca75

Revision history for this message
In , Fedora (fedora-redhat-bugs) wrote :

amanda-3.3.9-2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-2acd2eed98

Revision history for this message
In , Josef (josef-redhat-bugs) wrote :

I have just added patch from upstream, which should solve described problem.

If the problem will not persist, please close this bug, otherwise I will looking for another solution.

Relevant scm-commit is: http://pkgs.fedoraproject.org/cgit/rpms/amanda.git/commit/?h=f24&id=222578a274145fd9dc6b74b3f0dcfa6424a30ce4

Revision history for this message
In , Fedora (fedora-redhat-bugs) wrote :

amanda-3.3.9-2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-2acd2eed98

Revision history for this message
In , Fedora (fedora-redhat-bugs) wrote :

amanda-3.3.9-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-7b6f54ca75

Revision history for this message
In , Trever (trever-redhat-bugs) wrote :

Ok, the original problem seems to be fixed.

http://wiki.zmanda.com/man/amanda-security.conf.5.html

Seems to suggest the file is NOT required if things are at the default locations and not symlinks. These conditions are true, but the file must exist.

Revision history for this message
In , Fedora (fedora-redhat-bugs) wrote :

amanda-3.3.9-3.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-9ff34eaec5

Revision history for this message
In , Fedora (fedora-redhat-bugs) wrote :

amanda-3.3.9-3.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-ee1a82a83e

Revision history for this message
In , Fedora (fedora-redhat-bugs) wrote :

amanda-3.3.9-3.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-ee1a82a83e

Revision history for this message
In , Fedora (fedora-redhat-bugs) wrote :

amanda-3.3.9-3.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-9ff34eaec5

Revision history for this message
In , Trever (trever-redhat-bugs) wrote :

Thank you. As far as I can tell, this bug (both parts) has/have now been fixed. Thank you very much!

Revision history for this message
In , Fedora (fedora-redhat-bugs) wrote :

amanda-3.3.9-3.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Revision history for this message
In , Fedora (fedora-redhat-bugs) wrote :

amanda-3.3.9-3.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Changed in amanda (Debian):
status: Unknown → New
Changed in amanda (Debian):
status: New → Confirmed
Changed in amanda (Fedora):
importance: Unknown → Critical
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.