known issue: amrecover - can't talk to tape server: service amidxtaped:

Bug #1074574 reported by zwigno on 2012-11-03
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
amanda (Debian)
Fix Released
Unknown
amanda (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned

Bug Description

When trying to recover data from a backup with amrecover following the guides at:

http://wiki.zmanda.com/index.php/GSWA/Build_a_Basic_Configuration
http://wiki.zmanda.com/index.php/GSWA/Recovering_Files

One eventually gets the error, "amrecover - can't talk to tape server: service amidxtaped" when trying to do a restore. This is a known bug in 1:3.3.0-1 and is fixed in 1:3.3.1-1. It's already fixed in Debian wheezy.
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=655025

Unfortunately wheezy requires a newer version of perl so the package isn't installable.

Since 12.04 is an LTS release can we get this package updated to the fixed version?

Secondarily,
The file /etc/xinetd.d/amanda only contains an entry for the main amanda service. It's missing definitions for amidxtape and amandaidx. They should look something like this:

service amidxtape
{
        socket_type = stream
 flags = IPv4
        protocol = tcp
        wait = no
        user = backup
        group = disk
        groups = yes
        server = /usr/lib/amanda/amidxtape
        disable = no
}
service amandaidx
{
        socket_type = stream
 flags = IPv4
        protocol = tcp
        wait = no
        user = backup
        group = disk
        groups = yes
        server = /usr/lib/amanda/amindexd
        disable = no
}

It looks like it's acceptable for all 3 definitions to be in the /etc/xinetd.d/amanda file

Logan Rosen (logan) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. However, I am closing it because the bug has been fixed in the latest development version of Ubuntu - Raring Ringtail.

This is a significant bug in Ubuntu. If you need a fix for the bug in previous versions of Ubuntu, please do steps 1 and 2 of the SRU Procedure [1] to bring the need to a developer's attention.

[1]: https://wiki.ubuntu.com/StableReleaseUpdates#Procedure

Changed in amanda (Ubuntu):
status: New → Fix Committed
status: Fix Committed → Fix Released
Changed in amanda (Debian):
status: Unknown → Fix Released
Lindsay (fmouse) wrote :

The fix for this bug should be bacported ASAP to precise (12.04 LTS) since it renders amanda useless as a functional backup package. The bug only shows up when amanda is needed most - when data has been lost and needs to be restored from backups, which is unacceptable for a LTS release used in production and enterprise environments. The SRU Procedure referred to by logan is very obscure and the page he links to is long on what and when, and short on exactly how to get this process going. Perhaps one of the Ubuntu team would be kind enough to undertake to escalate Bug #1077105 (which provides a fix) accordingly and put the fix into consideration for backporting to the LTS version.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in amanda (Ubuntu Precise):
status: New → Confirmed
Jakub Kalab (jakubkalab-n) wrote :

+1 for backporting this to 12.04 LTS, as @fmouse said 'it renders amanda useless as a functional backup package' and it shows up pretty late.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.