cannot upgrade package "alsa-utils"

Bug #664812 reported by LGB [Gábor Lénárt] on 2010-10-21
4
This bug affects 1 person
Affects Status Importance Assigned to Milestone
alsa-utils (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: alsa-utils

I got updates in maverick on package alsa-utils today (as proposed):

alsa-utils (1.0.23-2ubuntu3.3) maverick-proposed; urgency=low

  * debian/patches/add_omap4_support.patch: [Make sure
    alsactl/init/Makefile.am and alsactl/init/Makefile.in install the omap4
    file along with the other init files] (LP: #637947)
  * also init all OMAP4 devices once from postinst so that the state file is
    updated with proper initialization values (LP: #637947)

 -- Oliver Grawert <email address hidden> Thu, 21 Oct 2010 11:19:15 +0200

However I can't cleanly install it, since:

Unpacking replacement alsa-utils ...
Setting up alsa-utils (1.0.23-2ubuntu3.3) ...
dpkg: error processing alsa-utils (--install):
 subprocess installed post-installation script returned error exit status 1

Surely, editing file /var/lib/dpkg/info/alsa-utils.postinst and commenting out the "set -e" then doing "dpkg --configure -a" does the trick, but it is not an elegant solution I think .... :)

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: alsa-utils 1.0.23-2ubuntu3.3
ProcVersionSignature: Ubuntu 2.6.35-22.35-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Fri Oct 22 00:09:07 2010
EcryptfsInUse: Yes
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: alsa-utils

LGB [Gábor Lénárt] (lgb) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers