defaults need adjustment on dove X0 for audible audio

Bug #451635 reported by Paul Larson on 2009-10-14
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
alsa-lib (Ubuntu)
Undecided
Unassigned
Karmic
Undecided
Unassigned
Lucid
Undecided
Unassigned
alsa-utils (Ubuntu)
High
Daniel T Chen
Karmic
High
Unassigned
Lucid
High
Daniel T Chen
pulseaudio (Ubuntu)
Undecided
Daniel T Chen
Karmic
Undecided
Unassigned
Lucid
Undecided
Daniel T Chen

Bug Description

I've tried experimenting with using different ports and settings, and confirmed my settings with someone who had a Y0 board with sound working, but still unable to get any sound out of it.

ProblemType: Bug
Architecture: armel
Date: Wed Oct 14 15:55:39 2009
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Alpha armel+dove (20091014)
Package: alsa-base 1.0.20+dfsg-1ubuntu5
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-208.16-hostname
SourcePackage: alsa-driver
Uname: Linux 2.6.31-208-dove armv7l

Workaround:
This has been reported to work for some, but not all.
1. open System->Preferences->Sound
     On the Output tab, ensure that headphones are selected
2. Open alsamixer in a terminal, use the arrow keys to move right to "Line HP" and press the 'm' key to unmute it

Paul Larson (pwlars) wrote :
Loïc Minier (lool) on 2009-10-16
Changed in alsa-driver (Ubuntu):
importance: Undecided → Medium
Tobin Davis (gruemaster) wrote :

I am able to get audio working just fine using the 20091015 live image on Y1. By default, audio is muted. To unmute, I ran alsamixer in a terminal, and found that the main audio is enabled by unmuting the Headphone volume control. This enables audio through the RCA jacks on the board. To enable the headphone jack next to the serial port, you also need to enable Line HP. See attached screenshot (both audio and headphones are enabled).

Changed in alsa-driver (Ubuntu):
status: New → Invalid
Paul Larson (pwlars) wrote :

I've changed my settings to match yours, still doesn't work on my board. In any case, it shouldn't be necessary to do all of that manually in order to get sound working.

Changed in alsa-driver (Ubuntu):
status: Invalid → New
Paul Larson (pwlars) wrote :

updated

Paul Larson (pwlars) on 2009-10-28
description: updated
Loïc Minier (lool) wrote :

Michael, please confirm/infirm the workaround here; thanks!

tags: added: iso-testing

After discussing this bug with Tobin at UDS, I think this is an audio mixer element recognition issue with PulseAudio. I will take a look at the amixer output from the alsa-info.sh dump, and look at what Pulseaudio looks for in terms of mixer elements, and try and work out what is going on.

Luke

Here are the relevant sections from Paul's alsa-info.txt:

Simple mixer control 'Headphone',0
  Capabilities: pvolume pswitch pswitch-joined
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 31 [100%] [on]
  Front Right: Playback 31 [100%] [on]
...
Simple mixer control 'Line HP Swap',0
  Capabilities: pswitch
  Playback channels: Front Left - Front Right
  Mono:
  Front Left: Playback [on]
  Front Right: Playback [on]

Thanks to Tobin's comments above, it looks like changes (at least) need to be made to the mixer files for PA, src/modules/alsa/mixer/paths/analog-output-headphones.conf[0]. The following stanza should be added:

[Element Line HP Swap]
switch = mute

[0] http://git.0pointer.de/?p=pulseaudio.git;a=blob;f=src/modules/alsa/mixer/paths/analog-output-headphones.conf;h=2131cfe81e2f9a6481fff71ac2023d9cf98229d8;hb=refs/heads/stable-0.9.20

Paul Larson (pwlars) on 2010-02-26
Changed in alsa-driver (Ubuntu Lucid):
milestone: none → ubuntu-10.04-beta-1
Alexander Sack (asac) wrote :

we dont support Y1 anymore in lucid. also we have bug 528524 now.

Changed in alsa-driver (Ubuntu Lucid):
status: New → Invalid
Paul Larson (pwlars) wrote :

I believe this is still a separate bug that needs to be addressed, however I will edit the title to be more descriptive of the problem. Even on x0 model boards, alsamixer settings are not correctly defaulted and must be modified by hand before sound will work properly.

Changed in alsa-driver (Ubuntu Lucid):
status: Invalid → Confirmed
summary: - Sound not working on dove Y1 board
+ alsamixer defaults need adjustment on dove boards
Steve Langasek (vorlon) on 2010-03-23
Changed in alsa-driver (Ubuntu Lucid):
milestone: ubuntu-10.04-beta-1 → ubuntu-10.04-beta-2
Daniel T Chen (crimsun) on 2010-03-24
affects: alsa-driver (Ubuntu Lucid) → alsa-utils (Ubuntu Lucid)

Bumped to high, as this makes sound completely unusable on a default installation

Changed in alsa-utils (Ubuntu Lucid):
importance: Medium → High
Changed in alsa-utils (Ubuntu Karmic):
importance: Medium → High

mcasadevall@dawn:~$ cat .asoundrc
pcm.!default {
 type plug
 slave.pcm {
  type hw
  card 0
  device 2
 }
}

Daniel T Chen (crimsun) on 2010-03-25
summary: - alsamixer defaults need adjustment on dove boards
+ alsa defaults need adjustment on dove x0
summary: - alsa defaults need adjustment on dove x0
+ alsa defaults need adjustment on dove X0
Daniel T Chen (crimsun) on 2010-03-25
Changed in alsa-lib (Ubuntu Karmic):
status: New → Invalid
Changed in alsa-lib (Ubuntu Lucid):
status: New → Invalid

This bug was fixed in the package alsa-utils - 1.0.22-0ubuntu4

---------------
alsa-utils (1.0.22-0ubuntu4) lucid; urgency=low

  * Unmute 'Line HP Swap' for Dove boards (LP: #451635)
 -- Daniel T Chen <email address hidden> Tue, 23 Mar 2010 20:20:20 -0400

Changed in alsa-utils (Ubuntu Lucid):
status: Confirmed → Fix Released
Daniel T Chen (crimsun) on 2010-03-25
Changed in alsa-utils (Ubuntu Lucid):
assignee: nobody → Daniel T Chen (crimsun)
Tobin Davis (gruemaster) wrote :

While this is a good interim fix, the proper fix is to have pulse audio handle the swapping of HP and line out. I have so far been successful in getting the sound-applet to switch Line HP Swap on enabling the headphone port when selecting analog headphones, but have not been able to turn it off when reverting back to analog output.

Adding the following lines to /usr/share/pulseaudio/alsa-mixer/paths/analog-output-headphones.conf works to enable HP jack:
[Element Line HP Swap]
switch = on

Now I need to figure out which conf file to add the switch = off line to.

Daniel T Chen (crimsun) on 2010-03-26
Changed in pulseaudio (Ubuntu Lucid):
assignee: nobody → Daniel T Chen (crimsun)
summary: - alsa defaults need adjustment on dove X0
+ defaults need adjustment on dove X0 for audible audio
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pulseaudio - 1:0.9.22~0.9.21+stable-queue-32-g8478-0ubuntu13

---------------
pulseaudio (1:0.9.22~0.9.21+stable-queue-32-g8478-0ubuntu13) lucid; urgency=low

  [ Daniel T Chen ]
  * 0093-backport-fixes-stable-queue-head.patch: Backport the following
    changesets from the stable-queue branch:
    + a7c1778 (don't pick monitor sources automatically for role-based
               device selection).
    + e8b83fa (handle asyncns failure when IPv6 is not supported in the
               kernel).
  * 0096-lp453966-handle-digmic-pt2.patch: Raise the priority of the
    'Digital Mic 1' digital input source for newer Dell laptops.
    (LP: #453966)
  * 0096-lp451635-handle-dove-x0-line-hp-swap.patch: Add 'Line HP Swap'
    to the Headphone profile. (LP: #451635)
  * debian/control: Update Vcs-Bzr to point to new branch that uses pack
    repo format 2a.
 -- Daniel T Chen <email address hidden> Thu, 25 Mar 2010 21:58:46 -0700

Changed in pulseaudio (Ubuntu Lucid):
status: New → Fix Released
Tobin Davis (gruemaster) wrote :

Ok, this is a bug in pulseaudio. Here is the scenario:

Sound-Applet->Preferences Output tab currently lists two connectors: Analog Output and Analog Headphones. Making the following changes has these effects:

Adding the following:
 [Element Line HP Swap]
 required = any
 switch = on
 override-map.1 = all
 override-map.2 = all-left,all-right
to /usr/share/pulseaudio/alsa-mixer/paths/analog-output-headphones.conf will toggle the switch on when selecting "Analog Headphones" connector, however adding:
 [Element Line HP Swap]
 required = any
 switch = off
 override-map.1 = all
 override-map.2 = all-left,all-right
to /usr/share/pulseaudio/alsa-mixer/paths/analog-output.conf has no effect when selecting Analog Output.

Adding:
;;; 'Headphone Switch'

 [Element Line HP Swap]
 required = any
 switch = select
 override-map.1 = all
 override-map.2 = all-left,all-right

 [Option Line HP Swap:on]
 name = output-headphones
 priority = 10

 [Option Line HP Swap:off]
 name = output-speakers
 priority = 0
to the headphones.conf only changes the connectors list to Analog Output | Analog Headphones/output-headphones | Analog Headphones/output-speakers.

Adding the same lines to analog-output.conf only creates a similar list with Analog Headphones | Analog Output/output-headphones | Analog Output/output-speakers.

Ideally, a user should be able to select Analog Headphones and get the HP jack to work (similar to front panel HP jack on Intel boards). Selecting Analog Output should disable the switch, sending audio to the rear connectors (RCA jacks on dove board).

Daniel T Chen (crimsun) wrote :

Just to confirm, using only the switch lines (no required or override* lines) in analog-output-headphones and analog-output also fails?

Changed in pulseaudio (Ubuntu Lucid):
status: Fix Released → Confirmed
Tobin Davis (gruemaster) wrote :

Correct. Changing both files to only include the following lines has no effect in analog-output.conf (note - I tried both on and off):
 [Element Line HP Swap]
  switch = <on|off>

Daniel T Chen (crimsun) wrote :

Index: pulseaudio-0.9.22~0.9.21+stable-queue-32-g8478/src/modules/alsa/mixer/paths/analog-output-headphones.conf
===================================================================
--- pulseaudio-0.9.22~0.9.21+stable-queue-32-g8478.orig/src/modules/alsa/mixer/paths/analog-output-headphones.conf 2010-03-26 12:51:15.000000000 -0700
+++ pulseaudio-0.9.22~0.9.21+stable-queue-32-g8478/src/modules/alsa/mixer/paths/analog-output-headphones.conf 2010-03-26 13:22:26.000000000 -0700
@@ -51,6 +51,9 @@
 override-map.1 = all
 override-map.2 = all-left,all-right

+[Element Line HP Swap]
+switch = on
+
 ; This profile path is intended to control the first headphones, not
 ; the second headphones. But it should not hurt if we leave the second
 ; headphone jack enabled nonetheless.
Index: pulseaudio-0.9.22~0.9.21+stable-queue-32-g8478/src/modules/alsa/mixer/paths/analog-output.conf
===================================================================
--- pulseaudio-0.9.22~0.9.21+stable-queue-32-g8478.orig/src/modules/alsa/mixer/paths/analog-output.conf 2010-03-26 12:51:15.000000000 -0700
+++ pulseaudio-0.9.22~0.9.21+stable-queue-32-g8478/src/modules/alsa/mixer/paths/analog-output.conf 2010-03-26 14:08:57.000000000 -0700
@@ -44,6 +44,9 @@
 switch = off
 volume = off

+[Element Line HP Swap]
+switch = off
+
 ; This profile path is intended to control the default output, not the
 ; headphones. But it should not hurt if we leave the headphone jack
 ; enabled nonetheless.

Tobin Davis (gruemaster) wrote :

Got it working. Here's the required patch for the conf files. This supercedes all other patches in this bug report (including asound.state changes earlier). It can also be sru'd to karmic if desired. Tested on Dove X0 with Lucid and Dove Y1 with Karmic.

Tobin Davis (gruemaster) wrote :

Nevermind. Both patches are similar. Mine was from a different trunk.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pulseaudio - 1:0.9.22~0.9.21+stable-queue-32-g8478-0ubuntu14

---------------
pulseaudio (1:0.9.22~0.9.21+stable-queue-32-g8478-0ubuntu14) lucid; urgency=low

  * 0096-lp451635-handle-dove-x0-line-hp-swap.patch: Make the connector
    work as intended: if 'Analog Output' is selected in the dropdown,
    then 'Line HP Swap' is muted; if 'Analog Headphones' is selected,
    then 'Line HP Swap' is unmuted. This better fits existing speaker
    semantics and actually works. Many thanks to Tobin Davis for
    helping chase this one. Really closes (LP: #451635)
 -- Daniel T Chen <email address hidden> Fri, 26 Mar 2010 15:18:35 -0700

Changed in pulseaudio (Ubuntu Lucid):
status: Confirmed → Fix Released
Tobin Davis (gruemaster) wrote :

Closing the karmic bug to "Won't fix" as karmic is no longer supported. Bug was fixed in Lucid.

Changed in alsa-utils (Ubuntu Karmic):
status: New → Won't Fix
Changed in pulseaudio (Ubuntu Karmic):
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers