Karmic alpha: No audio with Creative Labs SB0400 Audigy2 card.

Bug #400629 reported by moma on 2009-07-17
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
alsa-utils (Ubuntu)
Low
Daniel T Chen
pulseaudio (Ubuntu)
Low
Daniel T Chen

Bug Description

Hello,

This is my second 64bit Karmic Alpha installation on this machine.
The problem is that there is no sound.

The audio card is
$ lspci | grep audio
04:02.0 Multimedia audio controller: Creative Labs SB0400 Audigy2 Value

This test does not produce any sound either
$ speaker-test -c 6 -D surround51 -t wav

$ alsactl init
Unknown hardware: "Audigy2" "SigmaTel STAC9750,51" "AC97a:83847650" "0x1102" "0x1001"

Please tell me if you need other information, log files etc.

moma (osmoma) wrote :

I did a new installation of 64bit Karmic Alpha3.
No sound.

Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: moma 4265 F.... pulseaudio
 /dev/snd/controlC1: moma 4265 F.... pulseaudio
 /dev/snd/pcmC1D0p: moma 4265 F...m pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xfebf8000 irq 22'
   Mixer name : 'Analog Devices AD1988'
   Components : 'HDA:11d41988,104381e1,00100400'
   Controls : 48
   Simple ctrls : 27
Card1.Amixer.info:
 Card hw:1 'Audigy2'/'SB Audigy 2 Value [SB0400] (rev.0, serial:0x10011102) at 0xbc00, irq 23'
   Mixer name : 'SigmaTel STAC9750,51'
   Components : 'AC97a:83847650'
   Controls : 201
   Simple ctrls : 36
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: nvidia
Package: alsa-base 1.0.20+dfsg-1ubuntu4
PackageArchitecture: all
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-5.24-generic
Uname: Linux 2.6.31-5-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

moma (osmoma) wrote :
moma (osmoma) wrote :
moma (osmoma) wrote :
moma (osmoma) wrote :
moma (osmoma) wrote :
moma (osmoma) wrote :
moma (osmoma) wrote :
moma (osmoma) wrote :
moma (osmoma) wrote :
moma (osmoma) wrote :
moma (osmoma) wrote :
moma (osmoma) wrote :
tags: added: apport-collected
hype (hypeuser-lp) wrote :

I have the same sound card, same issue, but there's a "workaround" using alsamixer:
-start alsamixer from terminal (is there an easy way to get a gui?)
-just unmute the IEC958 0 track using the "m" key

I have no idea how to have this set up automatically.

Btw, the only way to get access to the sound card's equalizer is from alsamixer, which is absolutly not convinient.
I really hope we will get back full access to every options from a simple gui.

moma (osmoma) wrote :

Thank you very much.
I used "gnome-alsamixer" to uncheck the "IEC958 Optical Raw" value + activated the "Audigy Analog/Digital Output Jack" option and sound it is. Got sound!

See the attached picture.

affects: gst-plugins-good0.10 (Ubuntu) → ubuntu
tags: added: needs-reassignment
hype (hypeuser-lp) wrote :

Is anyone still having this issue?
i've seen update to the kernel, pulseaudio, but i still have to go through alsamixer to unmute the IEC958 channel in order to get sound working.

moma (osmoma) wrote :

Hello,

I can confirm this.
After each boot I have to uncheck the "IEC958 Optical Raw" option to get sound.

This is a very annoying bug.

Daniel T Chen (crimsun) wrote :

Please note that "fixing" this bug would completely invalidate an entire class of Audigy users who require that precise mixer element to be _muted_ in order to get sound; see bug 408370.

This bug, really, is no different to the old Audigy Analog/Digital Output debacle.

affects: ubuntu → alsa-utils (Ubuntu)
Changed in alsa-utils (Ubuntu):
assignee: nobody → Daniel T Chen (crimsun)
importance: Undecided → Low
status: New → Triaged
hype (hypeuser-lp) wrote :

Well, the thing is that i feel totally invalidated as this sound card used to work perfectly with previous versions of Ubuntu.

And by the way, the only way to get it working is to go through alsamixer, which is a "old" ncurse cli application, to unmute the proper channel.
 I think ideally, this should be working straight away. (as it did in previous versions)

Is there at least a workaround to not have to systematically by hand navigate through the 15 channels present in alsamixer to find the IEC598 channel and unmute it?

The thing is: if you want to be able to get the sound card's internal equalizer (that i often use because of my subwoofer that go way louder if bass are at "normal" level), you NEED to activate IEC598 channel. If you enable Audigy Analog/Digital Output Jack, the dont have the equalizer anymore.

 Ho, and if you dont know that the "m" key is the proper shortcut to unmute a channel, there's simply no information about it in alsamixer.

On Fri, Sep 4, 2009 at 12:54 PM, hype<email address hidden> wrote:
> And by the way, the only way to get it working is to go through alsamixer, which is a "old" ncurse cli application, to unmute the proper channel.

You could use, e.g., gnome-alsamixer.

>  I think ideally, this should be working straight away. (as it did in previous versions)

Sure, I understand the pain. No one wins. I suggest smacking Creative
with a trout.

> Is there at least a workaround to not have to systematically by hand
> navigate through the 15 channels present in alsamixer to find the IEC598
> channel and unmute it?

Do you mean IEC958 or IEC958 Optical Raw? They are very (i.e.,
significantly) different mixer elements with very (i.e.,
significantly) different semantics.

hype (hypeuser-lp) wrote :

/me feels retarded

Ok, i was totally wrong.
When i said that i needed to unmute IEC598, i was actually MUTING it !
I was willing to make some tests to check again...and noticed the status of the "Item: IEC958 Optical Raw [Off] "
So i'm actually muting IEC958 Optical Raw to get sound.

Then we both agree. :)

So, i reverse my question: is there a workaround to mute (!!) IEC958 Optical Raw at startup ? :p

Thanks again mate.

Ps: in previous version of Ubuntu, when you clicked on the speaker icon, you got an equivalent of gnome-alsamixer, which was very convinient as i often use the equlizer depending if i use speakers or headphones.
Now, if i click on the sound icon and select "Sound preference", i have no access to this equalizer.

Daniel T Chen (crimsun) wrote :

It's already set to mute it for new installs. See the changelog for alsa-utils (and the bug report I referenced above).

I will add this to the init db for alsa-utils and send upstream.

Daniel T Chen (crimsun) on 2009-09-17
Changed in pulseaudio (Ubuntu):
importance: Undecided → Low
assignee: nobody → Daniel T Chen (crimsun)
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pulseaudio - 1:0.9.17-0ubuntu2

---------------
pulseaudio (1:0.9.17-0ubuntu2) karmic; urgency=low

  * debian/patches/:
    + 0051-fix-sigfpe-mcalign.patch: Handle div by zero attempts
      (LP: #412224)
    + 0052-backport-56b6e18030.patch: Backport fixes from git HEAD
      (56b6e18030b5a467946bd0a5803ec119efccdc8a)
    + 0053-fix-output-element.patch: Fix misspelling of Surround
    + 0054-mute-iec958-optical-raw-for-audigyX.patch: Mute
      IEC958 Optical Raw by default (LP: #400629, #408370)

 -- Daniel T Chen <email address hidden> Thu, 17 Sep 2009 19:57:15 -0400

Changed in pulseaudio (Ubuntu):
status: Fix Committed → Fix Released
Daniel T Chen (crimsun) on 2010-01-28
Changed in alsa-utils (Ubuntu):
status: Triaged → Won't Fix
komputes (komputes) wrote :

The bug may have been fixed but we have gotten multiple reports that the sound card does not work out of the box (10.04 and 10.10).

02:06.0 Creative Labs SB0400 Audigy2 Value [1102:0008]
Kernel driver in use: EMU10K1_Audigy
Kernel modules: snd-emu10k1
Codec: STAC9750-51

After searching the forums [1], it seems that the sound card requires the following setup in ALSA (see screenshots).

[1] http://ubuntuforums.org/showpost.php?p=7783967&postcount=7

komputes (komputes) wrote :
To post a comment you must log in.