Ubuntu

Fix for Speaker swtich not on by default with Thinkpad T61/X61

Reported by Jerone Young on 2008-02-09
2
Affects Status Importance Assigned to Milestone
alsa-utils (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: alsa-utils

On Thinkpad T61/X61 or any other notebook using the AD1984 sound card. There is a lot of confusion as no noise comes out of the speaker even though PCM is at Maximum volume. The issue here is that the AD1984 now has a switch for "Headphone" & "Speaker". But having this switch cut on in the init script this resolves this issue and has sound coming out of the speakers & head phone jack.

Has been tested and will finally have these just work on Thinkpad T61.

This clears up a lot of issues, just googling around you can see users need this problem fixed.

This patch is for "/etc/init.d/alsa-utils":

Signed-off-by: Jerone Young <email address hidden>

--- /etc/init.d/alsa-utils.OLD 2008-02-09 01:17:09.000000000 -0600
+++ /etc/init.d/alsa-utils 2008-02-09 01:49:27.000000000 -0600
@@ -161,6 +161,10 @@

         mute_and_zero_level "Mic"
         mute_and_zero_level "IEC958" # Ubuntu #19648
+
+ # AD1984 -- Thinkpad T61/X61
+ switch_control "Speaker" on
+ switch_control "Headphone" on

         # Intel P4P800-MX (Ubuntu bug #5813)
         switch_control "Master Playback Switch" on

Related branches

Jerone Young (jerone) wrote :

Oh also this is issue effects both Hardy & Gutsy .. but I assume this will go forward toward for Hardy.

Hi,

Please submit patches against the debian source: debian/alsa-utils.init
in the future. Thanks.

William

On Sat, 2008-02-09 at 07:49 +0000, Jerone Young wrote:
> Public bug reported:
>
> Binary package hint: alsa-utils
>
> On Thinkpad T61/X61 or any other notebook using the AD1984 sound card.
> There is a lot of confusion as no noise comes out of the speaker even
> though PCM is at Maximum volume. The issue here is that the AD1984 now
> has a switch for "Headphone" & "Speaker". But having this switch cut on
> in the init script this resolves this issue and has sound coming out of
> the speakers & head phone jack.
>
> Has been tested and will finally have these just work on Thinkpad T61.
>
> This clears up a lot of issues, just googling around you can see users
> need this problem fixed.
>
> This patch is for "/etc/init.d/alsa-utils":
>
> Signed-off-by: Jerone Young <email address hidden>
>
> --- /etc/init.d/alsa-utils.OLD 2008-02-09 01:17:09.000000000 -0600
> +++ /etc/init.d/alsa-utils 2008-02-09 01:49:27.000000000 -0600
> @@ -161,6 +161,10 @@
>
> mute_and_zero_level "Mic"
> mute_and_zero_level "IEC958" # Ubuntu #19648
> +
> + # AD1984 -- Thinkpad T61/X61
> + switch_control "Speaker" on
> + switch_control "Headphone" on
>
> # Intel P4P800-MX (Ubuntu bug #5813)
> switch_control "Master Playback Switch" on
>
> ** Affects: alsa-utils (Ubuntu)
> Importance: Undecided
> Status: New
>

Daniel T Chen (crimsun) wrote :

This fix is incomplete, as it doesn't twit the appropriate element in mute_and_zero_levels_on_card(), too. I've fixed this in 1.0.15-3ubuntu1.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package alsa-utils - 1.0.15-3ubuntu1

---------------
alsa-utils (1.0.15-3ubuntu1) hardy; urgency=low

  * Merge from Debian unstable, remaining changes:
    - Packaging:
      + no alsaconf,
      + Vcs-Bzr (updated URI), lpia arch, maintainer field munging,
      + toggle additional mixer elements in initscript: in addition to
        the fix in 1.0.15-3 for Thinkpad T61/X61, also twit the control
        in mute_and_zero_levels_on_card() (LP: #190393).

 -- Daniel T Chen <email address hidden> Sun, 10 Feb 2008 09:41:23 +0000

Changed in alsa-utils:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers