Settings made by qasmixer are lost on next reboot

Bug #1799580 reported by Aere Greenway on 2018-10-23
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
alsa-utils (Ubuntu)
Medium
Unassigned

Bug Description

I use qasmixer to set the "Synth" volume to full, on my SoundBlaster Live sound-card.

On prior levels of Ubuntu (through 18.04), any settings I make are preserved over reboots.

On the latest level of Ubuntu (18.10) the settings are effective only as long as the system is running. The next time I reboot, the settings are gone, and I have to use qasmixer to set them all over again.

I expected the settings made by qasmixer to be preserved on the next reboot, as with past levels of Ubuntu.

The settings made by qasmixer are not preserved over a reboot on Ubuntu 18.10.

ProblemType: Bug
DistroRelease: Ubuntu 18.10
Package: qasmixer 0.21.0-1.1
ProcVersionSignature: Ubuntu 4.18.0-10.11-generic 4.18.12
Uname: Linux 4.18.0-10-generic i686
ApportVersion: 2.20.10-0ubuntu13
Architecture: i386
CurrentDesktop: LXQt
Date: Tue Oct 23 14:59:06 2018
InstallationDate: Installed on 2018-10-23 (0 days ago)
InstallationMedia: Lubuntu 18.10 "Cosmic Cuttlefish" - Release i386 (20181017.2)
SourcePackage: qastools
UpgradeStatus: No upgrade log present (probably fresh install)

Aere Greenway (aere) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in qastools (Ubuntu):
status: New → Confirmed
Terry Belton (tezzy) wrote :

I am using a stock Ubuntu Studio 20.04 on a Dell Optiplex 3020.

After every cold start or reboot the left channel returns to 0% volume.

I don't believe this is a bug with qastools since it simply tells alsa what to do. Also, the issue can be duplicated on alsamixer. qasmixer itself doesn't save anything, neither does alsamixer. Something somewhere isn't remembering between reboots, but it's definitely not qastools related.

Changed in alsa-utils (Ubuntu):
status: New → Confirmed
no longer affects: qastools (Ubuntu)
Changed in alsa-utils (Ubuntu):
importance: Undecided → Medium
Mauro Gaspari (ilvipero) wrote :

I noticed the same bug affecting me on 3 installs:

1. Ubuntu Budgie 20.04 with Ubuntu Studio tools. Desktop, USB audio interface.
2. Ubuntu Budgie 20.04 with Ubuntu Studio tools. Laptop, Internal Audio card.
3. Ubuntu Studio 20.10 daily. Desktop, USB audio interface.

I do not think the issue is specifically of QASmixer. I tried to manipulate ALSA volume settings using alsamixer and and alsactl store, both with normal user and using sudo. Volume settings persist in the session, if I close and reopen QASmixer or alsamixer, but all volume settings are reset on reboot.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers