alsa-utils does not store and restore alsa settings on boot reboot

Bug #1567993 reported by Len Ovens on 2016-04-08
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
alsa-utils (Ubuntu)
High
Unassigned
systemd (Ubuntu)
High
Unassigned

Bug Description

The standard run level seems to have changed from run level 2 to run level 5 in 16.04. /etc/init.d/alsa-utils does not have a symlink in rc5.d and so does not run and store and restore alsa settings on shutdown/boot.

Most internal audio interfaces are set to some reasonable level by pulse on login. However, some (semi)pro audio interfaces like the ice1712 based interfaces are not controlled by pulseaudio but just fed audio in. This means that the user has to reset the alsa level at every boot.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: alsa-utils 1.1.0-0ubuntu2
ProcVersionSignature: Ubuntu 4.4.0-17.33-lowlatency 4.4.6
Uname: Linux 4.4.0-17-lowlatency x86_64
ApportVersion: 2.20.1-0ubuntu1
Architecture: amd64
CurrentDesktop: XFCE
Date: Fri Apr 8 07:56:32 2016
InstallationDate: Installed on 2016-03-24 (14 days ago)
InstallationMedia: Ubuntu-Studio 16.04 LTS "Xenial Xerus" - Beta amd64 (20160323)
SourcePackage: alsa-utils
UpgradeStatus: No upgrade log present (probably fresh install)

Len Ovens (len-ovenwerks) wrote :
Len Ovens (len-ovenwerks) wrote :

On further checking, I find alsa-utils is not in rc2.d either, but in rcS.d, expected to run before final run level.

Kaj Ailomaa (zequence) on 2016-04-08
Changed in alsa-utils (Ubuntu):
status: New → Confirmed
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1567993

tags: added: iso-testing
Len Ovens (len-ovenwerks) wrote :

in /var/log/syslog I find systemd-udevd[400]: Process '/usr/sbin/alsactl -E HOME=/run/alsa restore 0' failed with exit code 99. Hmm, nothing to do with run levels perhaps.

The directory /run/alsa does not exist.

Normally /etc/init.d/alsa-utils would create this directory at run time.

My understanding was that systemd, like upstart, would also run legacy init.d scripts where needed, this does not seem to be the case.

Changed in alsa-utils (Ubuntu):
status: Confirmed → New
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in systemd (Ubuntu):
status: New → Confirmed
Henk Terhell (hterhell) wrote :

Besides needing to install pavucontrol to get sound, I now need start alsamixer from CLI after each boot to select sound card with F6 and point to my digital USB audio speakers. This bug was not present some days ago as alsamixer retained its settings then.
This on Lubuntu 16.04 Xenial amd64 daily 20160408

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package alsa-utils - 1.1.0-0ubuntu3

---------------
alsa-utils (1.1.0-0ubuntu3) xenial; urgency=medium

  * Create the /run/alsa directory before running alsactl, so that alsactl
    doesn't fail (LP: #1567993)

 -- Luke Yelavich <email address hidden> Mon, 11 Apr 2016 11:25:20 +1000

Changed in alsa-utils (Ubuntu):
status: Confirmed → Fix Released
Henk Terhell (hterhell) wrote :

Update of alsa-utils received in Lubuntu Xenial AMD-64 today, however alsamixer still doesn't retain sound card settings for USB. After each boot alsamixer have to be opened and settings changed.

Could you possibly get me any relevant log data from syslog or journalctl related to alsamixer so I might take a look?

Thanks.

Henk Terhell (hterhell) wrote :

System is https://gist.github.com/8fc92845f99e05e52769
Will report later on syslog and journalctl
Had reinstalled completely Lubuntu Xenial with ISO 20160412 but is the same.

Henk Terhell (hterhell) wrote :

syslog attached

Henk Terhell (hterhell) wrote :

journalctl attached

Len Ovens (len-ovenwerks) wrote :

I confirm that it still doesn't work for me either. I did try manually creating /run/alsa/ but that did not work either. The directory seems to vanish on reboot... perhaps because /run is created at boot. That would indicate that alsa-utils needs to create this directory at each boot.

Changed in alsa-utils (Ubuntu):
status: Fix Released → Confirmed
Len Ovens (len-ovenwerks) wrote :

synaptic says I have alsa-utils (1.1.0-0ubuntu4)

Luke Yelavich (themuso) wrote :

Do either of you have a /var/lib/alsa/asound.state file?

Seems the alsa-restore service doesn't even get run if this file doesn't exist.

Len Ovens (len-ovenwerks) wrote :

 >> "Do either of you have a /var/lib/alsa/asound.state file?"

Not here. The directory exists, but no file inside.

Henk Terhell (hterhell) wrote :

Also I have an empty /var/lib/alsa directory

Changed in alsa-utils (Ubuntu):
importance: Undecided → High
Changed in systemd (Ubuntu):
importance: Undecided → High
Luke Yelavich (themuso) wrote :

Ok, I am pretty sure I have a fix, will upload.

Thanks for your help.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package alsa-utils - 1.1.0-0ubuntu5

---------------
alsa-utils (1.1.0-0ubuntu5) xenial; urgency=medium

  * Stop applying systemd_restore_condition.patch. On pure ALSA systems
    this prevents alsa volume state from being saved to disk on shutdown
    or reboot. (LP: #1567993)

 -- Luke Yelavich <email address hidden> Fri, 15 Apr 2016 09:28:51 +1000

Changed in alsa-utils (Ubuntu):
status: Confirmed → Fix Released
Henk Terhell (hterhell) wrote :

Thanks a lot, on my system it works fine now!

Len Ovens (len-ovenwerks) wrote :

Fix confirmed here too. Thank you.

Changed in systemd (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers