udev alsa restore restore rules are broken

Bug #1268301 reported by Alistair Buxton on 2014-01-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
alsa-utils (Ubuntu)
Undecided
Luke Yelavich

Bug Description

To reproduce:

1. Run the following command: udevadm test --action=add /class/sound/controlC0 2>/dev/null | grep alsactl

Expected output:

run: '/usr/sbin/alsactl restore 0'

Actual output:

run: '/usr/sbin/alsactl restore '

Note the missing '0' - this causes alsactl to restore the levels on all cards instead of the one that was just plugged in. The rules file looks like this:

TEST!="/var/lib/alsa/state-daemon.conf", RUN+="/usr/sbin/alsactl restore $attr{number}"

This has not changed since raring (where this stuff works correctly). Under saucy the $attr{number} macro expands to empty string.

udevadm info --query=all --path=/class/sound/controlC0 --attribute-walk outputs exactly the same attributes on both saucy and raring.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: alsa-utils 1.0.27.1-1ubuntu1 [modified: lib/udev/rules.d/90-alsa-restore.rules usr/sbin/alsactl]
Uname: Linux 3.11.0-031100-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.12.5-0ubuntu2.2
Architecture: amd64
Date: Sun Jan 12 13:06:47 2014
InstallationDate: Installed on 2013-08-27 (137 days ago)
InstallationMedia: Xubuntu 13.10 "Saucy Salamander" - Alpha amd64 (20130827)
MarkForUpload: True
SourcePackage: alsa-utils
UpgradeStatus: No upgrade log present (probably fresh install)

Alistair Buxton (a-j-buxton) wrote :
Alistair Buxton (a-j-buxton) wrote :

Also affects trusty

tags: added: trusty
Alistair Buxton (a-j-buxton) wrote :

No upstream bug URL, but a patch has been sent to alsa-devel to fix this issue: http://mailman.alsa-project.org/pipermail/alsa-devel/2014-January/071156.html

Luke Yelavich (themuso) wrote :

I'll get this in for trusty. However, I am not sure this is severe enough for a saucy SRU.

Changed in alsa-utils (Ubuntu):
assignee: nobody → Luke Yelavich (themuso)
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package alsa-utils - 1.0.27.2-1ubuntu2

---------------
alsa-utils (1.0.27.2-1ubuntu2) trusty; urgency=medium

  * Forgot to add an env declaration for an environment variable to the
    upstart files. (LP: #1269731)
  * debian/patches/work_around_ncurses_weirdness.patch:
    - Work around some ncurses pkg-config changes for now, not sure if ncurses
      upstream intended the include dir changes, or whether its a bug. Fixes
      FTBFs.
 -- Luke Yelavich <email address hidden> Fri, 17 Jan 2014 15:08:13 +1100

Changed in alsa-utils (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers