No hdspmixer in alsa-tools-gui (1.0.24.1-0ubuntu1)

Bug #891390 reported by sonicwarrior on 2011-11-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
alsa-tools (Ubuntu)
Undecided
Unassigned

Bug Description

/usr/bin/hdspmixer is missing in the amd64 package alsa-tools-gui (1.0.24.1-0ubuntu1) which is used by Natty (11.04) and Oneiric (11.10):
http://packages.ubuntu.com/natty/amd64/alsa-tools-gui/filelist
http://packages.ubuntu.com/oneiric/amd64/alsa-tools-gui/filelist

This leads to a non-working soundcard. The workaround is to use the older 1.0.23 package from Maverick (10.10):
http://packages.ubuntu.com/maverick/amd64/alsa-tools-gui/filelist

Manually compiling the hdspmixer from 1.0.24.1 leads to bug
https://bugtrack.alsa-project.org/alsa-bug/view.php?id=5329

Using the sid version 1.0.24.1-3 results in a crash when I select a menu entry:
https://bugtrack.alsa-project.org/alsa-bug/view.php?id=5481

Related branches

Jason Conti (jconti) wrote :

hdspmixer isn't building in precise either. Adding a branch which just adds a build-dep on dh-autoreconf and allows hdspmixer to build.

I'm not sure whether the crashes listed above are fixed, since I don't seem to have a supported sound card (running hdspmixer just prints out "No RME cards founds.") So that will still need testing.

Changed in alsa-tools (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package alsa-tools - 1.0.24.1-2ubuntu2

---------------
alsa-tools (1.0.24.1-2ubuntu2) precise; urgency=low

  * debian/control:
    - Add build-dep on dh-autoreconf so the changes in
      cb40769c-hdsp-massive-fixes.patch build. (LP: #891390)
 -- Jason Conti <email address hidden> Tue, 17 Jan 2012 15:08:38 -0500

Changed in alsa-tools (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers