Ubuntu

/usr/bin/hdspmixer is missing

Reported by David Kastrup on 2011-02-22
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
alsa-tools (Ubuntu)
Medium
Daniel T Chen
Natty
Medium
Unassigned
Oneiric
Medium
Daniel T Chen

Bug Description

Binary package hint: alsa-tools-gui

Suddenly /usr/bin/hdspmixer has gone missing. Its documentation is still there.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: alsa-tools-gui 1.0.24.1-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-3.30~ppa1-lowlatency 2.6.38-rc3
Uname: Linux 2.6.38-3-lowlatency i686
Architecture: i386
Date: Tue Feb 22 18:18:28 2011
ProcEnviron:
 LANGUAGE=en_US.UTF-8:en
 PATH=(custom, user)
 LANG=en_US.UTF-8
 LC_MESSAGES=en_AG.utf8
 SHELL=/bin/bash
SourcePackage: alsa-tools

David Kastrup (dak) wrote :
David Kastrup (dak) wrote :

That's not exactly unimportant. The RME Hammerfall DSP contains a cross-bar configuration with lots of inputs and outputs. The crossbar is initialized to zeros by default (usual safety measure). When using the Hammerfall for sound output, one needs to open more than just the volume control for PCM output: one needs to route the output to some physical output via the crossbar as well.

The only user-available application for doing that is hdspmixer. Without hdspmixer, the soundcard is basically useless.

There is an obscure way for using alsactl for accessing crossbar elements write-only. But that is only accessible to scripts and the command line (or C programming).

mokabar (tim-klingt) wrote :

rebuilding alsa-tools, gives me hdspmixer as part of the alsa-tools-gui package.

however it tells me:
Uninitialized HDSP card found.
Use hdsploader to upload configuration data to the card.

the card can be opened by hdspconf and jack, though

David Kastrup (dak) wrote :

The binary version distributed with natty is still without hdspmixer, and this bug is not even marked as "Confirmed" even though the absence of the file is trivial to verify.

Patrick le Roux (pleroux-gmail) wrote :

Rebuilding alsa-tools from snapshot 1.0.24.1.43.gcb407 works. hdspmixer loads and seems to work correctly.

http://www.alsa-project.org/snapshot/

mokabar (tim-klingt) wrote :

there have been some changes in hdspmixer ... iirc older releases won't work with newer kernel ... updating to a recent snapshot may be required.
lets just hope that a usable version of hdspmixer will be included in natty

David Kastrup (dak) wrote :

You may hope for whatever you want, but the release date of natty is _today_.

mokabar (tim-klingt) wrote :

... from my experience, earlier releases were in a better shape than natty ... :/

David Kastrup (dak) wrote :

Actually, I found that rebuilding alsa-tools-gui via apt-get from the _current_ source package of natty works on my system.

So it would appear that either the distributed binaries were built on a faulty machine, or the dependencies are incomplete so that the build process failed on the Ubuntu build machine but succeeded on mine (which is running just natty).

What is the required process to have someone trigger a rebuild of the distributed binary package for natty without changing the source package (apart possibly from bumping the version)?

David Kastrup (dak) wrote :

Let me take that back. Building the package like this results in executables that complain about a busy device even when there is nothing contending for that device. So the current natty source does not help in creating a working alsamixer executable.

It still is mysterious to me why the natty binary package does not contain an alsamixer executable: even though it would not work, the normal build process should have produced and included one.

For now I stay with using the previous alsa-tools-gui package from Debian sid.

zob (zob) wrote :
Download full text (3.4 KiB)

I can confirm the but in the ubuntu 11.04 package build.

Everything seems to be fine, modules loaded and stuff. But I can't find the hdspmixer.
Normally it's included in the alsa-tools and alsa-tools-gui packages. And actually the mixer GUI does get an entry in the menu. But there is no command for it to execute. It is supposed to run hdspmixer - but it's not there.
If I write "hdsp" and try to autocomplete with tab in the terminal, I can now only se hdsploader and hdspconf (both seem to run just fine btw.).

From lspci
02:09.0 Multimedia audio controller: Xilinx Corporation RME Hammerfall DSP (rev 9a)

From lshw:
 description: Multimedia audio controller
       product: RME Hammerfall DSP
       vendor: Xilinx Corporation
       physical id: 9
       bus info: pci@0000:02:09.0
       version: 9a
       width: 32 bits
       clock: 33MHz
       capabilities: bus_master
       configuration: driver=RME Hammerfall DSP latency=255
       resources: irq:19 memory:fdff0000-fdffffff

uname -a:
Linux lars-desktop 2.6.38-8-generic #42-Ubuntu SMP Mon Apr 11 03:31:50 UTC 2011 i686 athlon i386 GNU/Linux

Version of alsa-tools:
 *** 1.0.24.1-0ubuntu1 0

Version of alsa-firmware-loaders:
*** 1.0.24.1-0ubuntu1 0

cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version 1.0.23.

cat /proc/asound/cards
 0 [DSP ]: H-DSP - Hammerfall DSP
                      RME Hammerfall HDSP 9632 at 0xfdff0000, irq 19

cat /proc/asound/modules
 0 snd_hdsp

cat /proc/asound/DSP/hdsp
RME Hammerfall HDSP 9632 (Card #1)
Buffers: capture f2400000 playback f2600000
IRQ: 19 Registers bus: 0xfdff0000 VM: 0xf819c000
Control register: 0x300409a
Control2 register: 0x0
Status register: 0x32000000
Status2 register: 0xffff8701
FIFO status: 0
MIDI1 Output status: 0xffffff00
MIDI1 Input status: 0xffffff00
MIDI2 Output status: 0xffffff00
MIDI2 Input status: 0xffffff00
Use Midi Tasklet: on

Buffer Size (Latency): 2048 samples (2 periods of 8192 bytes)
Hardware pointer (frames): 0
Precise pointer: off
Line out: on
Firmware version: 1

Sample Clock Source: Internal 44.1 kHz
Preferred Sync Reference: ADAT1
AutoSync Reference: None
AutoSync Frequency: 0
System Clock Mode: Master
System Clock Frequency: 44100
System Clock Locked: No

IEC958 input: Coaxial
IEC958 output: Coaxial only
IEC958 quality: Consumer
IEC958 emphasis: off
IEC958 NonAudio: off
IEC958 sample rate: Error flag set

ADAT1: No Lock
SPDIF: No Lock
Word Clock: No Lock
ADAT Sync: No Lock

AD Gain : +4 dBu
DA Gain : -10 dBV
Phones Gain : -12 dB
XLR Breakout Cable : no
AEB : off (ADAT1 external)

modinfo soundcore
filename: /lib/modules/2.6.38-8-generic/kernel/sound/soundcore.ko
license: GPL
author: Alan Cox
description: Core sound module
srcversion: 982D4ED4F640D0B9C43B130
depends:
vermagic: 2.6.38-8-generic SMP mod_unload modversions 686

lsmod | grep snd
snd_hdsp 53247 0
snd_pcm 80244 1 snd_hdsp
snd_page_alloc 14073 2 snd_hdsp,snd_pcm
snd_hwdep 13274 1 snd_hdsp
snd_seq_midi 13132 0
snd_rawmidi 25269 2 snd_hdsp,snd_seq_midi
snd_seq_midi_event 14475 1 snd_seq_midi
snd_seq ...

Read more...

yuri (nim-batu) wrote :

Can confirm this too, have been trying to reinstall hdspmixer but cannot find any files anywhere, everything else is working, shouldn't this do the trick?.

yuri (nim-batu) wrote :

Ok, so it's a problem with fltk-config which lies bundled in the package "libfltk1.1-dev". Apparently this isn't installed as default in 11.04, to fix this, install "libfltk1.1-dev" using synaptic then download alsa-tools from the site suggested by "Patrick le Roux", http://www.alsa-project.org/snapshot/ , open with Archive Manager, open the first folder, up-pack the hdspmixer folder and compile and install it. .)

zob (zob) wrote :

Installing the Debian Sid package solved the problem for me:
http://packages.debian.org/sid/i386/alsa-tools-gui/download

For other architectures look at the bottom of this page:
http://packages.debian.org/sid/alsa-tools-gui

zob (zob) wrote :

If you follow this solution, remember to lock the package with your package manager of choice. Otherwise it will update to the ubuntu package which is more recent - and unfortunately broken.

falkTX (falk-t-j) wrote :

the solution for this could not be simpler - just rebuild alsa-tools.

it seems that alsa-tools should build-depend no alsa-lib 1.0.24, which is not the case right now.
(I guess that alsa-tools was built before or at the same time as alsa-lib...)

I fixed it in my PPA (just rebuild):
https://launchpad.net/~kxstudio-team/+archive/ppa/+sourcepub/1740931/+listing-archive-extra

David Kastrup (dak) wrote :

As mentioned before: rebuilding leads to an executable that will usually complain about a busy device and do nothing.

The previous version, in contrast, works on a standard Ubuntu Gnome desktop.

mokabar (tim-klingt) wrote :

falkTX, if you want to ship a working version of hdspmixer, you should package an alsa-tools git snapshot

falkTX (falk-t-j) wrote :

sorry I missed the info (need to start reading more carefully...)

I'll update the package in the PPA with the latest snapshot

Daniel T Chen (crimsun) on 2011-06-07
Changed in alsa-tools (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Daniel T Chen (crimsun) on 2011-06-30
Changed in alsa-tools (Ubuntu Natty):
status: New → Triaged
importance: Undecided → Medium
Changed in alsa-tools (Ubuntu Oneiric):
assignee: nobody → Daniel T Chen (crimsun)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package alsa-tools - 1.0.24.1-2ubuntu1

---------------
alsa-tools (1.0.24.1-2ubuntu1) precise; urgency=low

  [ Daniel T Chen ]
  * cb40769c-hdsp-massive-fixes.patch: Backport fixes so that
    card init and mixer actually work (LP: #723276)

  [ Luke Yelavich ]
  * Merge from debian unstable (LP: #600536), remaining changes:
    - envy24control should use /sbin/alsactl
  * Update Vcs-Bzr field

alsa-tools (1.0.24.1-2) unstable; urgency=low

  * Tighten libasound2-dev Build-Depends to >= 1.0.24.1, to avoid a build
    failure of hdspmixer due to missing new alsa-lib headers
    (closes: #629911).

alsa-tools (1.0.24.1-1) unstable; urgency=low

  * New upstream release.
  * Bump debhelper compat to v8. Update .install files to remove the
    debian/tmp prefix.
  * Rename alsa-firmware-loaders.rules to .udev and use dh_installudev to
    install the rules file.
  * Drop obsolete README.source.
  * Bump Standards-Version to 3.9.2.
  * Use $(CURDIR) instead of `pwd`.
 -- Luke Yelavich <email address hidden> Tue, 25 Oct 2011 14:55:34 +1100

Changed in alsa-tools (Ubuntu):
status: Triaged → Fix Released
dino99 (9d9) on 2013-05-18
Changed in alsa-tools (Ubuntu Natty):
status: Triaged → Invalid
Changed in alsa-tools (Ubuntu Oneiric):
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers