No sound from subwoofer on Asus N551JM

Bug #1405691 reported by Paweł Kowalczyk on 2014-12-25
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
alsa-tools (Ubuntu)
Undecided
Jan Palak

Bug Description

On Asus N551JM there is no sound from external subwoofer on fresh Kubuntu 14.10 installation. There is no "Bass speaker" in alsamixer. Adding "options snd-hda-intel model=asus-mode4" to /etc/modprobe.d/alsa-base.conf makes "Bass speaker" appears in alsamixer but I was unable to make it play any sound. On Win8 works out-of-box.

Alsa-base version: 1.0.25+dfsg-0ubuntu4.

Howto fix: redirect pin 0x1a to "Internal speaker (back)" using HDAJackRetask on codec Realtek ALC668. Contents of /lib/firmware/hda-jack-retask.fw:

[codec]
0x10ec0668 0x1043177d 0

[pincfg]
0x12 0x90a60130
0x14 0x90170110
0x15 0x04211020
0x16 0x40000000
0x18 0x411111f0
0x19 0x411111f0
0x1a 0x90170152
0x1b 0x411111f0
0x1d 0x40c6832d
0x1e 0x411111f0
0x1f 0x411111f0

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in alsa-driver (Ubuntu):
status: New → Confirmed
Jan Palak (jpalak) on 2015-01-12
Changed in alsa-driver (Ubuntu):
status: Confirmed → Fix Released
Jan Palak (jpalak) wrote :

I have Asus N551JM too, and you shoud try this:
1. put in bash
$ sudo apt-get install alsa-tools-gui
2. open a hdajackretask with command $ hdajackretask
You will see a small window, select a codec Realtek ALC668 and check option "show unconnected pins" check "overwrite" in pin id: 0x1a and select internal speaker then "Apply now" and "install boot overwrite".
3. Reboot the system
4. In sound setting select profile that you want and you will hear a subwoofer

This result work for me.

affects: alsa-driver (Ubuntu) → alsa-tools (Ubuntu)
Changed in alsa-tools (Ubuntu):
assignee: nobody → Jan Palak (jpalak)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers