alsa-plugins a52 module broken with libav

Bug #872871 reported by Rob Hall on 2011-10-12
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
alsa-plugins (Ubuntu)
Low
Daniel T Chen
Oneiric
Low
Daniel T Chen
Precise
Undecided
Unassigned

Bug Description

[Impact statement]
Due to changes in the ac3 encoder in libav the a52 alsa-plugin will no longer work in Oneric.

[Development fix] / [Stable fix]
Committed in r59 of http://bazaar.launchpad.net/~ubuntu-audio-dev/alsa-plugins/ubuntu.oneiric/revision/59. Already fixed in r2557 of http://anonscm.debian.org/viewvc/pkg-alsa?view=revision&revision=2557.

[Test case]
speaker-test -Da52 -c6
[ac3 @ 0x1c14000] Specified sample_fmt is not supported.

[Regression potential]
Low - This commit only touches the a52 plugin source, and as it will ship not working, it won't regress further.

[Original defect report]
A patch is available

http://git.alsa-project.org/?p=alsa-plugins.git;a=blobdiff;f=a52/pcm_a52.c;h=76f21cd003bfcfb8c3b07e003f04aca6132a7b79;hp=ed491b31c32a87a65258524b497d05d6e876fc0b;hb=40c129a160f37fe9488b2828d6299f99c269703e;hpb=06ca71522f1dc48b8503d945da81fdbcbab0aafa

description: updated
Daniel T Chen (crimsun) wrote :

We actually need to conditionalize upon libav* version, so we need both commits from upstream.

Changed in alsa-plugins (Ubuntu):
assignee: nobody → Daniel T Chen (crimsun)
importance: Undecided → Low
status: New → In Progress
Daniel T Chen (crimsun) on 2011-10-12
description: updated

Hello Rob, or anyone else affected,

Accepted alsa-plugins into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in alsa-plugins (Ubuntu Oneiric):
status: In Progress → Fix Committed
tags: added: verification-needed
Rob Hall (rhall-lincommander) wrote :

I've upgraded to the proposed package and built the a52 module from the package source without any issues. Thanks for the speedy resolution of this issue.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in alsa-plugins (Ubuntu Precise):
status: New → Confirmed
Daniel T Chen (crimsun) wrote :

This was fixed in the merge for Precise.

Changed in alsa-plugins (Ubuntu Precise):
status: Confirmed → Fix Released
Daniel T Chen (crimsun) wrote :

I confirm that the fix in oneiric-proposed also resolves the reported symptom.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package alsa-plugins - 1.0.24-0ubuntu6.1

---------------
alsa-plugins (1.0.24-0ubuntu6.1) oneiric-proposed; urgency=low

  * debian/patches/0006-handle-new-libav.patch: Backport upstream git
    commits 40c129a and 826dafa so that the a52 plugin works again.
    (LP: #872871)
 -- Daniel T Chen <email address hidden> Wed, 12 Oct 2011 11:08:02 -0400

Changed in alsa-plugins (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers