libasound2-plugins misses alsa pcm jack plugin

Bug #84900 reported by tapas on 2007-02-13
66
This bug affects 7 people
Affects Status Importance Assigned to Milestone
alsa-plugins (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: libasound2-plugins

Since the latest update (two days ago, so it was feb. 10 or 11) i did an apt-get update/upgrade and since then the jack pcm plugin misses from the libasound2-plugins package.. This is too bad, since i use it to play amarok through jack :(

Christophe Giboudeaux (krop) wrote :

I can confirm. libasound_module_pcm_jack.so disappeared from feisty package (it was present in edgy's one).

Changed in alsa-plugins:
status: Unconfirmed → Confirmed
raboof (arnouten) wrote :

I'm also running into this. A symptom of this problem is the following output when running mpg321 (so people googling for the same problem will find this report):

ALSA lib pcm.c:2106:(snd_pcm_open_conf) Cannot open shared library /usr/lib/alsa-lib/libasound_module_pcm_jack.so
ALSA snd_pcm_open error: No such file or directory

GCH (robotify) wrote :

This is confirmed for Feisty. In Edgy, this package did include the output plugin that allows ALSA to output to JACK, but that has gone missing. Any reasons (other than not wanting to force people to install JACK??). For those of us who use JACK as a primary audio interface, this plugin is an absolute necessity for applications that do not natively support JACK.

Furthermore, the package text description still says the package includes support for JACK, despite that being removed. This is potentially very confusing for new users.

tapas (mista-tapas) wrote :

Some research on my part shows that the jack plugin was removed deliberately (at least the changelog said somehing like this). I cannot understand this decision. Deliberately limiting the power of this great linux distro called ubuntu.

tapas (mista-tapas) wrote :

btw:

as a workaround it is possible to build the alsa jack pcm plugin from source..

0] install libasound2-dev package
1] get the alsa-plugins tarball from http://www.alsa-project.org
2] extract the tarball somewhere
3] configure --prefix=/usr and make (you can even try make only in the jack subdir if the whole build fails)
4] manually copy the libasound_module_pcm_jack.la to /usr/lib/alsa-lib/
5] profit in the form of heightened enjoyment of ubuntu

Micon Frink (frink) wrote :

Thanks for the research on this. It's important for this to be included. With the release of Ubuntu Studio we are even more in need of this as many audio studio will want to run everything through JACK. I wish the MOTUs were as responsive as the community...

Micon Frink (frink) wrote :

Even easier is to get the previous compiled version from Edgy.I just downloaded the deb and extracted the two files from data.tar.gz/usr/lib/alsa-lib/ and put them in /usr/lib/alsa-lib/ - works like a charm!

- Frink

Daniel T Chen (crimsun) wrote :

libasound2-plugins was migrated to main for pulseaudio. Because jackd's source remains in universe, we cannot build libasound2-plugins with jackd plugin support.

Changed in alsa-plugins:
status: Confirmed → Rejected
tapas (mista-tapas) wrote :

@Daniel. The obvious solution is then to package the jack alsa pcm plugin separately so it can depend on jack. Or put libjack in main (you don't need jackd in main, just libjack)..

What is the status of this bug? What version of ubuntu will contain the fix?

On Monday 24 March 2008, Ralph Navarro wrote:
> What is the status of this bug? What version of ubuntu will contain the
> fix?

AFAIK this is not a bug but broken by design. Someone from the ubuntu team
told me it will never be "fixed" because it adds a dependency to
libasound2-plugins..

Well, i always simply build it from source now..

Regards,
Flo

--
Palimm Palimm!
http://tapas.affenbande.org

raboof (arnouten) wrote :

David rejected this report. I think this was wrong: indeed the obvious solution (compiling libasound2-plugins with jack support) is infeasible (as libasound2-plugins is now in main and jack is in universe). This, however, does not make the problem disappear :).

I think the status should go back to 'Confirmed', investigate whether it'd be possible to package the jack alsa pcm plugin separately, lobby for the inclusion of libjack in main, and/or look for other solutions.

raboof (arnouten) wrote :

changing to 'confirmed' after discussion on #ubuntu-bugs, as it does not appear to be invalid and the problem is fairly widespread (e.g. http://linuxmusicians.com/posting.php?mode=editpost&p=251 )

Changed in alsa-plugins:
status: Invalid → Confirmed
Michael Rooney (mrooney) wrote :

Whoever marked this as Invalid didn't offer an explanation (that I noticed anyway) so I will make this Confirmed, as a result of that and the two options we have:

1) Promote libjack to main. Promoting libjack0 to main would, as I understand, require promoting libfreebob0 to main as well, however all of libfreebob0's deps are already in main.
2) Package libasound2-plugins-extra.

What are the chances of promoting libjack to main?

raboof (arnouten) wrote :

It looks like there are more people already in the process of trying to get jack promoted back into main (actually, it was in main before, but got demoted after breezy).

https://wiki.ubuntu.com/MainInclusionReportJACK

Also, I heard it is possible for a source package in 'main' to produce some of its binary packages in 'universe', and depend on packages in universe for those targets. That might make producing a libasound2-plugins-extra (or -jack) much easier.

raboof (arnouten) wrote :

(Sorry, I was mistaken: a source package in 'main' may produce binary packages in 'universe', but may not depend on packages in universe, not even for build deps. Looks like we're going to have to try and put jack in main, or get the libasound-jack-plugin building separately from the rest of the plugins).

raboof (arnouten) wrote :

see also bug 197957

Michael Rooney (mrooney) wrote :

Thanks for the related bug raboof, do you think one is a duplicate of the other?

raboof (arnouten) wrote :

Not really, as this bug can be resolved without resolving all of bug 197957 (by promoting jack to main). On the other hand, if bug 197957 is resolved then this issue is also fixed.

I suppose this is some kind of 'subset' or 'child bug' of #197957 - not a duplicate.

as of Intrepid 8.10, this issue is still active.

^rooker (rooker) wrote :

This is a sad thing - and there's still no solution.

Is there any decision yet regarding a separate "libasound2-plugins-extra" package?
Just leaving libasound-jack out in the rain is a bit hard, don't you think?

Especially, because people doing audio *DO* want almost everything to go through jack in order to record it (and are very often not the ones able or willing to compile stuff)

jd (jd-typhon) wrote :

Hi. Building from source in order to get the missing file is quite a pain in the ass. Is there any positive prospects on this issue? Thank you :)

naught101 (naught101) wrote :

poke

tapas: what comes after step 4 in your work around? I have libasound_module_pcm_jack.la installed. I tried this: http://alsa.opensrc.org/index.php/Jack_%28plugin%29 but I get no joy after restarting both jack and alsa.

lvecsey (lvecsey) wrote :

It's actually the jack/.libs/libasound_module_pcm_jack.so file that gets moved to /usr/lib/alsa-lib

The rest of the details can be found by searching for keywords "asoundrc jack" which will bring you to this page:

http://www.alsa-project.org/main/index.php/Asoundrc

Anyway, this was the critical text that goes into your ~/.asoundrc file:

pcm.!default {
             type plug
             slave { pcm "jack" }
}

pcm.jack {

    type jack

    playback_ports {
        0 system:playback_1
        1 system:playback_2
    }

I've had excellent success with this just now (Ubuntu 9.10, compiled from alsa-plugins 1.0.18), and actually have a firefox browser playing a myspace music page to headphones connected to a remote machine (using jack_netsource, jackd -d net, and jack_connect to assign ports). You don't need any of that if you plan to do everything on your local machine. But it's pretty clear to me at least that all of this stuff starts to get into more advanced and tricky territory, and from a support standpoint I can see why the Ubuntu folks would opt to keep a new user from venturing into _any_ of this territory, when just trying to get rudimentary sound output working.

Motin (motin) wrote :

JACK-Enabled alsa-plugins packages for Karmic can be found here: https://launchpad.net/~motin/+archive/until-jack-is-included-in-main/+packages

thanks :)

On Fri, Oct 23, 2009 at 3:02 AM, Motin <email address hidden> wrote:

> JACK-Enabled alsa-plugins packages for Karmic can be found here:
> https://launchpad.net/~motin/+archive/until-jack-is-included-in-
> main/+packages<https://launchpad.net/%7Emotin/+archive/until-jack-is-included-in-%0Amain/+packages>
>
> --
> libasound2-plugins misses alsa pcm jack plugin
> https://bugs.launchpad.net/bugs/84900
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “alsa-plugins” package in Ubuntu: Confirmed
>
> Bug description:
> Binary package hint: libasound2-plugins
>
> Since the latest update (two days ago, so it was feb. 10 or 11) i did an
> apt-get update/upgrade and since then the jack pcm plugin misses from the
> libasound2-plugins package.. This is too bad, since i use it to play amarok
> through jack :(
>

Changed in alsa-plugins (Ubuntu):
status: Confirmed → Fix Committed

I'm believe this should be Fix Released as of alsa-plugins 1.0.22-0ubuntu4.

Changed in alsa-plugins (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers