Ubuntu

mpg123 produces skippy output in 9.10

Reported by SilverStreak on 2009-10-30
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
alsa-plugins (Ubuntu)
Medium
David Henningsson

Bug Description

Binary package hint: mpg123

Relevent Information: Ubuntu 9.10, mpg123 1.7.3

After the upgrade to 9.10, I tried using mpg123 to play back MP3 audio files. When I did this, mpg123 would not output a steady output stream, instead "skipping" a la an old CD player. Sometimes, the entire program would become unresponsive, forcing a killall to quit. I tried reverting back to a previous version of mpg123, however the problem was still present.

The odd thing is, is that this problem is not present in any other audio application, including mpg321. This problem also does not manifest if you preview the audio file in nautilus - odd, because nautilus should still be using mpg123 as the audio preview backend. There is also no skipping if the .wav output option is selected.

In light of all this, I am unsure as to whether this problem is an mpg123 problem, or an audio backend (pulse, alsa, etc.) problem.

SilverStreak (silv-streak) wrote :

I seem to have found the source of the problem.

At one point when using mpg321 instead of mpg123, I got an ALSA underrun error, prompting me to search for solutions relating to alsa underruns with mpg123. One solution was to use the plughw device (-a plughw), which worked. I've made this permanent by adding a single line to my .asoundrc file:

pcm.!default "plughw:0,0"

Hopefully, this solution will come in handy for other people who encounter the same problem.

Daniel T Chen (crimsun) on 2009-12-21
affects: mpg123 (Ubuntu) → alsa-plugins (Ubuntu)
David Henningsson (diwic) wrote :

https://tango.0pointer.de/pipermail/pulseaudio-discuss/2010-January/006286.html

After some thought, I'll go with the second solution discussed in the link here, toiignore obsolete underruns.

Changed in alsa-plugins (Ubuntu):
assignee: nobody → David Henningsson (diwic)
importance: Undecided → Medium
status: New → In Progress
David Henningsson (diwic) wrote :

@SilverStreak: Btw, your workaround is normally not recommended because it disables the alsa-pulse gateway for all alsa applications, so there will be problems e g if you try to play an alsa application simultaneously with something else.

David Henningsson (diwic) wrote :

I'm almost considering the radical solution of not reporting underruns to the upper layer (i e ALSA) at all. Underruns in the pulseaudio front differs from underruns on a real soundcard, both because of the obsolete issue (and so far there's no known way to find out if it really is obsolete or not), and because the recovery is so different. On an hw/mmap device you must reset pointers to get back on track, but on the pulse front you just have to keep feeding it buffers. And that's what's likely going to happen if you don't report the underrun back.

Marco Craveiro (marco-craveiro) wrote :

Just a bit of a me-too post, to say that I've been bitten by this bug and had to stop playing music from emacs (bongo/emms were using mpg123 backend). Thanks for looking into it.

David Henningsson (diwic) wrote :

An update on this issue; this fix is blocked due to awaiting comments from Lennart Poettering, see https://lists.launchpad.net/ubuntu-audio-dev/msg00011.html
In the meantime, there is a fixed version for Karmic available in my PPA. Testing is very welcome, especially if there are any regressions.

Changed in alsa-plugins (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package alsa-plugins - 1.0.22-0ubuntu6

---------------
alsa-plugins (1.0.22-0ubuntu6) lucid; urgency=low

  [ Daniel T Chen ]
  * Add e3b3c40-check-null-before-dereference.patch

  [ David Henningsson ]
  * Add lp464008lp503174.patch (LP: #464008, #503174)
 -- Daniel T Chen <email address hidden> Sun, 28 Feb 2010 17:03:48 -0500

Changed in alsa-plugins (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers