Provide a lib32asound2-plugins package

Bug #182731 reported by Chris Halse Rogers on 2008-01-14
28
Affects Status Importance Assigned to Milestone
alsa-plugins (Debian)
Fix Released
Unknown
alsa-plugins (Ubuntu)
Wishlist
Unassigned
ia32-libs (Ubuntu)
Medium
Unassigned

Bug Description

With pulseaudio coming in Hardy, the easiest default ALSA setup is with the default ALSA device going through the pulse ALSA plugin. For this to work on AMD64 with 32bit apps like wine, we need to build a 32bit package of libasound2-plugins to get the 32bit pulse ALSA plugin.

Related branches

Changed in alsa-plugins:
importance: Undecided → Wishlist
Changed in alsa-plugins:
status: Unknown → New
TRiSS (triss) wrote :

seems ok in hardy alpha...

Ernst Sjöstrand (ernstp) wrote :

Does it? Doesn't work here.
Do you have /usr/lib32/alsa-lib/libasound_module_pcm_pulse.so on your system?
Which package does it come from? (dpkg -S /usr/lib32/alsa-lib/libasound_module_pcm_pulse.so if you have it)

wine Wow.exe -opengl
fixme:spoolsv:serv_main (0 (nil))
ALSA lib ../../../src/pcm/pcm.c:2106:(snd_pcm_open_conf) Cannot open shared library /usr/lib32/alsa-lib/libasound_module_pcm_pulse.so
ALSA lib ../../../src/pcm/pcm.c:2106:(snd_pcm_open_conf) Cannot open shared library /usr/lib32/alsa-lib/libasound_module_pcm_pulse.so

Ernst Sjöstrand (ernstp) wrote :

A suggestion!

Changed in ia32-libs:
assignee: nobody → pitti
Patrice DUROUX (patrice-duroux) wrote :

Hy,

I have the same problem as I would like to use a 32bit app (Skype) with PulseAudio thru the Alsa plugin.
It would complete some adding done recently in ia32-libs about PulseAudio support.

Regards.

Chris Halse Rogers (raof) wrote :

Closing the ia32-libs task. This is doable and should be done in the alsa-plugins package. The Debian bug has a patch against their alsa-plugins package attached to it which builds (among other things) a lib32asound2-plugins package. However, this is probably a bit late for Hardy.

Changed in ia32-libs:
status: New → Invalid
Ernst Sjöstrand (ernstp) wrote :

Isn't this a big regression from Gutsy, that you can't run 32-bit alsa applications?
I think lib32asound2-plugins would be an important part of the Pulseaudio migration.
(Except for flash, which is fixed by the libflashsupport special case...)

Kevin Welch (kebinusan) wrote :

Not having this kinda screws things up when I run 32bit apps on ubuntu64. Would love to see it make it into hardy so I can get PA to work with some 32 bitapps like wine. As it stands not having this seems to be causing some of my 32bit audio apps to stop functioning when they try to access hardware in use by PA

Roberto Cássio Jr. (rcsdnj) wrote :

any chances of a freeze break or something like that to fix this for Hardy?

I also believe this is a serious regression, I've found no easy way to make wine run correctly under Hardy, and the same for other important 32 bit applications (like Skype). Currently, pulseaudio, unfortunately, brings more problems to me than it solved, at least at this moment.

Martin Pitt (pitti) on 2008-03-24
Changed in ia32-libs:
assignee: pitti → nobody
Susan Cragin (susancragin) wrote :

I have the same problems but I have a 32-bit machine. I usually run Dragon NaturallySpeaking under wine and Linux-Skype, but the only input/output I get is very weak and terrible. But none of my audio works. Not Macromedia Flash.
All programs have been rendered unusable.

Ernst Sjöstrand (ernstp) wrote :

Hi Susan, this problem is specifically for 64-bit machines. I think you should file another bug.

Erik (echakr) wrote :

How is this wishlist?!

No sound for virtually any 3rd party app (as most are not x86_64) on 64bit systems...

This is a dealbreaker for getting people to migrate from a Windows desktop.

Homersp (maa-tillman) wrote :

I had the same problem, but it was quite an easy fix really.
Just download the 32-bit libasound2-plugins deb from the ubuntu package repository (for Hardy: http://packages.ubuntu.com/hardy/libasound2-plugins). Extract the contents to your home directory, and then extract data.tar.gz.
Rename usr/lib to usr/lib32 and copy usr to /.

Using this fix wine works just fine. But I do agree, it should be included in the ia32-libs package.

Scott Ritchie (scottritchie) wrote :

Agreed. For Hardy we should put this in ia32-libs since there isn't time to fix it elsewhere, however in the future it should be a part of a separate package (like everything else in ia32-libs, really)

Changed in ia32-libs:
importance: Undecided → Medium
status: Invalid → Confirmed
Changed in alsa-plugins:
status: New → Confirmed
Scott Ritchie (scottritchie) wrote :

I'm going to tag this a milestone bug as we really should do this before release, especially since it's so simple.

Changed in ia32-libs:
milestone: none → ubuntu-8.04
Stephan Ruegamer (sadig) wrote :

Dear MOTU-Release:

Please ack this addition to ia32-libs ....

a debdiff and everything is not suitable for this type of addition..

The upload will be done most likely by pitti.

thx in adv,

\sh

StefanPotyra (sistpoty) wrote :

ACK.

Martin Pitt (pitti) on 2008-04-14
Changed in ia32-libs:
assignee: nobody → pitti
status: Confirmed → In Progress
Martin Pitt (pitti) wrote :

Uploaded, in RM queue now.

Changed in ia32-libs:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ia32-libs - 2.2ubuntu9

---------------
ia32-libs (2.2ubuntu9) hardy; urgency=low

  * Add libsamplerate0 and libasound2-plugins. (LP: #182731)

 -- Martin Pitt <email address hidden> Mon, 14 Apr 2008 17:23:00 +0000

Changed in ia32-libs:
status: Fix Committed → Fix Released
Matthew Williams (number6) wrote :

When running gizmo with the updated ia32-libs, I get the following swears:

ALSA lib control.c:874:(snd_ctl_open_conf) Cannot open shared library /usr/lib/alsa-lib/libasound_module_ctl_pulse.so
ALSA lib control.c:874:(snd_ctl_open_conf) Cannot open shared library /usr/lib/alsa-lib/libasound_module_ctl_pulse.so
ALSA lib control.c:874:(snd_ctl_open_conf) Cannot open shared library /usr/lib/alsa-lib/libasound_module_ctl_pulse.so
ALSA lib control.c:874:(snd_ctl_open_conf) Cannot open shared library /usr/lib/alsa-lib/libasound_module_ctl_pulse.so
ALSA lib pcm.c:2106:(snd_pcm_open_conf) Cannot open shared library /usr/lib/alsa-lib/libasound_module_pcm_pulse.so
ALSA lib pcm.c:2106:(snd_pcm_open_conf) Cannot open shared library /usr/lib/alsa-lib/libasound_module_pcm_pulse.so

Notice that the 64 bit versions of the libraries are being referenced, not the ones in /usr/lib32. Here is the output from ldd /usr/bin/gizmo | grep asound:
libasound.so.2 => /usr/lib32/libasound.so.2 (0xf716e000)

So, it looks like gizmo is loading the correct 32 bit version of the asound library, but then that library is trying to load the 64 bit plugins which fails miserably. Is there a way to get the 32 bit version of libasound to look in /usr/lib32/alsa-lib instead of /usr/lib/alsa-lib?

Martin Pitt (pitti) wrote :

So apparently this hasn't been sufficiently tested before? Reopening. Please note that in ia32-libs we can *only* include the i386 debs as they are. If they need to do something special under 32 bit mode under amd64, then alsa-plugins/alsa-libs need to build their own lib32foo packages, and then we make ia32-libs depend on those.

Changed in ia32-libs:
milestone: ubuntu-8.04 → none
status: Fix Released → Incomplete
sklp (sklp) wrote :

This bug still hasn't been fixed in Intrepid alpha 5.
Although pulse isn't the default alsa pcm yet either (LP #198453 ), so until that is fixed I guess this is less of an issue then it otherwise would be. But it really should be fixed before Intrepid final, since it's a major regression compared to gutsy...

Daniel T Chen (crimsun) wrote :

Slated for 9.04.

Changed in alsa-plugins:
status: Confirmed → Triaged
Changed in alsa-plugins:
status: New → Fix Committed
Daniel T Chen (crimsun) on 2008-11-11
Changed in alsa-plugins:
status: Triaged → Fix Released
Changed in alsa-plugins:
status: Fix Committed → Fix Released
sklp (sklp) wrote :

Hi. So this bug is supposedly fixed in jaunty. Great news. It's a pretty useful feature to be able to get sound from a 32 bit application running on a 64 bit system, so I'm thinking it would also be good with some kind of backport for intrepid and hardy, or at least for intrepid.

Luke Yelavich (themuso) wrote :

Unfortunately a backport isi not possible, so far as I know. The newer alsa-plugins 1.0.18 requires alsa-lib 1.0.18, and policy for backports is that libraries generally aren't backported.

In addition, ia32-libs contains libasound2-plugins 1.0.17 for intrepid, yes I know it installs a lot of other stuff as well, but if that package already provides the alsa plugins, why backport
another just for a 32-bit package that is independant of ia32-libs? Functionality and fixes I can understand.

Martin Pitt (pitti) wrote :

Now that alsa builds lib32 packages, the ia32-libs side is obsolete, as far as I can see.

Changed in ia32-libs:
assignee: pitti → nobody
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.