Ubuntu

package libasound2 1.0.25-1ubuntu10 [modified: usr/share/alsa/alsa.conf usr/share/alsa/cards/USB-Audio.conf] failed to install/upgrade: './usr/share/alsa/cards/USB-Audio.conf' is different from the same file on the system

Reported by Norman Duncan on 2012-04-29
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
alsa-lib (Ubuntu)
Undecided
Unassigned

Bug Description

The following packages were automatically installed and are no longer required:
  libcaca-dev libslang2-dev libxt-dev
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 2 reinstalled, 0 to remove and 0 not upgraded.
Need to get 0 B/858 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue [Y/n]? y
(Reading database ... 232790 files and directories currently installed.)
Preparing to replace libasound2 1.0.25-1ubuntu10 (using .../libasound2_1.0.25-1ubuntu10_amd64.deb) ...
Unpacking replacement libasound2 ...
dpkg: error processing /var/cache/apt/archives/libasound2_1.0.25-1ubuntu10_amd64.deb (--unpack):
 './usr/share/alsa/cards/USB-Audio.conf' is different from the same file on the system
Preparing to replace libasound2:i386 1.0.25-1ubuntu10 (using .../libasound2_1.0.25-1ubuntu10_i386.deb) ...
Unpacking replacement libasound2:i386 ...
dpkg: error processing /var/cache/apt/archives/libasound2_1.0.25-1ubuntu10_i386.deb (--unpack):
 './usr/share/alsa/cards/USB-Audio.conf' is different from the same file on the system
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/libasound2_1.0.25-1ubuntu10_amd64.deb
 /var/cache/apt/archives/libasound2_1.0.25-1ubuntu10_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

ProblemType: Package
DistroRelease: Ubuntu 12.04
Package: libasound2 1.0.25-1ubuntu10 [modified: usr/share/alsa/alsa.conf usr/share/alsa/cards/USB-Audio.conf]
ProcVersionSignature: Ubuntu 3.2.0-24.37-generic 3.2.14
Uname: Linux 3.2.0-24-generic x86_64
ApportVersion: 2.0.1-0ubuntu7
AptOrdering:
 libasound2: Install
 libasound2: Install
 libasound2: Configure
 libasound2: Configure
Architecture: amd64
Date: Sun Apr 29 14:43:41 2012
DpkgTerminalLog:
 Preparing to replace libasound2 1.0.25-1ubuntu10 (using .../libasound2_1.0.25-1ubuntu10_amd64.deb) ...
 Unpacking replacement libasound2 ...
 dpkg: error processing /var/cache/apt/archives/libasound2_1.0.25-1ubuntu10_amd64.deb (--unpack):
  './usr/share/alsa/cards/USB-Audio.conf' is different from the same file on the system
DuplicateSignature:
 Unpacking replacement libasound2 ...
 dpkg: error processing /var/cache/apt/archives/libasound2_1.0.25-1ubuntu10_amd64.deb (--unpack):
  './usr/share/alsa/cards/USB-Audio.conf' is different from the same file on the system
ErrorMessage: './usr/share/alsa/cards/USB-Audio.conf' is different from the same file on the system
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
SourcePackage: alsa-lib
Title: package libasound2 1.0.25-1ubuntu10 [modified: usr/share/alsa/alsa.conf usr/share/alsa/cards/USB-Audio.conf] failed to install/upgrade: './usr/share/alsa/cards/USB-Audio.conf' is different from the same file on the system
UpgradeStatus: Upgraded to precise on 2012-04-21 (7 days ago)

Norman Duncan (norman-artofnow) wrote :
tags: removed: need-duplicate-check
Keivan Moradi (shayanmansuri) wrote :

I was trying to reinstall some of alsa related packages and see the same error.

E: /var/cache/apt/archives/libasound2_1.0.25-1ubuntu10_amd64.deb: './usr/share/alsa/cards/USB-Audio.conf' is different from the same file on the system
E: /var/cache/apt/archives/libasound2_1.0.25-1ubuntu10_i386.deb: './usr/share/alsa/cards/USB-Audio.conf' is different from the same file on the system

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in alsa-lib (Ubuntu):
status: New → Confirmed
David Henningsson (diwic) wrote :

Should be fixed in 13.10, because with alsa-lib 1.0.27 this file is now
in a separate all-architecture package instead (libasound2-data).

Changed in alsa-lib (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers