libasound2 not finding usb sound card

Bug #652035 reported by Kjetil Wiekhorst Jørgensen on 2010-09-30
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
alsa-lib (Ubuntu)
Medium
Daniel T Chen
Maverick
High
Daniel T Chen

Bug Description

-- StableReleaseUpdates candidate (for Maverick) information follows --

Impact statement: Due to changes in alsa-lib configuration file parsing (an overly-optimistic short-circuit) as shipped in Maverick final, certain virtual hw devices and audio cards that lack a definition file in /usr/share/alsa/cards/ are not exposed properly to userspace. This impact is manifested via missing virtual hw devices and/or cards. The original description below (i.e., this bug) contains an example of the former; bug 637947 contains an example of the latter.

Fix: It is worth noting that, to properly address both bugs mentioned above, both source changes and default configuration file changes must be made. These changes are contained in debian/patches/lp652035-fix-missing-hw-devices.patch and debian/patches/lp652035-use-extended-namehints.patch, respectively, as seen at http://bazaar.launchpad.net/~ubuntu-core-dev/alsa-lib/ubuntu.new/revision/66.

Minimal patch: http://bazaar.launchpad.net/%7Eubuntu-core-dev/alsa-lib/ubuntu.new/diff/66

TEST CASE: One test case is provided in (the entirety of) bug 637947. Another is given below.

Regression potential: There is a *very* low probability that (native) ALSA applications may not be equipped to handle the additional information exposed by extended hints (enabled by debian/patches/lp652035-use-extended-namehints.patch). In practice, this probability has been so trivial as to be negligible. Further, there would not be crashes, only additional virtual hw device(s) exposed in the UIs of graphical ALSA applications that offer potentially-confusing device strings. This probability is sufficiently negligible in light of its afforded fix of exposing sufficient information to userspace to "make audio devices work."

-- Original defect report follows --

When upgrading to libasound2 1.0.23-1ubuntu2 my usb sound card stop being discovered by programs like aplay, mumble.

aplay -L will not list the usb sound devices anymore.

The attachment will show my problem before and after installing the latest version of libasound2.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: libasound2 1.0.22-0ubuntu7
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Thu Sep 30 15:02:12 2010
InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release amd64 (20100816.1)
SourcePackage: alsa-lib

Please attach respective `dmesg|tail', too.

Since this is a library bug and not a driver bug, that command won't give any information at all.

Daniel T Chen (crimsun) wrote :

You misunderstand me, rather. I'm looking for something resembling
this line in your dmesg:

[83775.406331] 7:2:1: endpoint lacks sample rate attribute bit, cannot set.

Please clarify whether you rebooted between updating libasound2 versions.

Yes, I have rebooted between changing versions, but that is totally beyond the point as I said. This is still not a driver problem. The drivers have not changed only the library. I have tried different install options and narrowed it down to libasound2 and the problem is only in the latest version (1.0.23-1ubuntu2).

This is the lines you're looking for and those will not change even if I change the library.

[91659.558926] HDA Intel 0000:00:06.1: PCI INT B -> Link[AAZA] -> GSI 21 (level, low) -> IRQ 21
[91659.558935] hda_intel: Disable MSI for Nvidia chipset
[91659.559273] HDA Intel 0000:00:06.1: setting latency timer to 64
[91665.723240] 7:2:1: endpoint lacks sample rate attribute bit, cannot set.
[91665.724580] 7:2:2: endpoint lacks sample rate attribute bit, cannot set.
[91665.725819] 7:2:3: endpoint lacks sample rate attribute bit, cannot set.
[91665.727069] 7:2:4: endpoint lacks sample rate attribute bit, cannot set.
[91665.904509] usbcore: registered new interface driver snd-usb-audio

This was done by removing all the alsa drivers from the running kernel and then loading them again and not by rebooting since that serves no point.

Daniel T Chen (crimsun) wrote :

Please attach lsusb -v information (prune as necessary only for the
usb audio device).

As requested.

Both units have usb sound devices.

Daniel T Chen (crimsun) wrote :

Hmm, definitely broken in Maverick's current source package. There are two parts to the fix; one has been committed upstream, and the other seems to require an additional configuration file parameter. I'm working on this; sorry for the delay.

Changed in alsa-lib (Ubuntu):
assignee: nobody → Daniel T Chen (crimsun)
status: New → In Progress
importance: Undecided → Medium
Daniel T Chen (crimsun) wrote :

I've uploaded an SRU candidate to my ppa for maverick; please test.

It seems to work. I've only done a quick test, nothing major.

Daniel T Chen (crimsun) on 2010-10-11
tags: added: regression-release
Oliver Grawert (ogra) wrote :

i can confirm that this fix helps massively with the issue we see initializing sound on the panda OMAP4 board in bug 637947, the arm team would appreciate an upload asap.

Oliver Grawert (ogra) on 2010-10-13
Changed in alsa-lib (Ubuntu Maverick):
milestone: none → maverick-updates
Daniel T Chen (crimsun) on 2010-10-13
Changed in alsa-lib (Ubuntu Maverick):
status: New → Triaged
importance: Undecided → High
Daniel T Chen (crimsun) on 2010-10-13
description: updated
Daniel T Chen (crimsun) on 2010-10-13
Changed in alsa-lib (Ubuntu Maverick):
assignee: nobody → Daniel T Chen (crimsun)

Accepted alsa-lib into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in alsa-lib (Ubuntu Maverick):
status: Triaged → Fix Committed
tags: added: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package alsa-lib - 1.0.23-2ubuntu1

---------------
alsa-lib (1.0.23-2ubuntu1) natty; urgency=low

  * Merge from debian unstable. Remaining changes:
    - debian/rules:
      + Don't bail when removing include/alsa
    - debian/control: Add Vcs-Bzr URI
    - Add configuration files for bluetooth/bluez-alsa and pulseaudio
    - debian/libasound2.install: Ship smixer plugins for native and bi-arch
      packages
    - drop libcxxtools-dev build dependency, its in universe
    - add --with-plugindir=\$${prefix}/lib/alsa-lib to configure-stamp
    - Demote libc6-i386 pre-depends to depends for lib32asound2
    - correctly free dl handles
  * debian/patches/series: Uncomment debian's thread patches, as our
    relibtoolize.patch encorporates those fixes already, as well as the above
    dl handlers fix, and its a little difficult unraveling them

  [ Daniel T Chen ]
  * Apply upstream git changesets
    0244370 and c049d48 to help fix LP: #652035.
  * lp652035-use-extended-namehints.patch: Show hints for non-standard
    devices that lack configuration files. This patch is also required
    to help fix LP: #652035 and by consequence also addresses
    LP: #425362.

alsa-lib (1.0.23-2) unstable; urgency=medium

  [ Elimar Riesebieter ]
  * Make setlocale() thread safe:
    Applied thread-safe-locale.patch and thread-specific-locale.patch from
    upstream. (Closes: #595252)
  * Bump Standards-Version to 3.9.1, with no changes required.
 -- Luke Yelavich <email address hidden> Sat, 16 Oct 2010 15:05:11 +1100

Changed in alsa-lib (Ubuntu):
status: In Progress → Fix Released
Oliver Grawert (ogra) wrote :

the uploaded package behaves identical to the tested one from the PPA, please let it into maverick-updates

Steve Langasek (vorlon) on 2010-10-28
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package alsa-lib - 1.0.23-1ubuntu2.1

---------------
alsa-lib (1.0.23-1ubuntu2.1) maverick-proposed; urgency=low

  * lp652035-fix-missing-hw-devices.patch: Apply upstream git changesets
    0244370 and c049d48 to help fix LP: #652035.
  * lp652035-use-extended-namehints.patch: Show hints for non-standard
    devices that lack configuration files. This patch is also required
    to help fix LP: #652035 and by consequence also addresses
    LP: #425362.
 -- Daniel T Chen <email address hidden> Sun, 03 Oct 2010 14:56:12 -0400

Changed in alsa-lib (Ubuntu Maverick):
status: Fix Committed → Fix Released
tags: added: testcase
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers