knotify4 crashed with SIGSEGV in snd_pcm_close()

Bug #552411 reported by Kai Kasurinen on 2010-03-31
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Phonon
Won't Fix
High
alsa-lib (Ubuntu)
Medium
Daniel T Chen

Bug Description

Binary package hint: kdebase-runtime

ProblemType: Crash
DistroRelease: Ubuntu 10.04
Package: kdebase-runtime 4:4.4.2-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-18.27-generic 2.6.32.10+drm33.1
Uname: Linux 2.6.32-18-generic x86_64
Architecture: amd64
Date: Wed Mar 31 11:04:30 2010
ExecutablePath: /usr/bin/knotify4
ProcCmdline: /usr/bin/knotify4
ProcEnviron:
 LANGUAGE=fi_FI:fi:en_GB:en
 PATH=(custom, user)
 LANG=fi_FI.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7f37cf592e79: mov 0x20(%rax),%rax
 PC (0x7f37cf592e79) ok
 source "0x20(%rax)" (0x7f37cb7fdd00) not located in a known VMA region (needed readable region)!
 destination "%rax" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: kdebase-runtime
StacktraceTop:
 ?? () from /usr/lib/libasound.so.2
 snd_pcm_close () from /usr/lib/libasound.so.2
 ?? () from /usr/lib/gstreamer-0.10/libgstalsa.so
 ?? () from /usr/lib/libgstaudio-0.10.so.0
 gst_ring_buffer_close_device ()
Title: knotify4 crashed with SIGSEGV in snd_pcm_close()
UserGroups: adm admin audio cdrom dialout dip floppy fuse libvirtd lpadmin plugdev staff video
XsessionErrors: (process:28595): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

Kai Kasurinen (kai-kasurinen) wrote :

StacktraceTop:
 snd_pcm_ioplug_close (pcm=<value optimized out>)
 snd_pcm_close (pcm=0x1841c80) at pcm.c:706
 gst_alsasink_close (asink=<value optimized out>)
 gst_audioringbuffer_close_device (
 gst_ring_buffer_close_device (buf=0x1818340)

Changed in kdebase-runtime (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
visibility: private → public
Jonathan Thomas (echidnaman) wrote :

Is this crash reproducible?

affects: kdebase-runtime (Ubuntu) → phonon-backends (Ubuntu)
Changed in phonon-backends (Ubuntu):
status: New → Incomplete
Kai Kasurinen (kai-kasurinen) wrote :

Yes, I get this every time I plug or unplug power cord.

Changed in phonon-backends (Ubuntu):
status: Incomplete → Triaged
Changed in phonon:
status: Unknown → New
Changed in phonon:
status: New → Invalid
Changed in phonon:
status: Invalid → Unknown
Changed in phonon:
status: Unknown → New
Changed in phonon:
status: New → Confirmed
Changed in phonon:
status: Confirmed → Unknown
Jonathan Thomas (echidnaman) wrote :

Phonon upstream believes that this is a libasound crasher that may have been remedied by http://git.alsa-project.org/?p=alsa-lib.git;a=commitdiff;h=91c9c8f1b85e69b4bdc94a777d2767c4906c3f47 (Post-1.0.23 fix)

affects: phonon-backends (Ubuntu) → alsa-lib (Ubuntu)
Jonathan Thomas (echidnaman) wrote :

Testcase from upstream:

 1. export PHONON_PULSEAUDIO_DISABLE=1
 2. export PHONON_GST_AUDIOSINK=alsasink
 3. dragon somefile.ogg (likely any phonon client will do).

Daniel T Chen (crimsun) wrote :

This is likely the cause behind bug 584393, too.

Changed in alsa-lib (Ubuntu):
assignee: nobody → Daniel T Chen (crimsun)
Daniel T Chen (crimsun) on 2010-08-29
Changed in alsa-lib (Ubuntu):
status: Triaged → Fix Committed
Colin Watson (cjwatson) wrote :

alsa-lib (1.0.23-1ubuntu2) maverick; urgency=low

  * Apply upstream git changesets aadcbab through 72c7260ce
    and rediff debian/patches/relibtoolise.patch
    - correctly free dl handles, fixes LP: #552411, #584393
      (Closes: #589896)

 -- Daniel T Chen <email address hidden> Sun, 29 Aug 2010 13:13:19 -0400

Changed in alsa-lib (Ubuntu):
status: Fix Committed → Fix Released
Changed in phonon:
status: Unknown → Won't Fix
Changed in phonon:
importance: Unknown → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.