Alsa should show more device names in default setup

Bug #425362 reported by David Henningsson on 2009-09-06
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
alsa-lib (Ubuntu)
Wishlist
Daniel T Chen
Maverick
Undecided
Unassigned

Bug Description

Ubuntu Jaunty and/or Karmic:

aplay, among other sound playing & recording utilities, use snd_device_name_hint() to enumerate known devices. However, with the current (inherited from upstream) namehint policy, neither "pulse" or "default" are shown - very valid devices if you ask me. These can be shown if "defaults.namehint.showall" is changed to "on" in /usr/share/alsa/alsa.conf, and possibly ~/.asoundrc.asoundconf as well. Furthermore, the "hw" and "plughw" devices won't be shown until "defaults.namehint.extended" is turned on as well.

So my suggestion is that we turn both "defaults.namehint.extended" and "defaults.namehint.showall" on. I believe it would be better in the long run.

David Henningsson (diwic) wrote :

Or at least the pulse device should show up by default, by providing a proper name hint.

Daniel T Chen (crimsun) on 2010-01-25
Changed in alsa-lib (Ubuntu):
importance: Undecided → Wishlist
status: New → Triaged
Daniel T Chen (crimsun) wrote :

What's the driver for this change? (It won't land for Lucid.) Are applications failing to work properly because of the default settings?

David Henningsson (diwic) wrote :

Valid question. It came up as I was trying to make a device selection combobox for QARecord, which I was working with a while ago. (The code is in QARecord cvs now.)

According to Lennart's "guide to sound API" blog post, snd_device_name_hint() is the API to use for device enumeration. But it didn't show the devices I wanted it to show. I was expecting plughw and/or hw devices for each soundcard, plus the pulse device. Instead I got a lot of different surround options (for a card that does not have more than two physical outputs!). But the most important problem - that the pulse device was not listed - is already fixed.

The driver is that if snd_device_name_hint() is the device enumeration API we should teach people to use (as opposed to snd_card_xxx and snd_config_xxx), we should make it return better results. Programs (e g audacity uses snd_config_xxx, the last time I checked) won't switch to the snd_device_name_hint() API unless the results are right. And currently it seems to be broken in more than one way.

Daniel T Chen (crimsun) on 2010-10-03
Changed in alsa-lib (Ubuntu):
status: Triaged → Fix Committed
assignee: nobody → Daniel T Chen (crimsun)

Accepted alsa-lib into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in alsa-lib (Ubuntu Maverick):
status: New → Fix Committed
tags: added: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package alsa-lib - 1.0.23-2ubuntu1

---------------
alsa-lib (1.0.23-2ubuntu1) natty; urgency=low

  * Merge from debian unstable. Remaining changes:
    - debian/rules:
      + Don't bail when removing include/alsa
    - debian/control: Add Vcs-Bzr URI
    - Add configuration files for bluetooth/bluez-alsa and pulseaudio
    - debian/libasound2.install: Ship smixer plugins for native and bi-arch
      packages
    - drop libcxxtools-dev build dependency, its in universe
    - add --with-plugindir=\$${prefix}/lib/alsa-lib to configure-stamp
    - Demote libc6-i386 pre-depends to depends for lib32asound2
    - correctly free dl handles
  * debian/patches/series: Uncomment debian's thread patches, as our
    relibtoolize.patch encorporates those fixes already, as well as the above
    dl handlers fix, and its a little difficult unraveling them

  [ Daniel T Chen ]
  * Apply upstream git changesets
    0244370 and c049d48 to help fix LP: #652035.
  * lp652035-use-extended-namehints.patch: Show hints for non-standard
    devices that lack configuration files. This patch is also required
    to help fix LP: #652035 and by consequence also addresses
    LP: #425362.

alsa-lib (1.0.23-2) unstable; urgency=medium

  [ Elimar Riesebieter ]
  * Make setlocale() thread safe:
    Applied thread-safe-locale.patch and thread-specific-locale.patch from
    upstream. (Closes: #595252)
  * Bump Standards-Version to 3.9.1, with no changes required.
 -- Luke Yelavich <email address hidden> Sat, 16 Oct 2010 15:05:11 +1100

Changed in alsa-lib (Ubuntu):
status: Fix Committed → Fix Released
Jean-Baptiste Lallement (jibel) wrote :

SRU verification for Maverick:
I have reproduced the problem with alsa-lib 1.0.23-1ubuntu2 in maverick and have verified that the version of alsa-lib 1.0.23-1ubuntu2.1 in -proposed fixes the issue. The following additional devices are listed with the version in proposed (note the default device, pulse was already there)
$ diff -u aplay.release aplay.proposed
--- aplay.release 2010-11-02 10:00:55.350225974 +0100
+++ aplay.proposed 2010-11-02 10:03:38.363838005 +0100
@@ -1,3 +1,4 @@
+default
 pulse
     Playback/recording through the PulseAudio sound server
 front:CARD=I82801AAICH,DEV=0
@@ -18,6 +19,18 @@
 iec958:CARD=I82801AAICH,DEV=0
     Intel 82801AA-ICH, Intel 82801AA-ICH
     IEC958 (S/PDIF) Digital Audio Output
+dmix:CARD=I82801AAICH,DEV=0
+ Intel 82801AA-ICH, Intel 82801AA-ICH
+ Direct sample mixing device
+dsnoop:CARD=I82801AAICH,DEV=0
+ Intel 82801AA-ICH, Intel 82801AA-ICH
+ Direct sample snooping device
+hw:CARD=I82801AAICH,DEV=0
+ Intel 82801AA-ICH, Intel 82801AA-ICH
+ Direct hardware device without any conversions
+plughw:CARD=I82801AAICH,DEV=0
+ Intel 82801AA-ICH, Intel 82801AA-ICH
+ Hardware device with all software conversions

Marking as verification-done

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package alsa-lib - 1.0.23-1ubuntu2.1

---------------
alsa-lib (1.0.23-1ubuntu2.1) maverick-proposed; urgency=low

  * lp652035-fix-missing-hw-devices.patch: Apply upstream git changesets
    0244370 and c049d48 to help fix LP: #652035.
  * lp652035-use-extended-namehints.patch: Show hints for non-standard
    devices that lack configuration files. This patch is also required
    to help fix LP: #652035 and by consequence also addresses
    LP: #425362.
 -- Daniel T Chen <email address hidden> Sun, 03 Oct 2010 14:56:12 -0400

Changed in alsa-lib (Ubuntu Maverick):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers