totem crashed with SIGSEGV when no mixer available

Bug #193679 reported by Stefan Bethge on 2008-02-20
6
Affects Status Importance Assigned to Milestone
alsa-lib (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: totem

When using my Edirol UA25 USB sound card, I can use it fine with jackd.
However, setting it as default sound card or selecting it for the various(?) types of sound types in gnome-sound-properties, and testing the sound in there or running totem or something else will instantly crash the playing program. Testing in gnome-sound-properties plays the test beep sound for a very short time and then crashes with a Segmentation Fault. I suspect this to happen because the ua25 doesn't have a software mixer available. There are no problems with the internal sound card. This was working in previous ubuntu versions (I'm on gutsy).

ProblemType: Crash
Architecture: i386
Date: Wed Feb 20 13:37:22 2008
DistroRelease: Ubuntu 7.10
ExecutablePath: /usr/bin/totem
NonfreeKernelModules: nvidia cdrom
Package: totem-gstreamer 2.20.0-0ubuntu3
PackageArchitecture: i386
ProcCmdline: totem
ProcCwd: /home/stefan
ProcEnviron:
 SHELL=/bin/bash
 PATH=/home/stefan/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=de_DE.UTF-8
Signal: 11
SourcePackage: totem
Stacktrace:
 #0 0xb6c2ec5c in ?? () from /usr/lib/libasound.so.2
 #1 0x00000000 in ?? ()
StacktraceTop:
 ?? () from /usr/lib/libasound.so.2
 ?? ()
Title: totem crashed with SIGSEGV
Uname: Linux munin 2.6.22-14-generic #1 SMP Tue Feb 12 07:42:25 UTC 2008 i686 GNU/Linux
UserGroups: adm admin audio cdrom dialout dip fax floppy fuse kmem lpadmin netdev plugdev powerdev scanner tape video

Stefan Bethge (kjyv) wrote :

StacktraceTop:mix_areas3_cmov (size=1,
snd_pcm_dmix_sync_area (pcm=0x85ff840) at pcm_dmix.c:244
snd_pcm_dmix_start (pcm=0x85ff840) at pcm_dmix.c:539
snd_pcm_start (pcm=0x85ff840) at pcm.c:1047
snd_pcm_generic_start (pcm=0x861f720) at pcm_generic.c:155

Changed in totem:
importance: Undecided → Medium
Daniel T Chen (crimsun) wrote :

Is this symptom still reproducible in 8.10 alpha?

Changed in alsa-lib:
status: New → Incomplete
Stefan Bethge (kjyv) wrote :

I tested the current Intrepid and it seems to be fine. This was another machine though, but that shouldn't have an influence I guess. I will investigate it a bit more but I think it is fine now.

Daniel T Chen (crimsun) on 2009-01-25
Changed in alsa-lib:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers