[SRU] alsa-lib: conf: USB - add "Cmedia Audio" to USB-Audio.pcm.iec958_device

Bug #1921452 reported by Shengyao Xue
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OEM Priority Project
Fix Released
Critical
Shengyao Xue
alsa-lib (Ubuntu)
Fix Released
Low
Unassigned
Bionic
Fix Released
Low
Hui Wang
Focal
Fix Released
Low
Unassigned
Groovy
Fix Released
Low
Unassigned
Hirsute
Fix Released
Low
Unassigned

Bug Description

[Impact]
On Cmedia Audio, unusable SPDIF can be selected as output from PulseAudio.

[Fix]
Disable IEC958 (SPDIF) through ALSA UCM.

[Test]
With the UCM applied, `pactl` and audio panel in gnome-control-center no longer have SPDIF option.

[Where problems will occur]
"Cmedia Audio" is the sound card name of this usb audio dongle, and this string is got from usb string descriptor, that is to say the "Cmedia Audio" is hard-coded in the firmware of that usb dongle.
Not all Cmedia usb audio dongle use "Cmedia Audio", most of the dongles don't set string descriptor, then the audio driver sets a generic name "USB Audio Device" for them, if a dongle has string descriptor, it may have different string like "C-Media USB Headphone Set", and all dongles I met before don't have SPDIF interface.
So If this SRU could introduce regression, it will happen on a Cmedia usb audio dongle which also hard-codes the "Cmedia Audio" in the string descriptor and it has SPDIF interface on it, after this SRU, users couldn't find the SPDIF playback device from the gnome-sound-setting. But this regression chance is very low since it is very rare a cmedia usb audio dongle uses "Cmedia Audio" in the string descriptor and it is very rare a usb audio dongle has SPDIF interface. So far we haven't met such a cmedia usb audio dongle.

Changed in alsa-lib (Ubuntu Hirsute):
assignee: nobody → Shengyao Xue (xueshengyao)
Revision history for this message
Shengyao Xue (xueshengyao) wrote :

This is the debdiff for hirsute, thanks.

Hui Wang (hui.wang)
description: updated
Revision history for this message
Shengyao Xue (xueshengyao) wrote :

This is the debdiff for Groovy, thanks.

Changed in alsa-lib (Ubuntu Groovy):
assignee: nobody → Shengyao Xue (xueshengyao)
Revision history for this message
Shengyao Xue (xueshengyao) wrote :

This is the debdiff for Focal, thanks.

Changed in alsa-lib (Ubuntu Focal):
assignee: nobody → Shengyao Xue (xueshengyao)
no longer affects: alsa-lib
tags: added: oem-priority originate-from-1916751 somerville
tags: added: originate-from-1916753
Changed in oem-priority:
assignee: nobody → Shengyao Xue (xueshengyao)
Changed in oem-priority:
importance: Undecided → Critical
status: New → In Progress
Changed in alsa-lib (Ubuntu Focal):
status: New → In Progress
Changed in alsa-lib (Ubuntu Groovy):
status: New → In Progress
Changed in alsa-lib (Ubuntu Hirsute):
status: New → In Progress
description: updated
description: updated
Mathew Hodson (mhodson)
Changed in alsa-lib (Ubuntu Focal):
importance: Undecided → Low
Changed in alsa-lib (Ubuntu Groovy):
importance: Undecided → Low
Changed in alsa-lib (Ubuntu Hirsute):
importance: Undecided → Low
Changed in alsa-lib (Ubuntu Focal):
assignee: Shengyao Xue (xueshengyao) → nobody
Changed in alsa-lib (Ubuntu Groovy):
assignee: Shengyao Xue (xueshengyao) → nobody
Changed in alsa-lib (Ubuntu Hirsute):
assignee: Shengyao Xue (xueshengyao) → nobody
Revision history for this message
Rex Tsai (chihchun) wrote :

The upstream alia-lib has not yet accepted the patch[1].

Shengyao, Hui, please clarify all "Cmedia Audio" chip does not support "Digital Output(S/PDIF)" as iec958 device.

[1] conf: USB - add "Cmedia Audio" to USB-Audio.pcm.iec958_device by jason77-wang · Pull Request #122 · alsa-project/alsa-lib - https://github.com/alsa-project/alsa-lib/pull/122/commits/879d57d979b59be8632ba788d5f567f2b6ec0c19

Regards
-Rex

Revision history for this message
Hui Wang (hui.wang) wrote :

Updated the [Where problems will occur] part.

description: updated
description: updated
Changed in alsa-lib (Ubuntu Hirsute):
status: In Progress → Fix Committed
Revision history for this message
Sebastien Bacher (seb128) wrote :

Thanks, I will start by sponsoring the fix to hirsute, small nitpicks comment to consider for the next time which I will fix for that round

- 1.2.4-1.1build1ubuntu1 is a bit akward as a version, if we add delta we usually replace 'build' by 'ubuntu', it becomes 1.2.4-1.1ubuntu1

- please include the upstream pull request reference in the patch itself

- ' * conf: USB - add "Cmedia Audio" to USB-Audio.pcm.iec958_device (LP: #1921452)' is formatted like if a file name 'conf' was changed, remove the '*' there

basically reformatted the changelog entry is

' * d/p/0001-conf-USB-add-Cmedia-Audio-to-USB-Audio.pcm.iec958_de.patch:
     conf: USB - add "Cmedia Audio" to USB-Audio.pcm.iec958_device
     (LP: #1921452)'

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package alsa-lib - 1.2.4-1.1ubuntu2

---------------
alsa-lib (1.2.4-1.1ubuntu2) hirsute; urgency=medium

  * d/p/0001-conf-USB-add-Cmedia-Audio-to-USB-Audio.pcm.iec958_de.patch:
    conf: USB - add "Cmedia Audio" to USB-Audio.pcm.iec958_device
    https://github.com/alsa-project/alsa-lib/pull/122 (LP: #1921452)

 -- Shengyao Xue <email address hidden> Fri, 26 Mar 2021 12:03:07 +0800

Changed in alsa-lib (Ubuntu Hirsute):
status: Fix Committed → Fix Released
Revision history for this message
Sebastien Bacher (seb128) wrote :

Uploaded to 20.10 also, there was another SRU done in novembre though, please try to base your changes on the current version, the debdiff didn't apply to that version since it was done on top of the release pocket version instead

Revision history for this message
Shengyao Xue (xueshengyao) wrote :

@seb128, sorry about this, a new version of debdiff for Groovy uploaded, thanks.

Revision history for this message
Timo Aaltonen (tjaalton) wrote : Please test proposed package

Hello Shengyao, or anyone else affected,

Accepted alsa-lib into groovy-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/alsa-lib/1.2.3.2-1ubuntu3.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-groovy to verification-done-groovy. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-groovy. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in alsa-lib (Ubuntu Groovy):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-groovy
Changed in alsa-lib (Ubuntu Focal):
status: In Progress → Fix Committed
tags: added: verification-needed-focal
Revision history for this message
Timo Aaltonen (tjaalton) wrote :

Hello Shengyao, or anyone else affected,

Accepted alsa-lib into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/alsa-lib/1.2.2-2.1ubuntu2.4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Revision history for this message
Shengyao Xue (xueshengyao) wrote :

tested the alsa-lib in groovy-proposed, this issue was fixed. change verification tag to done.

tags: added: verification-done verification-done-focal verification-done-groovy
removed: verification-needed verification-needed-focal verification-needed-groovy
Changed in oem-priority:
status: In Progress → Fix Released
Revision history for this message
Shengyao Xue (xueshengyao) wrote :

tested the alsa-lib in focal-proposed, this issue was fixed. change verification tag to done.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package alsa-lib - 1.2.3.2-1ubuntu3.2

---------------
alsa-lib (1.2.3.2-1ubuntu3.2) groovy; urgency=medium

  * d/p/0001-conf-USB-add-Cmedia-Audio-to-USB-Audio.pcm.iec958_de.patch:
     conf: USB - add "Cmedia Audio" to USB-Audio.pcm.iec958_device
     (LP: #1921452)

 -- Shengyao Xue <email address hidden> Tue, 06 Apr 2021 21:26:31 +0200

Changed in alsa-lib (Ubuntu Groovy):
status: Fix Committed → Fix Released
Revision history for this message
Łukasz Zemczak (sil2100) wrote : Update Released

The verification of the Stable Release Update for alsa-lib has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package alsa-lib - 1.2.2-2.1ubuntu2.4

---------------
alsa-lib (1.2.2-2.1ubuntu2.4) focal; urgency=medium

  * d/p/0001-conf-USB-add-Cmedia-Audio-to-USB-Audio.pcm.iec958_de.patch:
     conf: USB - add "Cmedia Audio" to USB-Audio.pcm.iec958_device
     (LP: #1921452)

 -- Shengyao Xue <email address hidden> Tue, 06 Apr 2021 21:33:31 +0200

Changed in alsa-lib (Ubuntu Focal):
status: Fix Committed → Fix Released
Hui Wang (hui.wang)
Changed in alsa-lib (Ubuntu Bionic):
status: New → In Progress
importance: Undecided → Critical
assignee: nobody → Hui Wang (hui.wang)
Revision history for this message
Hui Wang (hui.wang) wrote :

Subscribe the sponsor team again, since our oem project needs this fix to be landed to bionic too.

This is the debdiff for bionic, please help review and upload

thx.

Changed in alsa-lib (Ubuntu Bionic):
importance: Critical → Low
Revision history for this message
Sebastien Bacher (seb128) wrote :

Upload to the bionic queue now

Changed in alsa-lib (Ubuntu Bionic):
status: In Progress → Fix Committed
Revision history for this message
Brian Murray (brian-murray) wrote : Please test proposed package

Hello Shengyao, or anyone else affected,

Accepted alsa-lib into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/alsa-lib/1.1.3-5ubuntu0.6 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

tags: added: verification-needed verification-needed-bionic
removed: verification-done
Revision history for this message
Hui Wang (hui.wang) wrote :

Installed the ubuntu 18.04 to that Dell machine with usb c-media audio card, enable the -proposed channel and install the alsa-lib 1.1.3-5ubuntu0.6, reboot, open the gnome-sound-setting, there is no SPDIF in the output device anymore.

Verified on the bionic, it worked very well.

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package alsa-lib - 1.1.3-5ubuntu0.6

---------------
alsa-lib (1.1.3-5ubuntu0.6) bionic; urgency=medium

  * d/p/0021-conf-USB-add-Cmedia-Audio-to-USB-Audio.pcm.iec958_de.patch
    https://github.com/alsa-project/alsa-lib/pull/122
    Add "Cmedia Audio" to USB-Audio.pcm.iec958_device, otherwise users
    will see 2 IEC985 devices from UI, but there is no those physical
    devices in fact. After adding this patch, those 2 IEC985 devices will
    not show up in the UI. (LP: #1921452)

 -- Hui Wang <email address hidden> Tue, 22 Jun 2021 10:01:54 +0000

Changed in alsa-lib (Ubuntu Bionic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers