[SRU][Lenovo ThinkPad T14 Gen 1] No sound output device on startup

Bug #1901922 reported by Johan Segerstedt on 2020-10-28
84
This bug affects 23 people
Affects Status Importance Assigned to Milestone
ALSA Libraries
Fix Released
Undecided
Unassigned
alsa-lib (Ubuntu)
Status tracked in Hirsute
Focal
High
Hui Wang
Groovy
High
Hui Wang
Hirsute
High
Hui Wang
alsa-ucm-conf (Ubuntu)
Status tracked in Hirsute
Focal
High
Hui Wang
Groovy
High
Hui Wang
Hirsute
High
Hui Wang

Bug Description

[Impact]
On the machines with AMD Ryzen acp audio design, the audio can't work
anymore after upgrading the libasound2 to ubuntu3(groovy)/ubuntu2.1(
focal), this is a regression on libasound2 for those machines. the AMD
Ryzen acp audio card needs to load ucm to work with pulseaudio, but
this audio card doesn't have an independant ucm for it, it needs to
link to an existing HDA-Intel ucm, the check_empty_configuration() needs
to cover the situation that Linked is true, otherwise it will fail
to load the ucm for the audio card. Even the audio card could load the
ucm, the output is muted and the init output volume is too low if
freshly install the OS on these machines.

[Fix]
Backport 1 alsa-lib patch to fix the failure of loading ucm on AMD
Ryzen acp audio machines. Backport 4 alsa-ucm-conf patches to fix
init mute and init output volume problem.

[Test Case]
Install the updated libasuond2, rm ~/.config/pulse/*; sudo rm -rf
/var/lib/alsa/*; sudo sh -c 'echo b > /proc/sysrq-trigger' and run pacmd
list-cards, we could see the pulseaudio load the ucm successfully and we could see
the sound card is generated and all output and input devices are listed
under sound card, but the init output is muted and the volume is very low
if we manually unumte it. Now install the updated alsa-ucm-conf, rm ~/.config/pulse/*; sudo rm -rf
/var/lib/alsa/*; sudo sh -c 'echo b > /proc/sysrq-trigger', the output is
not muted anymore and the output volume is OK to most users.

[Regression Risk]
This could make the machines with sof audio driver fail to load ucm
, then all audio function can't work as before, like the speaker can't
output sound or the internal mic can't be found or can't record sound.
But this possibility is very low, I tested this SRU on some machines with or
without sof audio driver, all worked as well as before.

After logging in, only a dummy device is available for audio playback (resulting in no audible playback). When running "pactl load-module module-detect" the sound card shows up, and playback works as expected.

If pulseaudio is restarted with "pulseaudio -k" the playback device disappears again. Running the above command get things working again.

If I change the following section in /etc/pulse/default.pa from:

### Automatically load driver modules depending on the hardware available
.ifexists module-udev-detect.so
load-module module-udev-detect
.else
### Use the static hardware detection module (for systems that lack udev support)
load-module module-detect
.endif

To:

### Automatically load driver modules depending on the hardware available
#.ifexists module-udev-detect.so
#load-module module-udev-detect
#.else
### Use the static hardware detection module (for systems that lack udev support)
load-module module-detect
#.endif

Things start working as they should after running "pulseaudio -k".

ProblemType: Bug
DistroRelease: Ubuntu 20.10
Package: pulseaudio 1:13.99.2-1ubuntu1
ProcVersionSignature: Ubuntu 5.8.0-26.27-generic 5.8.14
Uname: Linux 5.8.0-26-generic x86_64
ApportVersion: 2.20.11-0ubuntu50
Architecture: amd64
CasperMD5CheckResult: skip
CurrentDesktop: KDE
Date: Wed Oct 28 17:21:02 2020
InstallationDate: Installed on 2020-10-23 (4 days ago)
InstallationMedia: Kubuntu 20.10 "Groovy Gorilla" - Release amd64 (20201022)
SourcePackage: pulseaudio
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 08/07/2020
dmi.bios.release: 1.9
dmi.bios.vendor: LENOVO
dmi.bios.version: R1BET40W(1.09 )
dmi.board.asset.tag: Not Available
dmi.board.name: 20UDCTO1WW
dmi.board.vendor: LENOVO
dmi.board.version: Not Defined
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: None
dmi.ec.firmware.release: 1.9
dmi.modalias: dmi:bvnLENOVO:bvrR1BET40W(1.09):bd08/07/2020:br1.9:efr1.9:svnLENOVO:pn20UDCTO1WW:pvrThinkPadT14Gen1:rvnLENOVO:rn20UDCTO1WW:rvrNotDefined:cvnLENOVO:ct10:cvrNone:
dmi.product.family: ThinkPad T14 Gen 1
dmi.product.name: 20UDCTO1WW
dmi.product.sku: LENOVO_MT_20UD_BU_Think_FM_ThinkPad T14 Gen 1
dmi.product.version: ThinkPad T14 Gen 1
dmi.sys.vendor: LENOVO

summary: - No sound output device on startup
+ [Lenovo ThinkPad T14 Gen 1] No sound output device on startup

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in pulseaudio (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, could you report the issue upstream on https://gitlab.freedesktop.org/pulseaudio/pulseaudio/-/issues ?

Changed in pulseaudio (Ubuntu):
importance: Undecided → Low

@seb128 , upstream (pulseaudio) asks whether it would be possible to test an Ubuntu build of the pulseaudio 13.99.3 package by us. Are you able to provide a 13.99.3 pulseaudio packages for us to test?

Daniel van Vugt (vanvugt) wrote :

Yes we plan on it eventually (bug 1902485).

Sebastien Bacher (seb128) wrote :

I've uploaded the new version to hirsute and a groovy build in the ppa there

https://launchpad.net/~ubuntu-desktop/+archive/ubuntu/ppa/

@seb128 Thank you for the build in the ppa! Can you please publish the binaries so we can update pulseaudio the standard way?

I can confirm that the issue still persists with pulseaudio 13.99.3 from the ppa. Will report details upstream.

Another thing that brings the soundcard correctly up is running the following sequence of commands:

udevadm control --reload-rules && udevadm trigger

I took a snapshot of the /dev tree before and after the command. There are no significant differences.

Sorry for doubler post, I forgot to add attachment.

Hui Wang (hui.wang) wrote :

I built a testing package of libasound2 for 20.10, please install and test it:

sudo add-apt-repository ppa:hui.wang/pa-testing
sudo apt install libasound2

This will install the alsa-lib 1.2.3.2-1ubuntu3+testamd

reboot.

The issue seems so far resolved by the testing package. After two full power cycles (power off, disconnect power, power on, reconnect power) the audio still works!

The testing package of libasound2 built by @hui.wang has resolved the issue for me as well. Thank you!

Upstream notes that some errors are still not resolved by this fix:

Nov 8 18:34:15 determinist pulseaudio[2219]: error: failed to import hw:0 (empty configuration)
Nov 8 18:34:15 determinist pulseaudio[2219]: error: failed to import HD-Audio Generic (empty configuration)

However these errors do not directly impact functionality of sound input and output.

Upstream notes that these remaining errors should be resolved once we are on alsa-lib 1.2.4.

affects: pulseaudio (Ubuntu) → alsa-lib (Ubuntu)
Changed in alsa-lib (Ubuntu):
assignee: nobody → Hui Wang (hui.wang)
status: Confirmed → In Progress
Hui Wang (hui.wang) on 2020-11-09
Changed in alsa-ucm-conf (Ubuntu):
status: New → In Progress
importance: Undecided → Low
assignee: nobody → Hui Wang (hui.wang)
Changed in alsa-ucm-conf (Ubuntu Groovy):
status: New → In Progress
Changed in alsa-ucm-conf (Ubuntu Focal):
status: New → In Progress
Changed in alsa-ucm-conf (Ubuntu Groovy):
importance: Undecided → Low
Changed in alsa-ucm-conf (Ubuntu Focal):
importance: Undecided → High
Changed in alsa-ucm-conf (Ubuntu Groovy):
importance: Low → High
Changed in alsa-ucm-conf (Ubuntu Hirsute):
importance: Low → High
Changed in alsa-lib (Ubuntu Hirsute):
importance: Low → High
Changed in alsa-lib (Ubuntu Focal):
importance: Undecided → High
Changed in alsa-lib (Ubuntu Groovy):
importance: Undecided → High
status: New → In Progress
Changed in alsa-lib (Ubuntu Focal):
status: New → In Progress
assignee: nobody → Hui Wang (hui.wang)
Changed in alsa-lib (Ubuntu Groovy):
assignee: nobody → Hui Wang (hui.wang)
Changed in alsa-ucm-conf (Ubuntu Focal):
assignee: nobody → Hui Wang (hui.wang)
Changed in alsa-ucm-conf (Ubuntu Groovy):
assignee: nobody → Hui Wang (hui.wang)
Hui Wang (hui.wang) wrote :

This is the alsa-lib debdiff for groovy.

thx.

Hui Wang (hui.wang) wrote :

This is the alsa-lib debdiff for focal.

thx.

Hui Wang (hui.wang) wrote :

This is the alsa-ucm-conf debdiff for groovy.

thx.

Hui Wang (hui.wang) wrote :

This is the alsa-ucm-conf debdiff for focal.

Thx.

Hui Wang (hui.wang) wrote :

I checked the docker image hub, there is no ubuntu hirsute image yet, so I didn't generate debdiff for hirsute, maybe H and G share the same debdiff?

Please let me know if need a debdiff for H, I will download the daily built image and find a machine to install it and generate the debdiff.

thx.

Hui Wang (hui.wang) on 2020-11-09
summary: - [Lenovo ThinkPad T14 Gen 1] No sound output device on startup
+ [SRU][Lenovo ThinkPad T14 Gen 1] No sound output device on startup
description: updated
rud (jazco) wrote :

I reported this today, didn't realise an extensive bug report already exists:
https://bugs.launchpad.net/ubuntu/+source/alsa-lib/+bug/1903570

Lenovo S540-13ARE (AMD Ryzen 4800u).

Sebastien Bacher (seb128) wrote :

> Please let me know if need a debdiff for H, I will download the daily built image and find a machine to install it and generate the debdiff.

No it's fine, I've changed the 20.10 version to ubuntu3.1 and uploaded the debdiff from the bug to hirsute (no need to install hirsute to be able to generate the debdiff btw, especially not that earlier in the cycle, it can be built fine on 20.10)

I've uploaded alsa-lib to F, G, H now, ucm is next in the queue

Changed in alsa-lib (Ubuntu Focal):
status: In Progress → Fix Committed
Changed in alsa-lib (Ubuntu Groovy):
status: In Progress → Fix Committed
Changed in alsa-lib (Ubuntu Hirsute):
status: In Progress → Fix Committed
Changed in alsa-ucm-conf (Ubuntu Hirsute):
status: In Progress → Fix Committed
Changed in alsa-ucm-conf (Ubuntu Groovy):
status: In Progress → Fix Committed
Changed in alsa-ucm-conf (Ubuntu Focal):
status: In Progress → Fix Committed
Changed in alsa-ucm-conf (Ubuntu Hirsute):
status: Fix Committed → Fix Released
Changed in alsa-ucm-conf (Ubuntu Hirsute):
status: Fix Released → Fix Committed

Sorry on my part, the last change to the status was a mistake and was not intended. Unfortunately, I cannot reverse it myself

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package alsa-ucm-conf - 1.2.2-1ubuntu6

---------------
alsa-ucm-conf (1.2.2-1ubuntu6) hirsute; urgency=medium

  * d/p/0001-sof-hda-dsp-add-initial-kcontrol-values.patch
  * d/p/0002-sof-hda-dsp-make-the-boot-init-optional-for-all-cont.patch
  * d/p/0003-sof-hda-dsp-Set-Master-Playback-Switch-on-in-the-Boo.patch
  * d/p/0004-sof-hda-dsp-Increase-the-speaker-output-volume-in-th.patch
    Unmute the master playback switch and increase the init output volume,
    otherwise the playback will be muted after freshly install the OS if
    the machine uses ucm to configure the audio mixers, and the init playback
    output volume is too low after freshly install the OS.
    (LP: #1901922)

 -- Hui Wang <email address hidden> Mon, 09 Nov 2020 03:59:02 +0000

Changed in alsa-ucm-conf (Ubuntu Hirsute):
status: Fix Committed → Fix Released

Hello Johan, or anyone else affected,

Accepted alsa-lib into groovy-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/alsa-lib/1.2.3.2-1ubuntu3.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-groovy to verification-done-groovy. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-groovy. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

tags: added: verification-needed verification-needed-groovy
tags: added: verification-needed-focal
Timo Aaltonen (tjaalton) wrote :

Hello Johan, or anyone else affected,

Accepted alsa-lib into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/alsa-lib/1.2.2-2.1ubuntu2.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Timo Aaltonen (tjaalton) wrote :

Hello Johan, or anyone else affected,

Accepted alsa-ucm-conf into groovy-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/alsa-ucm-conf/1.2.2-1ubuntu5.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-groovy to verification-done-groovy. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-groovy. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Timo Aaltonen (tjaalton) wrote :

Hello Johan, or anyone else affected,

Accepted alsa-ucm-conf into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/alsa-ucm-conf/1.2.2-1ubuntu0.5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Nick Price (dominotree) wrote :

Did a fresh install of Groovy on an affected machine and updated it to the latest release packages first, and confirmed the audio issue still existed.

I then installed the packages above and rebooted, and audio seems to be working as expected on that system now.

I think that did the trick!

Nick Price (dominotree) wrote :

Oh, as mentioned elsewhere, the microphone light on the keyboard doesn't seem to turn off/on as expected, but this may be an issue elsewhere (FWIW it works as expected under a current Fedora install on this system)

Nick Price (dominotree) on 2020-11-14
tags: added: verification-done-groovy
removed: verification-needed-groovy

All autopkgtests for the newly accepted alsa-lib (1.2.2-2.1ubuntu2.2) for focal have finished running.
The following regressions have been reported in tests triggered by the package:

openjdk-8/8u275-b01-0ubuntu1~20.04 (armhf)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/focal/update_excuses.html#alsa-lib

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

All autopkgtests for the newly accepted alsa-lib (1.2.3.2-1ubuntu3.1) for groovy have finished running.
The following regressions have been reported in tests triggered by the package:

openjdk-8/8u275-b01-0ubuntu1~20.10 (armhf)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/groovy/update_excuses.html#alsa-lib

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

Jrandiny (jrandiny) wrote :

Hi, I have tested the updated package on Focal and it solved my problem (Lenovo Yoga Slim 7 AMD 4800u)

Florian Beier (devopsguy) wrote :

I can confirm that the updated packages fix the issue for me (Groovy on a ThinkPad T14 w/ Ryzen 7 Pro 4750U). However, the LED on the keyboard for muting the microphone (on the F4 key) doesn't work for the internal microphone. It works as expected when another microphone is present and selected as input device (I plugged a headset into the audio jack).

I, too, confirm that the proposed updates solve the audio issue (for my system info, please see the initial information in the bug report).

cgampert (cgampert) wrote :

Hello, the focal-proposed 1.2.2-2.1ubuntu2.2 package solved the issue as far I could test; indeed, the audio output device was present after the multiple reboots or boot-ups I did.

System: yoga slim 7 4800u / ubuntu 20.04

Nick Price (dominotree) on 2020-11-15
tags: added: verification-done-focal
removed: verification-needed-focal
tags: removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package alsa-lib - 1.2.3.2-1ubuntu4

---------------
alsa-lib (1.2.3.2-1ubuntu4) hirsute; urgency=medium

  * d/p/0001-ucm-handle-correctly-Linked-configuration.patch
    - If the sound card is Linked in the ucm, don't return error
      in the check_empty_configuration(). So far the AMD Ryzen
      machines with acp sound card need this fix, otherwise the
      pulseaudio will fail to load ucm on those machines and the whole
      audio can't work. (LP: #1901922)

 -- Hui Wang <email address hidden> Mon, 09 Nov 2020 06:26:27 +0000

Changed in alsa-lib (Ubuntu Hirsute):
status: Fix Committed → Fix Released
Hui Wang (hui.wang) wrote :

Tested the alsa-ucm-conf 1.2.2-1ubuntu0.5 On the Lenovo T14 AMD ryzen machine, the init output is not muted anymore after install the OS, without installing the 1.2.2-1ubuntu0.5 version, the init output is muted.

Verified done for alsa-ucm-conf 1.2.2-1ubuntu0.5 in the focal.

Hui Wang (hui.wang) wrote :

Same as the #39, also verified alsa-ucm-conf 1.2.2-1ubuntu5.1 in the groovy too, it worked too.

Mathew Hodson (mhodson) on 2020-11-22
affects: pulseaudio → alsa-lib
Changed in alsa-lib:
importance: Unknown → Undecided
status: Unknown → New
status: New → Fix Released

The verification of the Stable Release Update for alsa-lib has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package alsa-ucm-conf - 1.2.2-1ubuntu0.5

---------------
alsa-ucm-conf (1.2.2-1ubuntu0.5) focal; urgency=medium

  * d/p/0001-sof-hda-dsp-add-initial-kcontrol-values.patch
  * d/p/0002-sof-hda-dsp-make-the-boot-init-optional-for-all-cont.patch
  * d/p/0003-sof-hda-dsp-Set-Master-Playback-Switch-on-in-the-Boo.patch
  * d/p/0004-sof-hda-dsp-Increase-the-speaker-output-volume-in-th.patch
    Unmute the master playback switch and increase the init output volume,
    otherwise, the playback will be muted after freshly install the OS if
    the machine uses ucm to configure the audio mixers, and the init playback
    output volume is too low after freshly install the OS.
    (LP: #1901922)

 -- Hui Wang <email address hidden> Mon, 09 Nov 2020 12:06:50 +0800

Changed in alsa-ucm-conf (Ubuntu Focal):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package alsa-lib - 1.2.3.2-1ubuntu3.1

---------------
alsa-lib (1.2.3.2-1ubuntu3.1) groovy; urgency=medium

  * d/p/0001-ucm-handle-correctly-Linked-configuration.patch
    - If the sound card is Linked in the ucm, don't return error
      in the check_empty_configuration(). So far the AMD Ryzen
      machines with acp sound card need this fix, otherwise the
      pulseaudio will fail to load ucm on those machines and the whole
      audio can't work. (LP: #1901922)

 -- Hui Wang <email address hidden> Mon, 09 Nov 2020 06:26:27 +0000

Changed in alsa-lib (Ubuntu Groovy):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package alsa-ucm-conf - 1.2.2-1ubuntu5.1

---------------
alsa-ucm-conf (1.2.2-1ubuntu5.1) groovy; urgency=medium

  * d/p/0001-sof-hda-dsp-add-initial-kcontrol-values.patch
  * d/p/0002-sof-hda-dsp-make-the-boot-init-optional-for-all-cont.patch
  * d/p/0003-sof-hda-dsp-Set-Master-Playback-Switch-on-in-the-Boo.patch
  * d/p/0004-sof-hda-dsp-Increase-the-speaker-output-volume-in-th.patch
    Unmute the master playback switch and increase the init output volume,
    otherwise the playback will be muted after freshly install the OS if
    the machine uses ucm to configure the audio mixers, and the init playback
    output volume is too low after freshly install the OS.
    (LP: #1901922)

 -- Hui Wang <email address hidden> Mon, 09 Nov 2020 03:59:02 +0000

Changed in alsa-ucm-conf (Ubuntu Groovy):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package alsa-lib - 1.2.2-2.1ubuntu2.2

---------------
alsa-lib (1.2.2-2.1ubuntu2.2) focal; urgency=medium

  * d/p/0001-ucm-handle-correctly-Linked-configuration.patch
    - If the sound card is Linked in the ucm, don't return error
      in the check_empty_configuration(). So far the AMD Ryzen
      machines with acp sound card need this fix, otherwise the
      pulseaudio will fail to load ucm on those machines and the whole
      audio can't work. (LP: #1901922)

 -- Hui Wang <email address hidden> Mon, 09 Nov 2020 14:53:11 +0800

Changed in alsa-lib (Ubuntu Focal):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers