[SRU][Intel HDA] The initial sound level is set to zero (muted)

Bug #1897934 reported by fossfreedom on 2020-09-30
38
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Unassigned
alsa-lib (Ubuntu)
Critical
Hui Wang
Focal
Critical
Hui Wang
Groovy
Critical
Hui Wang

Bug Description

[Impact]
Fail to run '/usr/sbin/alsactl restore' on the HDA-Intel machines, this
results in the failure on setting the init mixer values for HDA sound
card, and users experience the mute of audio after installing the 20.10.

[Fix]
Backport a patch from the latest alsa-lib (v1.2.3+)

[Test]
Without the patched alsa-lib, rm ~/.config/pulse/*;sudo rm /var/lib/alsa/*;
sudo sh -c "echo b > /proc/sysrq-trigger", after booting up, the audio is
muted.

Install the patched alsa-lib, rm ~/.config/pulse/*;sudo rm /var/lib/alsa/*;
sudo sh -c "echo b > /proc/sysrq-trigger", after booting up, the audio is
not muted.

[Regression Potential]
This could make the ucm audio fail to initialize, but this possibility is
very low, since this patch is from upstream, and I tested on a ucm based
machine, the audio is good.

On boot into the live session - or on first install the sound level is muted.

I have to use GNOME Control Center - Sounds to change to an appropriate level. Once changed the level chosen is correctly retained between reboots.

This appears to be a regression from 20.04 where the sound level was set to - I guess - 80% on the live-session/first install

ProblemType: BugDistroRelease: Ubuntu 20.10
Package: pulseaudio 1:13.99.1-1ubuntu11
ProcVersionSignature: Ubuntu 5.8.0-20.21-generic 5.8.10
Uname: Linux 5.8.0-20-generic x86_64
NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
ApportVersion: 2.20.11-0ubuntu48
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu-budgie 5041 F.... pulseaudio
CasperMD5CheckResult: pass
CasperVersion: 1.452
CurrentDesktop: Budgie:GNOME
Date: Wed Sep 30 16:03:08 2020
LiveMediaBuild: Ubuntu-Budgie 20.10 "Groovy Gorilla" - Beta amd64 (20200930)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bashSourcePackage: pulseaudio
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 02/15/2016
dmi.bios.release: 15.31
dmi.bios.vendor: Insyde
dmi.bios.version: F.1F
dmi.board.asset.tag: Type2 - Board Asset Tag
dmi.board.name: 80BF
dmi.board.vendor: HP
dmi.board.version: 95.16
dmi.chassis.asset.tag: Chassis Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: HP
dmi.chassis.version: Chassis Version
dmi.ec.firmware.release: 95.22
dmi.modalias: dmi:bvnInsyde:bvrF.1F:bd02/15/2016:br15.31:efr95.22:svnHP:pnHPNotebook:pvr:rvnHP:rn80BF:rvr95.16:cvnHP:ct10:cvrChassisVersion:
dmi.product.family: 103C_5335KV G=N L=CON B=HP
dmi.product.name: HP Notebook
dmi.product.sku: N9S73EA#ABU
dmi.sys.vendor: HP

fossfreedom (fossfreedom) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1897934

tags: added: iso-testing
Łukasz Zemczak (sil2100) wrote :

How was this in 20.04? Since you mentioned that it's a regression from 18.04 - does this mean we had it like this in focal as well?

Hi Lukasz,

  on 20.04.1 the sound level is correct (tested on the ISO).

So its only 20.10 where the sound level starts at zero.

On Thu, 1 Oct 2020 at 11:30, Łukasz Zemczak <email address hidden> wrote:
>
> How was this in 20.04? Since you mentioned that it's a regression from
> 18.04 - does this mean we had it like this in focal as well?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1897934
>
> Title:
> The initial sound level is set to zero (mute)
>
> Status in pulseaudio package in Ubuntu:
> New
>
> Bug description:
> On boot into the live session - or on first install the sound level is
> muted.
>
> I have to use GNOME Control Center - Sounds to change to an
> appropriate level. Once changed the level chosen is correctly
> retained between reboots.
>
> This appears to be a regression from 18.04 where the sound level was
> set to - I guess - 80% on the live-session/first install
>
> ProblemType: Bug
> DistroRelease: Ubuntu 20.10
> Package: pulseaudio 1:13.99.1-1ubuntu11
> ProcVersionSignature: Ubuntu 5.8.0-20.21-generic 5.8.10
> Uname: Linux 5.8.0-20-generic x86_64
> NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
> ApportVersion: 2.20.11-0ubuntu48
> Architecture: amd64
> AudioDevicesInUse:
> USER PID ACCESS COMMAND
> /dev/snd/controlC0: ubuntu-budgie 5041 F.... pulseaudio
> CasperMD5CheckResult: pass
> CasperVersion: 1.452
> CurrentDesktop: Budgie:GNOME
> Date: Wed Sep 30 16:03:08 2020
> LiveMediaBuild: Ubuntu-Budgie 20.10 "Groovy Gorilla" - Beta amd64 (20200930)
> ProcEnviron:
> TERM=xterm-256color
> PATH=(custom, no user)
> XDG_RUNTIME_DIR=<set>
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> SourcePackage: pulseaudio
> UpgradeStatus: No upgrade log present (probably fresh install)
> dmi.bios.date: 02/15/2016
> dmi.bios.release: 15.31
> dmi.bios.vendor: Insyde
> dmi.bios.version: F.1F
> dmi.board.asset.tag: Type2 - Board Asset Tag
> dmi.board.name: 80BF
> dmi.board.vendor: HP
> dmi.board.version: 95.16
> dmi.chassis.asset.tag: Chassis Asset Tag
> dmi.chassis.type: 10
> dmi.chassis.vendor: HP
> dmi.chassis.version: Chassis Version
> dmi.ec.firmware.release: 95.22
> dmi.modalias: dmi:bvnInsyde:bvrF.1F:bd02/15/2016:br15.31:efr95.22:svnHP:pnHPNotebook:pvr:rvnHP:rn80BF:rvr95.16:cvnHP:ct10:cvrChassisVersion:
> dmi.product.family: 103C_5335KV G=N L=CON B=HP
> dmi.product.name: HP Notebook
> dmi.product.sku: N9S73EA#ABU
> dmi.sys.vendor: HP
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/1897934/+subscriptions

summary: - The initial sound level is set to zero (mute)
+ [HP 14-ac100na] The initial sound level is set to zero (mute)
summary: - [HP 14-ac100na] The initial sound level is set to zero (mute)
+ [HP 14-ac100na N9S73EA#ABU] The initial sound level is set to zero
+ (mute)

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in alsa-driver (Ubuntu):
status: New → Confirmed
Changed in pulseaudio (Ubuntu):
status: New → Confirmed
Bill (franksmcb) (franksmcb) wrote :

This is occurring on 20.10 Ubuntu MATE 20201021.2

Bill (franksmcb) (franksmcb) wrote :

This breaks Screen Reader installs for Visually impaired users and breaks testcase #1305

description: updated
Norbert (nrbrtx) wrote :

Tested the Ubuntu and Ubuntu MATE 20201021.2 ISOs on Lenovo SL500.

This bug breaks whole LiveDVD experience.
The installer does not play greeting sound.

The sound can be unmuted from `alsamixer`, but it is unexpected at all.

Should be fixed before final release.

summary: - [HP 14-ac100na N9S73EA#ABU] The initial sound level is set to zero
- (mute)
+ The initial sound level is set to zero (mute)

I'm not entirely certain this is a great test case but given that the sound is not 0% with Ubuntu 20.04 LTS, I believe it is.

kvm -m 4096 -boot d -cdrom ubuntu-20.04-desktop-amd64.iso -nic none -soundhw hda -hda /srv/vms/groovy.qcow2

Sound is not at 0.

kvm -m 4096 -boot d -cdrom groovy-desktop-amd64.iso -nic none -soundhw hda -hda /srv/vms/groovy.qcow2

Sound is at 0, with both of these I was using the Ubuntu Desktop iso.

Steve Langasek (vorlon) wrote :

The alsa-driver package hasn't changed since 2015. This is almost certainly either a pulseaudio bug or a kernel bug.

Changed in alsa-driver (Ubuntu):
status: Confirmed → Invalid
Chris Guiver (guiverc) wrote :

Just an FYI.

I noticed this first 09-25 (that I can see from comments on IRC) with a Xubuntu QA-test (most will be in comments in QA-test reports on iso.qa.ubuntu.com), only recently added a much later report is (now a duplicate of this).

I got the impression the value (sound volume) wasn't always consistent (I mainly test Lubuntu) and seemed box specific.. It'd changed mid-late September, but I never considered this a big concern (no responses whenever I asked on IRC, or to my lp bug report) so I never explored it much. It was easily worked around I felt.

summary: - The initial sound level is set to zero (mute)
+ The initial sound level is set to zero (muted)
affects: alsa-driver (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
status: Invalid → New

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1897934

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Changed in linux (Ubuntu):
importance: Undecided → Low
Changed in pulseaudio (Ubuntu):
importance: Undecided → Low
summary: - The initial sound level is set to zero (muted)
+ [Intel HDA] The initial sound level is set to zero (muted)

FYI comment on sound: (made after seeing comments in #ubuntu-desktop)

Lubuntu 20.04.1 on my dell 755-5 (duplicate report 1899719) boots & has sound (volume is at 45%)

As stated before, I only noted the change occurring ~25 Sept 2020 (there was quite a bit of the groovy cycle where I couldn't boot ISOs though on my older boxes which may impact that date)

Changed in linux (Ubuntu):
assignee: nobody → Kai-Heng Feng (kaihengfeng)
status: Incomplete → In Progress
Changed in linux (Ubuntu):
assignee: Kai-Heng Feng (kaihengfeng) → Hui Wang (hui.wang)
Łukasz Zemczak (sil2100) wrote :

I disagree with the importance of this bug being 'Low'. This is very important from the accessibility point of view - with the sound muted, it is not possible to properly use the screen reader for installation, live session or after boot, requiring a visually impaired person to fist figure out how to bring the volume back up.
If we can't fix it before release, too bad, we'll live. But certainly from the release POV it's a rather critical bug.

Changed in linux (Ubuntu):
importance: Low → Critical
Changed in pulseaudio (Ubuntu):
importance: Low → Critical
Norbert (nrbrtx) wrote :

Below is apport-collect for Asustek UX32A. Sharing this to help you to debug the problem as a good will.

tags: added: apport-collected

ProblemType: Bug
ApportVersion: 2.20.11-0ubuntu50
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu-mate 5107 F.... pulseaudio
CasperMD5CheckResult: pass
CasperVersion: 1.455
CurrentDesktop: MATE
DistroRelease: Ubuntu 20.10
LiveMediaBuild: Ubuntu-MATE 20.10 "Groovy Gorilla" - Release amd64 (20201021.2)
MachineType: ASUSTeK COMPUTER INC. UX32A
NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
Package: pulseaudio 1:13.99.2-1ubuntu1
PackageArchitecture: amd64
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 i915drmfb
ProcKernelCmdLine: BOOT_IMAGE=/casper/vmlinuz file=/cdrom/preseed/username.seed maybe-ubiquity quiet splash ---
ProcVersionSignature: Ubuntu 5.8.0-25.26-generic 5.8.14
RelatedPackageVersions:
 linux-restricted-modules-5.8.0-25-generic N/A
 linux-backports-modules-5.8.0-25-generic N/A
 linux-firmware 1.190
Tags: groovy
Uname: Linux 5.8.0-25-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin lxd plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 02/12/2014
dmi.bios.release: 4.6
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: UX32A.216
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: UX32A
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: 1.0
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK COMPUTER INC.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrUX32A.216:bd02/12/2014:br4.6:svnASUSTeKCOMPUTERINC.:pnUX32A:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnUX32A:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0:
dmi.product.family: UX
dmi.product.name: UX32A
dmi.product.sku: ASUS-NotebookSKU
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK COMPUTER INC.

apport information

Norbert (nrbrtx) wrote : CRDA.txt

apport information

apport information

apport information

apport information

Norbert (nrbrtx) wrote : Lspci.txt

apport information

apport information

Norbert (nrbrtx) wrote : Lsusb.txt

apport information

Norbert (nrbrtx) wrote : Lsusb-t.txt

apport information

Norbert (nrbrtx) wrote : Lsusb-v.txt

apport information

Norbert (nrbrtx) wrote : PaInfo.txt

apport information

apport information

apport information

apport information

apport information

Norbert (nrbrtx) wrote : RfKill.txt

apport information

Norbert (nrbrtx) wrote : UdevDb.txt

apport information

apport information

apport information

Can somebody confirm if they had issue with VirtualBox as well? I tried on virt-manager and default volume is muted but when I tried on virtualbox, volume was normal (at about 80%). I am testing on Ubuntu MATE 20201021.2

Norbert (nrbrtx) wrote :

Below is apport-collect for Lenovo SL500.

ProblemType: Bug
ApportVersion: 2.20.11-0ubuntu50
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu-mate 4795 F.... pulseaudio
CasperMD5CheckResult: pass
CasperVersion: 1.455
CurrentDesktop: MATE
DistroRelease: Ubuntu 20.10
LiveMediaBuild: Ubuntu-MATE 20.10 "Groovy Gorilla" - Release amd64 (20201021.2)
MachineType: LENOVO 27463ZG
NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
Package: pulseaudio 1:13.99.2-1ubuntu1
PackageArchitecture: amd64
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 i915drmfb
ProcKernelCmdLine: BOOT_IMAGE=/casper/vmlinuz file=/cdrom/preseed/username.seed maybe-ubiquity quiet splash ---
ProcVersionSignature: Ubuntu 5.8.0-25.26-generic 5.8.14
RelatedPackageVersions:
 linux-restricted-modules-5.8.0-25-generic N/A
 linux-backports-modules-5.8.0-25-generic N/A
 linux-firmware 1.190
Tags: groovy
Uname: Linux 5.8.0-25-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin lxd plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 12/01/2010
dmi.bios.release: 6.15
dmi.bios.vendor: LENOVO
dmi.bios.version: 6AET64WW
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: 27463ZG
dmi.board.vendor: LENOVO
dmi.board.version: LENOVO 6AET64WW
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: LENOVO 6AET64WW
dmi.ec.firmware.release: 177.3
dmi.modalias: dmi:bvnLENOVO:bvr6AET64WW:bd12/01/2010:br6.15:efr177.3:svnLENOVO:pn27463ZG:pvrThinkPadSL500:rvnLENOVO:rn27463ZG:rvrLENOVO6AET64WW:cvnLENOVO:ct10:cvrLENOVO6AET64WW:
dmi.product.name: 27463ZG
dmi.product.version: ThinkPad SL500
dmi.sys.vendor: LENOVO

apport information

Norbert (nrbrtx) wrote : CRDA.txt

apport information

apport information

apport information

apport information

Norbert (nrbrtx) wrote : Lspci.txt

apport information

apport information

Norbert (nrbrtx) wrote : Lsusb.txt

apport information

Norbert (nrbrtx) wrote : Lsusb-t.txt

apport information

Norbert (nrbrtx) wrote : Lsusb-v.txt

apport information

Norbert (nrbrtx) wrote : PaInfo.txt

apport information

apport information

apport information

apport information

apport information

Norbert (nrbrtx) wrote : RfKill.txt

apport information

Norbert (nrbrtx) wrote : UdevDb.txt

apport information

apport information

apport information

I reproduced the bug, and this is a alsa-lib's issue, and the latest alsa-lib already has the fix. Let me test it and backport it to groovy and maybe focal.

affects: linux (Ubuntu) → alsa-lib (Ubuntu)
no longer affects: pulseaudio (Ubuntu)
Hui Wang (hui.wang) on 2020-10-22
Changed in alsa-lib (Ubuntu Focal):
assignee: nobody → Hui Wang (hui.wang)
status: New → In Progress
importance: Undecided → Critical
Hui Wang (hui.wang) wrote :

This is the debdiff for groovy.

summary: - [Intel HDA] The initial sound level is set to zero (muted)
+ [SRU][Intel HDA] The initial sound level is set to zero (muted)
Hui Wang (hui.wang) wrote :

The debdiff for focal, let us wait for groovy to be tested and pass.

description: updated
Sebastien Bacher (seb128) wrote :

Thanks Hui, I've sponsored the fix to G, let's see how it goes there

Changed in alsa-lib (Ubuntu Groovy):
status: In Progress → Fix Committed
Iain Lane (laney) wrote :

I don't see the same problem on the Focal ISO - do we need to fix this in Focal?

Changed in alsa-lib (Ubuntu Focal):
status: In Progress → Incomplete
Sebastien Bacher (seb128) wrote :

(the upload got rejected since it was already uploaded by someone who didn't bother updating the bug)

Hui Wang (hui.wang) wrote :

@Iain,

For focal, after we merge this SRU: https://bugs.launchpad.net/ubuntu/+source/alsa-utils/+bug/1899745, we will have this bug too. But for focal, the #1899745 will not be in the iso, so users will not notice this problem. If we merge #1899745 to 20.04.2 iso, users will meet this bug.

So for focal, this fix is not very urgent, even we merge the #1899745, it will not introduce this issue immediately.

Iain Lane (laney) wrote :

ah I see, OK - I will upload, thanks!

can you update the test case to say that this version of alsa-utils is needed please? maybe provide a PPA link for people to install it with, until that is accepted into focal?

Changed in alsa-lib (Ubuntu Focal):
status: Incomplete → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package alsa-lib - 1.2.3.2-1ubuntu3

---------------
alsa-lib (1.2.3.2-1ubuntu3) groovy; urgency=medium

  * d/p/0001-ucm-add-a-check-for-the-empty-configuration.patch
  - Fix the failure on init the HDA-Intel sound card, because there
    is no init mixer values in the ucm, the alsa-lib should return
    error and then let alsautils init this sound card in the legacy
    HDA way. (LP: #1897934)

 -- Hui Wang <email address hidden> Thu, 22 Oct 2020 16:46:14 +0800

Changed in alsa-lib (Ubuntu Groovy):
status: Fix Committed → Fix Released
Download full text (4.2 KiB)

I can confirm that sound is no longer muted for the ISO and is not muted on
installation.

So thanks and congrats!

On Thu, 22 Oct 2020, 14:30 Launchpad Bug Tracker, <
<email address hidden>> wrote:

> This bug was fixed in the package alsa-lib - 1.2.3.2-1ubuntu3
>
> ---------------
> alsa-lib (1.2.3.2-1ubuntu3) groovy; urgency=medium
>
> * d/p/0001-ucm-add-a-check-for-the-empty-configuration.patch
> - Fix the failure on init the HDA-Intel sound card, because there
> is no init mixer values in the ucm, the alsa-lib should return
> error and then let alsautils init this sound card in the legacy
> HDA way. (LP: #1897934)
>
> -- Hui Wang <email address hidden> Thu, 22 Oct 2020 16:46:14 +0800
>
> ** Changed in: alsa-lib (Ubuntu Groovy)
> Status: Fix Committed => Fix Released
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1897934
>
> Title:
> [SRU][Intel HDA] The initial sound level is set to zero (muted)
>
> Status in Release Notes for Ubuntu:
> New
> Status in alsa-lib package in Ubuntu:
> Fix Released
> Status in alsa-lib source package in Focal:
> Fix Committed
> Status in alsa-lib source package in Groovy:
> Fix Released
>
> Bug description:
> [Impact]
> Fail to run '/usr/sbin/alsactl restore' on the HDA-Intel machines, this
> results in the failure on setting the init mixer values for HDA sound
> card, and users experience the mute of audio after installing the
> 20.10.
>
> [Fix]
> Backport a patch from the latest alsa-lib (v1.2.3+)
>
> [Test]
> Without the patched alsa-lib, rm ~/.config/pulse/*;sudo rm
> /var/lib/alsa/*;
> sudo sh -c "echo b > /proc/sysrq-trigger", after booting up, the audio is
> muted.
>
> Install the patched alsa-lib, rm ~/.config/pulse/*;sudo rm
> /var/lib/alsa/*;
> sudo sh -c "echo b > /proc/sysrq-trigger", after booting up, the audio is
> not muted.
>
> [Regression Potential]
> This could make the ucm audio fail to initialize, but this possibility is
> very low, since this patch is from upstream, and I tested on a ucm based
> machine, the audio is good.
>
>
> On boot into the live session - or on first install the sound level is
> muted.
>
> I have to use GNOME Control Center - Sounds to change to an
> appropriate level. Once changed the level chosen is correctly
> retained between reboots.
>
> This appears to be a regression from 20.04 where the sound level was
> set to - I guess - 80% on the live-session/first install
>
> ProblemType: BugDistroRelease: Ubuntu 20.10
> Package: pulseaudio 1:13.99.1-1ubuntu11
> ProcVersionSignature: Ubuntu 5.8.0-20.21-generic 5.8.10
> Uname: Linux 5.8.0-20-generic x86_64
> NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
> ApportVersion: 2.20.11-0ubuntu48
> Architecture: amd64
> AudioDevicesInUse:
> USER PID ACCESS COMMAND
> /dev/snd/controlC0: ubuntu-budgie 5041 F.... pulseaudio
> CasperMD5CheckResult: pass
> CasperVersion: 1.452
> CurrentDesktop: Budgie:GNOME
> Date: Wed Sep 30 16:03:08 2020
> LiveMediaBuild: Ubuntu-Budgie 20.10 "Groovy Gorilla" - Beta amd64
> (202009...

Read more...

Bill (franksmcb) (franksmcb) wrote :

This is confirmed working correctly on Ubuntu MATE with 20201022 re-spin.

Changed in ubuntu-release-notes:
status: New → Invalid
Hui Wang (hui.wang) wrote :

Because there is an alsa-lib SRU for focal in the queue already (#1899857), I will submit the SRU of this bug for focal after #1899857 is put in the -proposed.

Hello fossfreedom, or anyone else affected,

Accepted alsa-lib into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/alsa-lib/1.2.2-2.1ubuntu2.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

tags: added: verification-needed verification-needed-focal

All autopkgtests for the newly accepted alsa-lib (1.2.2-2.1ubuntu2.1) for focal have finished running.
The following regressions have been reported in tests triggered by the package:

asterisk/1:16.2.1~dfsg-2ubuntu1 (armhf)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/focal/update_excuses.html#alsa-lib

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

Hui Wang (hui.wang) wrote :

Verified focal version 1.2.2-2.1ubuntu2.1 on the machine with legacy HDA audio design:

Installed the alsa-utils 1.2.2-1ubuntu2,
rm ~/.config/pulse/*;sudo rm /var/lib/alsa/*;
sudo sh -c "echo b > /proc/sysrq-trigger", after booting up, the audio is muted.

Installed the proposed libasound2 1.2.2-2.1ubuntu2.1, repeat the above steps, the audio is not muted anymore.

Verified Pass on the machine with legacy HDA audio design.

tags: added: verification-done verification-done-focal
removed: verification-needed verification-needed-focal
Hui Wang (hui.wang) wrote :

About the #72, I opened the URL, can't find any error on asterisk/1:16.2.1~dfsg-2ubuntu1 (armhf) introduced by new alsa-lib (1.2.2-2.1ubuntu2.1), looks like rebuild make the error disappear.

The verification of the Stable Release Update for alsa-lib has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package alsa-lib - 1.2.2-2.1ubuntu2.1

---------------
alsa-lib (1.2.2-2.1ubuntu2.1) focal; urgency=medium

  * d/p/0001-ucm-add-a-check-for-the-empty-configuration.patch
  - Fix the failure on init the HDA-Intel sound card, because there
    is no init mixer values in the ucm, the alsa-lib should return
    error and then let alsautils init this sound card in the legacy
    HDA way. (LP: #1897934)

 -- Hui Wang <email address hidden> Thu, 22 Oct 2020 11:50:50 +0100

Changed in alsa-lib (Ubuntu Focal):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers