the audio can't work on Lenovo machines with dual analogue codecs under ubuntu 18.04

Bug #1768830 reported by Hui Wang on 2018-05-03
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
HWE Next
Undecided
Unassigned
alsa-lib (Ubuntu)
Critical
Hui Wang
Bionic
Undecided
Unassigned

Bug Description

Steps:
1. Install the ubuntu 18.04 on the machine of Lenovo P520.
2. Login system.
3. Plug in an external headset to record and playback in front and rear panel.

Expected result:
Output and input audio should work in front and rear panel.

Actual result:
Front panel audio doesn't work at all.
Just output audio working, input audio does't work in rear panel.

SRU Document:

[Impact]

We have several Lenovo machines like Lenovo P520 which have 2 analogue audio codecs on them, the internal speaker and front headset are connected to the 1st codec, the Rear mic, Line in and Line out are connected to the 2nd codec. So far, under ubuntu 18.04 with the alsa-lib/libasound2 v1.1.3-5, only the audio devices (internal speaker and front headset) on the 1st codec can work. To make all audio devices work on this machine, upstream provided 3 patches for kernel audio driver and 5 patches for alsa-lib. The kernel patches are already in the linux-4.12, so this is not a problem anymore under 18.04 since we use linux-4.15 in 18.04. For the 5 patches of alsa-lib, we need to backport them to v1.1.3-5, the 5 patches are list as below:

2b9b3f01 ucm: Assure the user input card name not to exceed max size of card long name (it is in the alsa-lib v1.1.4)
4b9297e6 ucm: Load device-specific configuration file based on the card long name (it is in the alsa-lib v1.1.4)
b7e56af8 conf/ucm: Add dual HD-audio codecs config for Lenovo (it is in the alsa-lib v1.1.6)
181f8e25 ucm: adding the folder of card_long_name when finding verb conf file (it is in the alsa-lib v1.1.6+)
81db276f conf/ucm: increase the input volume for LineIn (it is in the alsa-lib v1.1.6+)

Some explanation for these 5 patches, to make the audio work, the alsa-lib needs to add an audio configuration file and verb conf file for lenovo machines with dual codecs, these two files are put in a folder named by card_long_name, and the name of configuration file itself is also named by card_long_name, this is implemented by the patches of NO. 3rd and 5th.

But the alsa-lib v1.1.3-5 itself doesn't support to search conf file with card_long_name, it only support searching with card_name, So we need to backport 3 patches to let alsa-lib v1.1.3-5 support to search with card_long_name, these 3 patches are No. 1st, 2nd and 4th.

[Test Case]

On the Lenovo machines with dual codecs (p520), I insatlled the libasound2 v1.1.3-5ubuntu1 and libasound2-data v1.1.3-5ubuntu1, the alsa-lib can find the conf file and can parse the conf file successfully, and I tested the internal speaker, front headset, rear mic, line out and line in, all audio devices work well.

On a HP and Dell machines without dual codecs, I insatlled the libasound2 v1.1.3-5ubuntu1 and libasound2-data v1.1.3-5ubuntu1, the alsa-lib can't find conf file by card_long_name and card_name, the pulseaudio will drive the sound card as before, so all audio functions worked well as before.

[Regression Potential]

After adding these 5 patches, there 2 two changes introduced into the alsa-lib v1.1.3-5ubuntu1:

1) before: only have folder and conf files named by card_name; after: has one folder and conf file named by card_long_name, this folder and conf file will not affect others,
2) before: the ucm parser will search the conf file/folder by card_name only; after: the ucm parser will search the conf file/foler by card_long_name first, if it fails, it will fallback to use card_name to search again. So this change is compatible with old version.

There is no regression since there is only one folder named by card_long_name in v1.1.3-5ubuntu1, if it runs on lenovo machine with dual codecs, it will find the conf file by card_long_name, if it runs on other machines, the search by card_long_name will definitely fail and fall back to search by card_name, then it will be same as before. So the objective of these 5 patches is to let lenovo machines with dual codecs find the conf file by card_long_name, let other machines fail to search by card_long_name, then fallback to original searching method - search by card_name.

[Other Info]

Since I could not find the alsa-lib repository in canonical, I just generated the debdiff with "apt-get source ...".

Hui Wang (hui.wang) on 2018-05-03
affects: pulseaudio (Ubuntu) → alsa-lib (Ubuntu)
summary: - the audio can't work on Lenovo machines with dual analogue cocecs
- underubuntu 18.04
+ the audio can't work on Lenovo machines with dual analogue codecs under
+ ubuntu 18.04
tags: added: originate-from-1735041 sutton
Hui Wang (hui.wang) wrote :

This tarball file contains those 5 patches mentioned in the bug description.

description: updated
Hui Wang (hui.wang) on 2018-05-04
Changed in alsa-lib (Ubuntu):
assignee: nobody → Hui Wang (hui.wang)
Hui Wang (hui.wang) wrote :

This is the debdiff. Sponsor team, please help submit the build request to the queue.

thx.

description: updated
Timo Aaltonen (tjaalton) wrote :

looks like two of the patches are not in cosmic yet, which has 1.1.6-1

Hui Wang (hui.wang) wrote :

This is the debdiff for cosmic. Backported the 2 patches to 1.1.6-1.

thanks.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package alsa-lib - 1.1.6-1ubuntu1

---------------
alsa-lib (1.1.6-1ubuntu1) cosmic; urgency=medium

  * debian/patches/0008-ucm-adding-the-folder-of-card_long_name-when-finding.patch
  * debian/patches/0009-conf-ucm-increase-the-input-volume-for-LineIn.patch
     - Backport 2 patches to make audio work on Lenovo machines with dual codecs.
       (LP: #1768830)

 -- Hui Wang <email address hidden> Tue, 08 May 2018 03:28:26 +0000

Changed in alsa-lib (Ubuntu):
status: New → Fix Released
Timo Aaltonen (tjaalton) on 2018-05-09
Changed in alsa-lib (Ubuntu Bionic):
status: New → In Progress
Hui Wang (hui.wang) wrote :

I installed cosmic daily build 0509, the alsa-lib is 1.1.6-1ubuntu1, it worked well.

Waiting for the bionic 1.1.3-5ubuntu1 to be ready.

Hello Hui, or anyone else affected,

Accepted alsa-lib into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/alsa-lib/1.1.3-5ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in alsa-lib (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-bionic
Hui Wang (hui.wang) wrote :

Tested 1.1.3-5ubuntu0.1 on bionic, it worked well and fixed the problem.

thx.

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic

An upload of tomcat8 to bionic-proposed has been rejected from the upload queue for the following reason: "Invalid bug in the .changes file - changelog mentions #1765616 but Launchpad-Bugs-Fixed: 1768830 (different).".

Łukasz Zemczak (sil2100) wrote :

(please ignore the rejection comment above - someone put the wrong bug number in an SRU so the rejection comment got included here instead)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package alsa-lib - 1.1.3-5ubuntu0.1

---------------
alsa-lib (1.1.3-5ubuntu0.1) bionic; urgency=medium

  * debian/patches/0009-ucm-Assure-the-user-input-card-name-not-to-exceed-ma.patch
  * debian/patches/0010-ucm-Load-device-specific-configuration-file-based-on.patch
  * debian/patches/0011-conf-ucm-Add-dual-HD-audio-codecs-config-for-Lenovo.patch
  * debian/patches/0012-ucm-adding-the-folder-of-card_long_name-when-finding.patch
  * debian/patches/0013-conf-ucm-increase-the-input-volume-for-LineIn.patch
    - Backport 5 patches to make audio work on Lenovo machines with dual audio
      codecs. (LP: #1768830)
      0009-xxx.patch: 2b9b3f01
      0010-xxx.patch: 4b9297e6
      0011-xxx.patch: b7e56af8 (minor change for fixing patch conflict)
      0012-xxx.patch: 181f8e25 (minor change for fixing patch conflict)
      0013-xxx.patch: 81db276f

 -- Hui Wang <email address hidden> Fri, 04 May 2018 09:15:08 +0800

Changed in alsa-lib (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for alsa-lib has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Changed in hwe-next:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments