Incorrect plugin directory for lib32asound2

Bug #145645 reported by Juan Ignacio Saitua on 2007-09-27
14
Affects Status Importance Assigned to Milestone
alsa-lib (Ubuntu)
Undecided
Unassigned

Bug Description

lib32asound2 is looking for plugins in /usr/lib/alsa-lib/ instead of /usr/lib32/alsa-lib. This happens in feisty and gutsy.

The attached patch changes the "with-plugindir" configuration option to /usr/lib32/alsa-lib (only for the 32 bits build).

BTW: there's no lib32asound2-plugins package, so meanwhile, and with this patch, you can copy a 32 bits /usr/lib/alsa-lib directory to /usr/lib32/alsa-lib of a 64 bits installation and it should work (I tested it on amd64).

Thanks.

Related branches

Changed in alsa-lib:
status: New → Fix Committed
maitrechang (fake2) wrote :

Also the status is "Fix Commited", it appears that it's not.

I'ld like to say that this bug is important because it prevents any 32 bits app (game, skype...) from being used along with an alsa plugin (pulseaudio etc).

maitrechang (fake2) wrote :

NB : alsa-lib-1.0.13 (feisty) does not support the with-plugindir option

Juan Ignacio Saitua (jisaitua) wrote :

maitrechang: You are right. The "with-plugindir" option is present in alsa-lib-1.0.14 (gutsy) and not in alsa-lib-1.0.13 (feisty).
So this patch applies only to gutsy.

Daniel T Chen (crimsun) on 2007-10-28
Changed in alsa-lib:
status: Fix Committed → Confirmed
Daniel T Chen (crimsun) wrote :

alsa-lib (1.0.15-2ubuntu1) hardy; urgency=low

  * Merge from Debian unstable.
  * Ubuntu-specific changes:
    - debian/libasound2.p{ostinst,rerm}: Install,remove update-notifier
      file, respectively;
    - debian/control: Add lpia to supported arches, adhere to
      DebianMaintainerField.
  * Dmix/dsnoop no longer use sockets (LP: #85157).
  * Biarch plugins support fixed (LP: #145645).

 -- Daniel T Chen <email address hidden> Sat, 01 Dec 2007 18:50:12 -0500

Changed in alsa-lib:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers