error: unknown type name ”u_int8_t” when building

Bug #1174429 reported by Tomi Leppänen on 2013-04-29
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
alsa-lib (Ubuntu)
Undecided
Unassigned
Raring
Undecided
Unassigned

Bug Description

[Impact]
Other programs FTBFS due to an error in libasound development headers.

[Test]
See below

[Regression potential]
Minimal

I tried to build MythTV (0.25) and I got following error:
In file included from /usr/include/alsa/asoundlib.h:49:0,
                 from libavdevice/alsa-audio-enc.c:40:
/usr/include/alsa/pcm.h:944:1: virhe: unknown type name ”u_int8_t”
/usr/include/alsa/pcm.h:945:1: virhe: unknown type name ”u_int16_t”
/usr/include/alsa/pcm.h:946:1: virhe: unknown type name ”u_int32_t”
/usr/include/alsa/pcm.h:947:1: virhe: unknown type name ”u_int64_t”
In file included from /usr/include/alsa/asoundlib.h:49:0,
                 from libavdevice/alsa-audio-enc.c:40:
/usr/include/alsa/pcm.h:1052:1: virhe: unknown type name ”int16_t”
In file included from /usr/include/alsa/asoundlib.h:49:0,
                 from libavdevice/alsa-audio-common.c:31:
/usr/include/alsa/pcm.h:944:1: virhe: unknown type name ”u_int8_t”
/usr/include/alsa/pcm.h:945:1: virhe: unknown type name ”u_int16_t”
/usr/include/alsa/pcm.h:946:1: virhe: unknown type name ”u_int32_t”
/usr/include/alsa/pcm.h:947:1: virhe: unknown type name ”u_int64_t”
In file included from /usr/include/alsa/asoundlib.h:49:0,
                 from libavdevice/alsa-audio-common.c:31:
This seems like a bug to me. There is an older bug about this problem in alsa-lib. It's #1109298 but it's "fix released".

The file is from package:
libasound2-dev:
  Installed: 1.0.25-4ubuntu3
  Candidate: 1.0.25-4ubuntu3
  Version table:
 *** 1.0.25-4ubuntu3 0
        500 http://archive.ubuntu.com/ubuntu/ raring/main amd64 Packages
        100 /var/lib/dpkg/status

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: libasound2-dev 1.0.25-4ubuntu3
ProcVersionSignature: Ubuntu 3.8.0-19.29-generic 3.8.8
Uname: Linux 3.8.0-19-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.9.2-0ubuntu8
Architecture: amd64
Date: Mon Apr 29 20:23:32 2013
InstallationDate: Installed on 2011-07-14 (655 days ago)
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=fi_FI.UTF-8
 SHELL=/bin/bash
SourcePackage: alsa-lib
UpgradeStatus: Upgraded to raring on 2013-04-24 (5 days ago)

Tomi Leppänen (tomin) wrote :
David Henningsson (diwic) wrote :

Confirmed - the sys_types_include patch suddenly does not apply, but the build system seems to ignore this (hmm?)

Changed in alsa-lib (Ubuntu):
status: New → Triaged

David, you weren't looking at the most recent content in lp:~ubuntu-audio-dev/alsa-lib/ubuntu were you? Prior to raring being released, I (probably inadvertently) updated that branch to 1.0.26, although we never followed through with updating raring to 1.0.26. The patch has been applied upstream as you know...

Anyway, things are cleaned up in lp:~ubuntu-audio-dev/ubuntu.raring now, and checking both the source package generated from that, as well as the build log from launchpad, the sys_includes_type patch is indeed applied.

David Henningsson (diwic) wrote :

Hmm, looking deeper at this issue, it seems that we're patching asoundlib.h, but asoundlib.h is dynamically generated during build (from asoundlib-head.h and other files), so our patched file is overwritten, which is why asoundlib.h ends up not having the patch.

Do you think this warrants an SRU?

Luke Yelavich (themuso) wrote :

On Thu, May 02, 2013 at 06:22:47PM EST, David Henningsson wrote:
> Hmm, looking deeper at this issue, it seems that we're patching
> asoundlib.h, but asoundlib.h is dynamically generated during build (from
> asoundlib-head.h and other files), so our patched file is overwritten,
> which is why asoundlib.h ends up not having the patch.
>
> Do you think this warrants an SRU?

Possibly, as this could very well bite other, and possibly proprietary, third parties who try and build against ALSA.

Luke

David Henningsson (diwic) wrote :

@Luke, ok, I've prepared an SRU and pushed to lp:~ubuntu-audio-dev/alsa-lib/ubuntu.raring

Feel free to sponsor - not sure if you prefer to upload 1.0.27 to Saucy first or just this particular fix.

description: updated
Changed in alsa-lib (Ubuntu):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package alsa-lib - 1.0.25-4ubuntu4

---------------
alsa-lib (1.0.25-4ubuntu4) saucy; urgency=low

  * sys_types_include.patch: Use the upstrea version of this patch.
    (LP: #1174429)
 -- Luke Yelavich <email address hidden> Mon, 06 May 2013 13:09:15 +1000

Changed in alsa-lib (Ubuntu):
status: In Progress → Fix Released

Hello Tomin, or anyone else affected,

Accepted alsa-lib into raring-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/alsa-lib/1.0.25-4ubuntu3.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Changed in alsa-lib (Ubuntu Raring):
status: New → Fix Committed
Tomi Leppänen (tomin) wrote :

Works great. Thanks.
libasound2-dev:
  Asennettu: 1.0.25-4ubuntu3.1
  Ehdokas: 1.0.25-4ubuntu3.1
  Versiotaulukko:
 *** 1.0.25-4ubuntu3.1 0
        100 /var/lib/dpkg/status
     1.0.25-4ubuntu3 0
        500 http://archive.ubuntu.com/ubuntu/ raring/main amd64 Packages

tags: added: verification-done
removed: verification-needed
Johnny Arthur (ubuntu-hwbqs69) wrote :

Hallo,
probably i am totally wrong here, but i had some unexpected behaviour when installing these packages from proposed.

Background:
i am suffering from Bug https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1169984, ie. there was no hdmi output available. For this reason i installed the new proposed kernel in proposed, that should fix it. I also installed the proposed alsa-packages, as i was not sure, whether they would be necessary too.
HDMI worked then as expected, but after some time - always listening to internet radio - the x-window-system froze: The mouse did no longer respond nor most of the keyboard commands. The internet radio however continued playing. The only things i could do in this state were:
- terminate the X-Server using Ctrl-Alt-Backspace and then logging in again.
- switching to console and back (logging into my user account in the text console even brought the internet radio back!)
This happened to me several times.
Today i reinstalled the "old" packages manually and it did not happen again (for now).
There was absolutely nothing relevant in syslog, kern.log and Xorg.0.log.

Hope, it's not too confusing... Once again, probably the failures were just a coincidence and not really related to those updates. But how can we know? Maybe the combination of HDMI-Output with the newest proposed kernel and these new alsa-lib's should be tested by other users? I listened to internet radio (http://gffstream.ic.llnwd.net/stream/gffstream_w13b) using vlc.

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package alsa-lib - 1.0.25-4ubuntu3.1

---------------
alsa-lib (1.0.25-4ubuntu3.1) raring-proposed; urgency=low

  * Replace sys_types_include.patch with upstream version,
    because that version works. (LP: #1174429)
 -- David Henningsson <email address hidden> Fri, 03 May 2013 09:39:59 +0200

Changed in alsa-lib (Ubuntu Raring):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers