[meta-bug] Invalid extra "Digital output S/PDIF" device for USB cards

Bug #1002952 reported by David Henningsson
96
This bug affects 20 people
Affects Status Importance Assigned to Milestone
alsa-lib (Ubuntu)
Confirmed
Undecided
Unassigned

Bug Description

=== Read me first ===

= Symptom =

If you have a USB headset, or other USB device that does not have any S/PDIF output, but yet sometimes there is an extra device called "Digital Output (S/PDIF)" for that device, you're suffering from this bug.

This bug is only for USB devices - if you have an invalid digital output for some other type of device, please file a separate bug instead.

= Workaround =

If you're affected, please try this workaround:

first check the output of "aplay -l" (lowercase L), or "arecord -l" if it's an input device, and grab the first of two name in brackets:

Example:
card 3: Headset [Sennheiser USB Headset], device 0: USB Audio [USB Audio]
here grab the name "Sennheiser USB Headset". Now edit the file /usr/share/alsa/cards/USB-Audio.conf (requires root permissions)
Around line 40, you will find a line saying "Logitech USB Headset" 999
Add a new line after this line, so that there is now a new line called
"Sennheiser USB Headset" 999
(including quotes, and replace "Sennheiser USB Headset" with whatever your particular card was named.)

Save the file and reboot your computer for the changes to take effect.

= Already known devices =

These card names are already in 12.04:

"Blue Snowball"
"Logitech USB Headset"
"Logitech Web Camera"

These card names are on their way into 12.04:

"Logitech Speaker Lapdesk N700"
"Logitech Wireless Headset"
"Plantronics USB Headset"
"Sennheiser USB headset"

If you have one of the above four, please help out by testing the proposed repository and report back in bug 987163.

If your name is not listed above, please add a comment to this bug, including your alsa-info: https://wiki.ubuntu.com/Audio/AlsaInfo - they will be collected for a SRU later on, or at least make it into the next release of Ubuntu.

Thanks!

Revision history for this message
Robert Hooker (sarvatt) wrote :

This is also happening with my headset

http://sarvatt.com/headset.png

Revision history for this message
Josh Holland (jshholland) wrote :

I was seeing this until the workaround worked, and adding "Plantronics GameCom 780" to USB-Audio.conf worked. alsa-info: http://www.alsa-project.org/db/?f=8a11d4256bdba3defb7e014f7f39b51506dd0cd8.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in alsa-lib (Ubuntu):
status: New → Confirmed
Revision history for this message
Randall Ross (randall) wrote :

I'm apparently affected by this bug.
My USB device is a Mackie ProFX12 mixer.

randall@machine:/$ lsusb
Bus 003 Device 006: ID 08bb:29b3 Texas Instruments Japan PCM2903B Audio CODEC

I have submitted the ALSA info here:
http://www.alsa-project.org/db/?f=c00eed2162c85b6b38be4660fe760559b2a333a6

Thank you for alerting me to this bug, and for your help.

Revision history for this message
Vadim Peretokin (vperetokin) wrote :

I have a USB wireless headset that I use, and I do have "Digital Output (S/PDIF) Built-in Audio" showing, even when headset receiver is not plugged in. When I plug it in, I get two of those entries, except it says "Plantronics Wireless Audio" instead of built-in. It has worked for playing sound through it. I also have an "Analogue Output" from Plantronics Wireless Audio listed. The headset does have a mic.

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC889 Analog [ALC889 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 1: ALC889 Digital [ALC889 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 7: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 8: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 9: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: Audio [Plantronics Wireless Audio], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

$ arecord -l
**** List of CAPTURE Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC889 Analog [ALC889 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 2: ALC889 Analog [ALC889 Analog]
  Subdevices: 2/2
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
card 2: Audio [Plantronics Wireless Audio], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

I'm not sure about applying the workaround because the digital output does work for me, and I don't want to break it.

Revision history for this message
David Henningsson (diwic) wrote :

"USB Audio CODEC" sounded a little too generic to add to that list (maybe the same name is used in other contexts where digital in/out exists), but I've picked up the other three and sent to upstream. I'll wait some more (for more devices to show up in this bug) before trying to push it into Ubuntu through an SRU.
Thanks!

Revision history for this message
Randall Ross (randall) wrote :

@David,
I recall seeing the device properly identified at/around 12.04 LTS release time, though I don't have the means to revert to check it again. Evidently between now and then something changed.

Revision history for this message
David Henningsson (diwic) wrote :

@Randall, the nature of the bug is such that the S/PDIF device does not always appear. But with the fix/workaround I'm proposing, you get rid of it all the time.

Revision history for this message
Chris (chris-secondfoundation) wrote :

The same is needed for the Jabra / GN Netcom DECT Phone + USB Sound Headset series:

Add

"GN 9350" 999

to /usr/share/alsa/cards/USB-Audio.conf

to the "USB-Audio.pcm.iec958_device { ... }" section and reboot.

I had wired mouse behaviour. No left click anymore ....

~$ cat /proc/asound/cards
 0 [NVidia ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xf7080000 irq 17
 1 [G9350 ]: USB-Audio - GN 9350
                      GN Netcom GN 9350 at usb-0000:00:1d.0-1.1, full speed

~$ aplay -l
Karte 1: G9350 [GN 9350], Gerät 0: USB Audio [USB Audio]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0

Revision history for this message
Chris (chris-secondfoundation) wrote :

Taking back my comment #9 from above. It just takes longer for the problem to appear.

So it must be an additional problem somewhere besides the entry in USB-Audio.conf.

Symptom:

- plugin usb headset
- headset gets listed in lsubs and aplay -l
- after a while (seconds or minutes) left mouse button stops working
- unplug usb headset
- mouse button works again

Revision history for this message
Orangedouble (blahblahstuff) wrote :
Revision history for this message
Jason Eggleston (jason-k4cybxwf60f) wrote :

I have the problems described here exactly, but I have this:

$ cat /proc/asound/cards
 0 [PCH ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xf7620000 irq 61
 1 [P7xx ]: USB-Audio - Plantronics Savi 7xx
                      Plantronics Plantronics Savi 7xx at usb-0000:00:1d.0-1.2, full speed
 2 [NVidia ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xf7080000 irq 17

I added the device to /usr/share/alsa/cards/USB-Audio.conf:

USB-Audio.pcm.iec958_device {
        # "NoiseBlaster 3000" 42

        # The below don't have digital in/out, so prevent them from being opened.
        "Blue Snowball" 999
        "Logitech Speaker Lapdesk N700" 999
        "Logitech USB Headset" 999
        "Logitech Web Camera" 999
        "Logitech Wireless Headset" 999
        "Plantronics USB Headset" 999
        "Sennheiser USB headset" 999
        "Plantronics Savi 7xx" 999
}

restarted, and I have the same problem. I cannot scroll, click windows, etc.

http://www.alsa-project.org/db/?f=2cdb64452838d6ee90613bfe22e9fa00e9ebe048

Revision history for this message
Daniel Castro (castromd) wrote :

@Chris.

I too have a Jabra GN9350e and I also get the weird mouse behavior. Not sure if it has anything to do with this bug at all.

A work-around I found so far is to make sure the base is set to 'PC' mode before you plug it to the USB port.

Revision history for this message
Miro Collasta (miro-collas) wrote :

I have this issue with a Jabra GN9330. I tried the woraround suggested in the inital post, but it doesn't help, sadly.

http://www.alsa-project.org/db/?f=1b19dd8181011c206b41c6aa78e59dea13ee6a1c

In short, if I detach the headset from the base, I immediately lose the left mouse button, and I have found no way of restoring it short of rebooting. Frustrating since I now cannot use the headeset at all.

Revision history for this message
Miro Collasta (miro-collas) wrote :

If your left mouse button dies when you detach your headset from its base, try the solution here:
https://bbs.archlinux.org/viewtopic.php?id=127699
That worked for me and one other person:
http://forums.linuxmint.com/viewtopic.php?f=49&t=109530&p=618983

Revision history for this message
Alan.Chen (hom691123) wrote :

My usb speaker also has the same problem .

Revision history for this message
Jon (doogie544) wrote :

I had this problem after the workaround my headset is working as well as the mic.

I am using a" HP Digital Stereo Headset" with Ubuntu 12.04

the alsa info is uploaded to

http://www.alsa-project.org/db/?f=9963b1f050d0249405d72f274aaaaefae675e683

Revision history for this message
David Henningsson (diwic) wrote :

@Alan Chen, unfortunately the name "USB AUDIO" is too generic to add. Sorry.

@Jon, thanks, I've upstreamed "HP Digital Stereo Headset".

Revision history for this message
Fabien Cortina (fabien.cortina) wrote :

I have a Jabra GN 9330 like user in comment #14, but adding the line:

    "GN 9330" 999

to the /usr/share/alsa/cards/USB-Audio.conf file did the trick.

Revision history for this message
Siarhei Dudzin (siarhei-dudzin) wrote :

A new device not listed in the OP:

"SWTOR Gaming Headset by Razer"

http://www.alsa-project.org/db/?f=c37695917a20550a364ffcd4dc9ed2af71b9ceeb

Revision history for this message
David Sowerby (david-sowerby) wrote :

Added "Andrea PureAudio USB-SA Headset" 999 at line 47, and SPDIF entry has been removed from sound settings inputs, but is still there for outputs

alsa info:

http://www.alsa-project.org/db/?f=9256809b3ec7ba8e79ce65303dbab91f00465fdc

Revision history for this message
Luis Angel Estebanez (unixtreme) wrote :

Bug confirmed for Trust 5.1 headphones.

Device is listed as "USB Sound Device" (generic name).

The proposed workaround fixed the issue, please find attached alsa info.

http://www.alsa-project.org/db/?f=1990ae45d29a75caa927351101c3295dc12ea616

Revision history for this message
Erik Engstrom (esengstrom) wrote :

Bug confirmed for Logitech h540

Device is listed as "USB-Audio - Logitech USB Headset H540"

The proposed workaround fixed the issue.

Revision history for this message
p_tony (p-tony) wrote :
Revision history for this message
Erigami (erigami) wrote :

Logitech wireless headset (h600). Listed as "Logitech Logitech Wireless Headset"

http://www.alsa-project.org/db/?f=a2d22b28a141f309eb535e7d8cd76143e2ea9079

Revision history for this message
David Henningsson (diwic) wrote : [PATCH (alsa-lib)] USB-audio: Add five more cards to IEC958 blacklist

These devices do not have any IEC958 outputs, so prevent them from
being opened.

Signed-off-by: David Henningsson <email address hidden>
---
 src/conf/cards/USB-Audio.conf | 5 +++++
 1 file changed, 5 insertions(+)

diff --git a/src/conf/cards/USB-Audio.conf b/src/conf/cards/USB-Audio.conf
index a6754d9..05e5d09 100644
--- a/src/conf/cards/USB-Audio.conf
+++ b/src/conf/cards/USB-Audio.conf
@@ -38,10 +38,14 @@ USB-Audio.pcm.iec958_device {
  # "NoiseBlaster 3000" 42

  # The below don't have digital in/out, so prevent them from being opened.
+ "Andrea PureAudio USB-SA Headset" 999
  "Blue Snowball" 999
  "HP Digital Stereo Headset" 999
+ "GN 9330" 999
  "Logitech Speaker Lapdesk N700" 999
+ "Logitech G35 Headset" 999
  "Logitech USB Headset" 999
+ "Logitech USB Headset H540" 999
  "Logitech Wireless Headset" 999
  "Plantronics GameCom 780" 999
  "Plantronics USB Headset" 999
@@ -50,6 +54,7 @@ USB-Audio.pcm.iec958_device {
  "Scarlett 2i2 USB" 999
  "Scarlett 2i4 USB" 999
  "Sennheiser USB headset" 999
+ "SWTOR Gaming Headset by Razer" 999
  "USB Device 0x46d:0x992" 999
 }

--
1.9.1

Revision history for this message
Takashi Iwai (tiwai) wrote :

At Mon, 17 Nov 2014 11:29:34 +0100,
David Henningsson wrote:
>
> These devices do not have any IEC958 outputs, so prevent them from
> being opened.
>
> Signed-off-by: David Henningsson <email address hidden>

Thanks, applied.

Takashi

> ---
> src/conf/cards/USB-Audio.conf | 5 +++++
> 1 file changed, 5 insertions(+)
>
> diff --git a/src/conf/cards/USB-Audio.conf b/src/conf/cards/USB-Audio.conf
> index a6754d9..05e5d09 100644
> --- a/src/conf/cards/USB-Audio.conf
> +++ b/src/conf/cards/USB-Audio.conf
> @@ -38,10 +38,14 @@ USB-Audio.pcm.iec958_device {
> # "NoiseBlaster 3000" 42
>
> # The below don't have digital in/out, so prevent them from being opened.
> + "Andrea PureAudio USB-SA Headset" 999
> "Blue Snowball" 999
> "HP Digital Stereo Headset" 999
> + "GN 9330" 999
> "Logitech Speaker Lapdesk N700" 999
> + "Logitech G35 Headset" 999
> "Logitech USB Headset" 999
> + "Logitech USB Headset H540" 999
> "Logitech Wireless Headset" 999
> "Plantronics GameCom 780" 999
> "Plantronics USB Headset" 999
> @@ -50,6 +54,7 @@ USB-Audio.pcm.iec958_device {
> "Scarlett 2i2 USB" 999
> "Scarlett 2i4 USB" 999
> "Sennheiser USB headset" 999
> + "SWTOR Gaming Headset by Razer" 999
> "USB Device 0x46d:0x992" 999
> }
>
> --
> 1.9.1
>

Revision history for this message
Ponchietto (ponchio) wrote :
Revision history for this message
Krzysztof Rohde (rohde-labs) wrote :

Same issue was encountered with this headset:
"Jabra UC VOICE 550a MS"

http://www.alsa-project.org/db/?f=864bc9d63da66650232a42d9747a239cd2a205d7

Revision history for this message
Lucas Magasweran (lucasrangit) wrote :

I'm curious what the root cause of this bug is because I have a custom USB audio device with this issue. Is it within ALSA or is something wrong with the USB audio device's AudioControl Interface descriptor?

Revision history for this message
ww (wegwerp) wrote :

This bug seems still there on Ubuntu 18.04 with a Jabra Speak 410 USB conference speaker/microphone, see attached screenshot of the top-right menu. Note that the output seems to work both when selecting 'Analog Output' or 'Digital Output (S/PDIF)'.

Revision history for this message
Martins (felipsmartins) wrote :

It's 2021 and it still here.
I dunno if it is a bug but I have a exactly case here: https://i.imgur.com/3cuCCFZ.png
Maybe it's more ALSA or Pulseaudio related than Ubuntu.

Revision history for this message
André Gomes (andre-gs) wrote :

The workaround is still valid. I just tested with my "Plantronics Blackwire 5220 Seri"

http://alsa-project.org/db/?f=461556fb1a5f3a0f5de01e66274d71a59dfb27d9

Revision history for this message
Edle8 (edle8) wrote (last edit ):

I have the same issue with the following USB devices:

"Sennheiser SC60 for Lync" (USB headset)
"Jabra SPEAK 410 USB" (conference speakerphone)
"HD Pro Webcam C920" (webcam with microphone)

I confirm that the workaround is still valid for the mentioned devices.

https://alsa-project.org/db/?f=d4596d4503525e4b1c998fd17d386c73adf8a9a9

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers