[AOD260, Realtek ALC272X, Mic, Internal] No sound at all

Bug #996611 reported by Brian Burch on 2012-05-08
This bug affects 2 people
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)

Bug Description

Acer Aspire One D260-A. Sound output and control via pulseaudio is fine and has been with 11.04, 11.10 and now 12.04. However, sound input from the internal mic has been mostly broken.

The internal mic was detected and the sound recorder application worked perfectly with 12.04 BETA 2 booted from a usb stick. I expected it would be fine when I upgraded to the new release, but it isn't.

When I boot my system (upgraded from 11.10 to 12.04 official releases), the mic doesn't record anything except low level static. Alsamixer shows it is at 100% gain and not muted. Pulseaudio control doesn't show ANY input device. Not surprisingly the volume control slider is at zero and the mute checkbox is unchecked, but both are greyede-out.

Wierdly, when I boot the 12.04 desktop official release from a usb stick sound recorder actually records my voice, but very faintly even at full gain. Pulseaudio control STILL shows no input devices and the volume control is greyed, set to zero and not muted.

Unfortunately I didn't keep the beta 2 system, so I can't look for differences - did any of the latest packages in the beta get forgotten when the release was cut (I don't see how that would be possible, but I have to ask).

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: alsa-base 1.0.25+dfsg-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-24.37-generic 3.2.14
Uname: Linux 3.2.0-24-generic i686
NonfreeKernelModules: wl
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC272X Analog [ALC272X Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
ApportVersion: 2.0.1-0ubuntu7
Architecture: i386
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC272X Analog [ALC272X Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
 /dev/snd/controlC0: jane 1822 F.... pulseaudio
                      jane 2578 F.... alsamixer
 Card hw:0 'Intel'/'HDA Intel at 0x58200000 irq 44'
   Mixer name : 'Realtek ALC272X'
   Components : 'HDA:10ec0272,10250349,00100001'
   Controls : 17
   Simple ctrls : 9
 [ 22.134596] init: plymouth-stop pre-start process (1257) terminated with status 1
 [ 22.360095] Adding 3998716k swap on /dev/mapper/cryptswap1. Priority:-1 extents:1 across:3998716k
 [ 51.672107] eth1: no IPv6 routers present
Date: Tue May 8 16:40:09 2012
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
PackageArchitecture: all
 PATH=(custom, no user)
SourcePackage: alsa-driver
Symptom: audio
Symptom_AlsaRecordingTest: ALSA recording test through plughw:Intel failed
Symptom_Card: Built-in Audio - HDA Intel
 1822 2578/dev/snd/controlC0: jane F.... pulseaudio
                      jane F.... alsamixer
Symptom_Jack: Mic, Internal
Symptom_Type: No sound at all
Title: [AOD260, Realtek ALC272X, Mic, Internal] No sound at all
UpgradeStatus: Upgraded to precise on 2012-05-04 (4 days ago)
dmi.bios.date: 04/28/2010
dmi.bios.vendor: Acer
dmi.bios.version: V1.01
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: AOD260
dmi.board.vendor: Acer
dmi.board.version: V1.01
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: V1.01
dmi.modalias: dmi:bvnAcer:bvrV1.01:bd04/28/2010:svnAcer:pnAOD260:pvrV1.01:rvnAcer:rnAOD260:rvrV1.01:cvnAcer:ct10:cvrV1.01:
dmi.product.name: AOD260
dmi.product.version: V1.01
dmi.sys.vendor: Acer

Brian Burch (brian-pingtoo) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in alsa-driver (Ubuntu):
status: New → Confirmed
Brian Burch (brian-pingtoo) wrote :

The bypass described in https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/946232 did not work. I have just tested with the proposed new pulseaudio package. The internal microphone is still not working. Therefore, I conclude that this bug is NOT a duplicate of 946232.

(I have collected alsa-info under the proposed pulseaudio package)

Brian Burch (brian-pingtoo) wrote :

At the suggestion of Renzo Bagnati, I Tried the bypass suggested in the meta-bug 1002978 and was very pleased to discover my microphone worked again!

I conclude this individual bug is a duplicate of the inverted internal microphone one instead.

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

This release of Ubuntu is no longer receiving maintenance updates. If this is still an issue on a maintained version of Ubuntu please let us know.

Changed in alsa-driver (Ubuntu):
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for alsa-driver (Ubuntu) because there has been no activity for 60 days.]

Changed in alsa-driver (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers