PCI/internal sound card seems to be detected, but is not available

Bug #931368 reported by EPO4it on 2012-02-13
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Undecided
Unassigned

Bug Description

In my PC is a VT8237A/VT8251 HDA Controller from VIA Technologies, Inc.
When I open the sound preferences, I only see a dummy output.
I tried a lot of commands to figure out the pronblem. It seems that the PCI sound controller is found.
Somehow it is not recognized as an audio device.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: alsa-base 1.0.24+dfsg-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-16.28-generic 3.0.17
Uname: Linux 3.0.0-16-generic i686
AlsaDevices:
 total 0
 crw-rw----+ 1 root audio 116, 1 2012-02-13 11:37 seq
 crw-rw----+ 1 root audio 116, 33 2012-02-13 11:37 timer
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
AplayDevices: aplay: device_list:240: no soundcards found...
ApportVersion: 1.23-0ubuntu4
Architecture: i386
ArecordDevices: arecord: device_list:240: no soundcards found...
AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/seq', '/dev/snd/timer'] failed with exit code 1:
Date: Mon Feb 13 12:04:02 2012
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
PackageArchitecture: all
SourcePackage: alsa-driver
Symptom: audio
Title: PCI/internal sound card not detected
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 04/23/2007
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: 6.00 PG
dmi.board.name: K8M890-8237A
dmi.board.vendor: Foxconn
dmi.chassis.type: 3
dmi.chassis.vendor: OEM
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvr6.00PG:bd04/23/2007:svnFoxconn:pnOEM:pvr:rvnFoxconn:rnK8M890-8237A:rvr:cvnOEM:ct3:cvr:
dmi.product.name: OEM
dmi.sys.vendor: Foxconn

EPO4it (info-epo4it) wrote :

So the issue is:
[ 7.379223] hda-intel: ioremap error
[ 7.379231] HDA Intel 0000:80:01.0: PCI INT A disabled

See if adding pci=use_crs to your boot line fixes it. Reference: https://bugzilla.kernel.org/show_bug.cgi?id=16921#c5

EPO4it (info-epo4it) wrote :

IT WORKS!!! Thanks a lot for the quick reaction.

I like to make one comment on the sentence "to your boot line".
The change is rather simple, but it took me a lot off time to get to the right place.
I did know something about the grub.conf, but could not find it in the first place. After some searching I rebooted my PC with the live-CD of Ubuntu 11.10, but Ubuntu did not show up (I installed my PC with this CD-rom). Then I decided to start with an old Fedora 14 live-CD. I could reach my harddisk and mount it. I could get to the grub.conf file, but it was read-only. This was easy to change with chmod. Finally I added the extra parameter and rebooted.

My conclussion: I find it strange that a solution is rather simple. We could wonder why it takes such an effort to perform it.
Thanks to your knowledge my problem is solved.
Kind regards, Erik

You're welcome.
Just a note: with GRUB2, you should modify /etc/default/grub file and not touch the /boot/grub/grub.cfg file directly

EPO4it (info-epo4it) wrote :

I did not know about /etc/default/grub . The idea is great so I executed: "info -f grub -n 'Simple configuration'" as was mentioned in the file. Alas I must say, that it probably would have cost me more time to make the change in the boot line and verify the result. I think I had to use "GRUP_CMDLINE_LINUX=pci=use_crs" and then run "update-grup".

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in alsa-driver (Ubuntu):
status: New → Confirmed
Jakub Mihalciak (anambroid) wrote :

Thank you Dave, your fix works.
I was struggling with the same problem.

Bjorn Helgaas (bjorn-helgaas) wrote :

Anybody seeing this problem on a Foxconn K8M890-8237A system, please test this patch. With it, sound should work without having to boot with "pci=use_crs". If you test it, please attach the complete dmesg log here. Thanks!

The attachment "quirk to turn on pci=use_crs on Foxconn K8M890-8237A" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.