Ubuntu

[Macmini5,3, Cirrus Logic CS4206, Headphone Out, No sound at all

Reported by skipper on 2011-11-20
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Undecided
Luke Yelavich

Bug Description

After a fresh install there was no sound at all. I added the line
options snd-hda-intel model=mbp55
to alsa-base.conf, now there is sound but only through the internal speaker, while in Sound Settings only 'Analog Headphones' appears. The same with model=imac27. With model=auto in Sound Settings both the speaker and the headphones appear (looks like everything is ok), but in that case there is no sound at all.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: alsa-base 1.0.24+dfsg-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.23-0ubuntu4
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: Cirrus Analog [Cirrus Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: sirna 7182 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xa0900000 irq 47'
   Mixer name : 'Cirrus Logic CS4206'
   Components : 'HDA:10134206,106b2100,00100302'
   Controls : 17
   Simple ctrls : 10
Date: Sun Nov 20 17:53:34 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_AU:en
 PATH=(custom, user)
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
SourcePackage: alsa-driver
Symptom: audio
Symptom_AlsaPlaybackTest: ALSA playback test through plughw:PCH failed
Symptom_Card: Internal Audio - HDA Intel PCH
Symptom_Jack: Green Headphone Out, Rear
Symptom_Type: No sound at all
Title: [Macmini5,3, Cirrus Logic CS4206, Green Headphone Out, Rear] No sound at all
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 10/14/2011
dmi.bios.vendor: Apple Inc.
dmi.bios.version: MM51.88Z.0077.B0E.1110141154
dmi.board.asset.tag: Base Board Asset Tag#
dmi.board.name: Mac-7BA5B2794B2CDB12
dmi.board.vendor: Apple Inc.
dmi.board.version: Macmini5,3
dmi.chassis.type: 16
dmi.chassis.vendor: Apple Inc.
dmi.chassis.version: Mac-7BA5B2794B2CDB12
dmi.modalias: dmi:bvnAppleInc.:bvrMM51.88Z.0077.B0E.1110141154:bd10/14/2011:svnAppleInc.:pnMacmini5,3:pvr1.0:rvnAppleInc.:rnMac-7BA5B2794B2CDB12:rvrMacmini5,3:cvnAppleInc.:ct16:cvrMac-7BA5B2794B2CDB12:
dmi.product.name: Macmini5,3
dmi.product.version: 1.0
dmi.sys.vendor: Apple Inc.
mtime.conffile..etc.modprobe.d.alsa.base.conf: 2011-11-19T14:21:59.456393

skipper (attila-egri-nagy) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in alsa-driver (Ubuntu):
status: New → Confirmed
Oleg Kalnichevski (olegk) wrote :

Same hardware (macnini5,3), same problem, same symptoms

skipper (attila-egri-nagy) wrote :

I tried connecting to a monitor with speakers by an HDMI cable. That also does not work.

Oleg Kalnichevski (olegk) wrote :

I managed to get sound on headphones/line out by tweaking HDA codec settings with HDA_Analyzer as described in this post:

http://forum.tinycorelinux.net/index.php?topic=11323.0

Diff for codec 0/0 (0x10134206):
---
+++
@@ -8,19 +8,19 @@
 Default PCM:
     rates [0x7f0]: 32000 44100 48000 88200 96000 176400 192000
     bits [0x1e]: 16 20 24 32
     formats [0x3]: PCM FLOAT
 Default Amp-In caps: N/A
 Default Amp-Out caps: N/A
 GPIO: io=4, o=0, i=0, unsolicited=0, wake=0
   IO[0]: enable=0, dir=0, wake=0, sticky=0, data=0, unsol=0
- IO[1]: enable=1, dir=1, wake=0, sticky=0, data=0, unsol=0
+ IO[1]: enable=1, dir=1, wake=0, sticky=0, data=1, unsol=0
   IO[2]: enable=0, dir=0, wake=0, sticky=0, data=0, unsol=0
- IO[3]: enable=1, dir=1, wake=0, sticky=0, data=1, unsol=0
+ IO[3]: enable=1, dir=0, wake=0, sticky=0, data=0, unsol=0
 Node 0x02 [Audio Output] wcaps 0xd041d: Stereo Amp-Out
   Control: name="Master Playback Switch", index=0, device=0
   Control: name="Master Playback Volume", index=0, device=0
   Control: name="Headphone Playback Switch", index=0, device=0
     ControlAmp: chs=3, dir=1, idx=0, ofs=0
   Control: name="Headphone Playback Volume", index=0, device=0
     ControlAmp: chs=3, dir=1, idx=0, ofs=0
   Amp-Out caps: ofs=0x73, nsteps=0x7f, stepsize=0x01, mute=
---

IMPORTANT: In addition I also had to un-mute 'Front Speaker' with alsamixer to get sound on headphones/line out.

skipper (attila-egri-nagy) wrote :

Yes, it works here as well. Strange enough, but I had to unmute the Surround speaker and muting the front speaker has no effect at all (maybe I did something differently).

I wonder whether the HDMI audio output is just the same kind of rerouting, or more involved.

Anyhow, this workaround is fine at the moment.

Oleg Kalnichevski (olegk) wrote :

Anyone might have an idea how to make the setting 'stick'? Presently I have to toggle GPIO bit manually every time the OS is rebooted or resumed. Is there a way to apply the setting automatically with a script?

skipper (attila-egri-nagy) wrote :

So this python script makes it work, but has to be executed after each boot/suspend. One can just put this into an init script, but that does not seem to be a nice solution.

Luke Yelavich (themuso) wrote :

I have access to this same hardware, and have experience with kernel patching for hda hardware. I'll take a look when I get a moment.

Changed in alsa-driver (Ubuntu):
assignee: nobody → Luke Yelavich (themuso)
skipper (attila-egri-nagy) wrote :

It seems that the change did not go into Quantal. Any special reason for that?
Thanks!

Raymond (superquad-vortex2) wrote :

00:1b.0 Audio device [0403]: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller [8086:1c20] (rev 05)
 Subsystem: Intel Corporation Device [8086:7270]

http://git.kernel.org/?p=linux/kernel/git/tiwai/sound.git;a=commitdiff;h=6dfeb703e386369d9f1585d29482efe7b2b4401d;hp=e2301a4de22c438f5a962c7cefc3e9cba736991c

Changed in alsa-driver (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers