[Thinkpad R61, 8932CTO, Conexant CX20549 (Venice), Green Headphone Out, Left] No sound at all

Bug #876020 reported by soundconjurer on 2011-10-16
104
This bug affects 18 people
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Undecided
Unassigned

Bug Description

No matter what program, no output to headphones.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: alsa-base 1.0.24+dfsg-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.23-0ubuntu3
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: soundconjurer 1580 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf8300000 irq 47'
   Mixer name : 'Conexant CX20549 (Venice)'
   Components : 'HDA:14f15045,17aa20db,00100100'
   Controls : 19
   Simple ctrls : 10
Card29.Amixer.info:
 Card hw:29 'ThinkPadEC'/'ThinkPad Console Audio Control at EC reg 0x30, fw 7KHT24WW-1.08'
   Mixer name : 'ThinkPad EC 7KHT24WW-1.08'
   Components : ''
   Controls : 1
   Simple ctrls : 1
Card29.Amixer.values:
 Simple mixer control 'Console',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Date: Sun Oct 16 18:07:16 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
PackageArchitecture: all
SourcePackage: alsa-driver
Symptom: audio
Symptom_AlsaPlaybackTest: ALSA playback test through plughw:Intel failed
Symptom_Card: Internal Audio - HDA Intel
Symptom_Jack: Green Headphone Out, Left
Symptom_Type: No sound at all
Title: [8932CTO, Conexant CX20549 (Venice), Green Headphone Out, Left] No sound at all
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 06/06/2008
dmi.bios.vendor: LENOVO
dmi.bios.version: 7OETB6WW (2.16 )
dmi.board.name: 8932CTO
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr7OETB6WW(2.16):bd06/06/2008:svnLENOVO:pn8932CTO:pvrThinkPadR61:rvnLENOVO:rn8932CTO:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 8932CTO
dmi.product.version: ThinkPad R61
dmi.sys.vendor: LENOVO

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in alsa-driver (Ubuntu):
status: New → Confirmed
fain182 (fain182) wrote :

I have the some problem, on my Thinkpad R61i, with natty everything work fine, but with oneiric the headphone makes no sound at all..

(I even tried to use "options snd-hda-intel model=thinkpad" in alsa-base.conf but nothing changed)

Fili (rogerwilco) wrote :

I also had no output on the headphones of my Lenovo Thinkpad R61i, adding

options snd-hda-intel model=generic

to /etc/modprobe.d/alsa-base.conf helped.

fain182 (fain182) wrote :

with model=generic it works perfectly, thank you!

Jochen Schnelle (noisefloor) wrote :

The additional line works fine, thanks!
In addition to that, general volume is addjustable in a wider range and more "fine-grained".

The additional line with "generic" worked for me as well. Thank you!!!

David Henningsson (diwic) wrote :

Hello,

Can you remove the "model=generic" line, and instead try the latest upstream drivers as outlined here: https://wiki.ubuntu.com/Audio/UpgradingAlsa/DKMS

Thanks!

Changed in alsa-driver (Ubuntu):
status: Confirmed → Incomplete
summary: - [8932CTO, Conexant CX20549 (Venice), Green Headphone Out, Left] No sound
- at all
+ [Thinkpad R61, 8932CTO, Conexant CX20549 (Venice), Green Headphone Out,
+ Left] No sound at all
fain182 (fain182) wrote :

With latest upstream drivers everything works..

David Henningsson (diwic) wrote :

Thanks, I assume it will then be fixed in the next release of Ubuntu.

Changed in alsa-driver (Ubuntu):
status: Incomplete → Fix Released

Well, sorry to break it to you. None of those fixes work at all. If anything, I think I see some changes to GUI settings over changes to the fact my headphone jack doesn't work.

This is not fixed, sorry.

Changed in alsa-driver (Ubuntu):
status: Fix Released → Incomplete
Piotr Borkowski (boroslav-t) wrote :

I confirm that the latest upstream drivers (alsa-hda-dkms_0.201112191418~oneiric1_all.deb) fixed the problem and now i can hear the sound from the headphones audio output on my Lenovo ThinkPad R61i laptop. Thanks!

Piotr Borkowski (boroslav-t) wrote :

I installed it on 64-bit system and it works. I think this package is compiled before installation.

Cool thanks, the driver plus adding line:

options snd-hda-intel model=generic

to /etc/modprobe.d/alsa-base.conf and a quick reboot has fixed the problem.

Shame this couldn't have come via an update.

Thanks for the heads up Piotr and linking my issue to this bug

Merry Christmas everybody :)

Piotr Borkowski (boroslav-t) wrote :

For me the line above was not necessary.

Mery Christmas

Marvin (marvin-nospam) wrote :

The dkms works partially. Yes the headphone started to work but the volume control behaves weird. I made a screen capture (see attachment) to show what's wrong. In this video I change the volume by the volume buttons on the keyboard. In a terminal window I have alsamixer running to see how the volume controls are influenced by this. What you see there is also what I hear: The volume decreases when the volume notification bar (at the top right corner of the screen) decreases from 100% to approximately 60%. In that range the volume of the headphone control descreases from 100% to 0%. Then from 60% to somewhere around 5% in the notification bar, nothing happens. And when the notification bar descreases from 5% to 0% then the PCM control decreases from 100% to 0%.

Marvin (marvin-nospam) wrote :

BTW: I guess the problem with controlling the volume I point out above, is more related to the user interface than the driver.

Marvin (marvin-nospam) wrote :

Why is the status of this bug report "incomplete"?

Changed in alsa-driver (Ubuntu):
status: Incomplete → Fix Released

Marvin,

Bug supervisors are the only people that can mark them as incomplete, I have now marked it as Fix Released.

Please attach your screen capture to the following Bug Report #909723 which I have created as I too have noticed that issue but now got round to opening a bug as there is a work around.

:)

fain182 (fain182) wrote :

This is not fixed.

I upgrade to Precise, but:
 - alsa-hda-dkms is not present for precise
 - I uninstalled alsa-hda-dkms and phone doesn't work no more

David Henningsson (diwic) wrote :

@fain182, thanks for the information. Assuming you have the same hardware as the original reporter, could you please attach alsa-info (from a 12.04 installation) according to https://wiki.ubuntu.com/Audio/AlsaInfo ? Thanks!

fain182 (fain182) wrote :

here it is: http://www.alsa-project.org/db/?f=dc65b230989f00359d4bd52a187d04ddb208d068

( btw I found a workaround for precise, i installed again alsa-hda-dkms using the ppa for Oneiric on Precise.. )

David Henningsson (diwic) wrote :

@fain182, according to your alsa-info, you're running an old 3.0 based kernel. Make sure you run a 3.2 based kernel for precise. If you do that, I hope the problem will be fixed.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers