Ubuntu

[HP Pavilion dv6, IDT 92HD75B3] Line out does not mute internal speakers

Reported by Bayan Rafeh on 2011-10-10
50
This bug affects 10 people
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Undecided
Unassigned

Bug Description

Well my card info is attached so I can't switch to headphones only in alsa. In Maverick and Natty I used to be able to switch via going to Sound>Output and switching to Analog Output instead of Analog Speakers. The Analog Output option is not available in Ubuntu Oneiric and I tried switching directly from the Alsa Mixer but it didn't have a "headphones" option either.

Sound comes out of both the headphone and speakers when headphone is plugged in.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: alsa-base 1.0.24+dfsg-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
NonfreeKernelModules: nvidia
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.23-0ubuntu3
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: bayan 1667 F.... pulseaudio
 /dev/snd/controlC0: bayan 1667 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xdb100000 irq 43'
   Mixer name : 'IDT 92HD75B3X5'
   Components : 'HDA:111d7603,103c3659,00100202'
   Controls : 20
   Simple ctrls : 12
Card1.Amixer.info:
 Card hw:1 'NVidia'/'HDA NVidia at 0xd3000000 irq 16'
   Mixer name : 'Nvidia GPU 0b HDMI/DP'
   Components : 'HDA:10de000b,10de0101,00100100'
   Controls : 16
   Simple ctrls : 4
Date: Mon Oct 10 11:18:26 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64+mac (20110901)
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: alsa-driver
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 02/06/2010
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.17
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 3659
dmi.board.vendor: Hewlett-Packard
dmi.board.version: 32.24
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.17:bd02/06/2010:svnHewlett-Packard:pnHPPaviliondv6NotebookPC:pvr049D210000241210000020000:rvnHewlett-Packard:rn3659:rvr32.24:cvnHewlett-Packard:ct10:cvrN/A:
dmi.product.name: HP Pavilion dv6 Notebook PC
dmi.product.version: 049D210000241210000020000
dmi.sys.vendor: Hewlett-Packard

Bayan Rafeh (bayan-rafeh92) wrote :
Gary M (garym) on 2011-10-10
tags: added: hda-jack-sense
summary: - Cannot switch to headphones on Ubuntu 11.10 Intel HDA sound card
+ [IDT 92HD75B3] Line out does not mute internal speakers
Changed in alsa-driver (Ubuntu):
status: New → Triaged
importance: Undecided → Wishlist

According to the info, what you have on the front side is a line out jack, rather than internal speakers. This is why auto-mute is not enabled in the kernel.

However, that "Analog Output" has disappeared is probably something we can work around. The problem is inconsistent volume control naming in the driver, and in PulseAudio we choose the naming that works for most people, and you're one of the people where the default does not work correctly.

Open
/usr/share/pulseaudio/alsa-mixer/paths/analog-output-speaker.conf

Change:

[Element Front]
switch = mute
volume = merge
override-map.1 = all-front
override-map.2 = front-left,front-right

To:

[Element Front]
switch = ignore
volume = ignore

...and reboot to try the new settings. Please report back to tell us if this worked out for you. Thanks!

Changed in alsa-driver (Ubuntu):
status: Triaged → Incomplete
David Henningsson (diwic) wrote :

I've marked bug 870360 as a duplicate of this one even though the hardware is slightly different. Let me ask both of you (Bayan and Reece): Is there actually a headphone icon on the front (and not a "Line out" icon)? If so we should consider making a kernel quirk that turns these outputs into headphones at the kernel level instead of working around it in PulseAudio.

Reece H. Dunn (msclrhd-gmail) wrote :

David: These are labelled with a headphone on my laptop (see h20424.www2.hp.com/program/cnb/kr/ko/resources/dv7-new-brochure.pdf) It has the same headphone symbol as on page 3. Page 4 clearly labels it as having 2 headphone jacks and 1 microphone jack.

Bayan Rafeh (bayan-rafeh92) wrote :

Same here, 2 headphone jacks and one microphone jack in the front of the laptop. The fix you suggested worked perfectly David thanks a lot!

Pavel Fischer (rubbiroid) wrote :

Same error with Asus Essences ST. I can switch output with alsamicer from console, but can't switch it from "Sound Settings"

Bayan Rafeh (bayan-rafeh92) wrote :

Pavel did you try the fix suggested above?

"Open
/usr/share/pulseaudio/alsa-mixer/paths/analog-output-speaker.conf

Change:

[Element Front]
switch = mute
volume = merge
override-map.1 = all-front
override-map.2 = front-left,front-right

To:

[Element Front]
switch = ignore
volume = ignore

...and reboot to try the new settings."

Pavel Fischer (rubbiroid) wrote :

> Bayan Rafeh (bayan-rafeh92) wrote 19 minutes ago:

no, that dont help

The fix that Bayan Rafeh suggested does not work for me to fix this issue.

Bayan Rafeh (bayan-rafeh92) wrote :

Did you try another sound preferences manager? If you can change it from alsamixer maybe it's an issue with the system settings manager. Did you try a different sound preferences gui frontend?

David Henningsson (diwic) wrote :

@Raymond, Pavel, if you have different hardware compared to the original reporter, please file separate bugs. Thanks!

summary: - [IDT 92HD75B3] Line out does not mute internal speakers
+ [HP Pavilion dv6, IDT 92HD75B3] Line out does not mute internal speakers
Benedikt Bär (beniwtv) wrote :

Pavel's workaround works, somewhat. I can now select "Analog Output" from the menu and only the headphones work. However switching back does not work, i.e. the speakers remain silent and the headphones continue.

I think this bug is related to the new jack sensing ability that is now present in Oneiric. I think it does not sense (or ignore) when headphones are plugged in.

Natty worked fine because it had the drop-down by default.

yen rio (yenrio) wrote :

Same here, same configuration of bug description and 2 headphone jacks and one microphone jack in the front of the laptop.
The fix suggested by David worked for me!

Launchpad Janitor (janitor) wrote :

[Expired for alsa-driver (Ubuntu) because there has been no activity for 60 days.]

Changed in alsa-driver (Ubuntu):
status: Incomplete → Expired
Gary M (garym) wrote :

Looks like David's question was answered, so winding back from Incomplete/Expired to Confirmed (can't restore to Triaged).

Changed in alsa-driver (Ubuntu):
status: Expired → Confirmed
David Henningsson (diwic) wrote :

@Gary M, thanks. Should you wish to be able to restore to "Triaged", you can become member of https://wiki.ubuntu.com/UbuntuBugControl

I seem to have lost this bug, sorry. A slightly better workaround these days would be to use hda-jack-retask ( see http://voices.canonical.com/david.henningsson/2011/11/29/turn-your-mic-jack-into-a-headphone-jack/ ) and change your line-out jack to a headphone jack. That would then have the same effect as putting a quirk in the kernel. Is that working out for you?

Changed in alsa-driver (Ubuntu):
importance: Wishlist → Undecided
status: Confirmed → Incomplete
Bayan Rafeh (bayan-rafeh92) wrote :

Thanks for the app david really helpful but I still don't have the "headphone jack" option on any of the configurations. Do I need to revert the pulseaudio configuration file to what it was?

David Henningsson (diwic) wrote :

> Do I need to revert the pulseaudio configuration file to what it was?

Yes, please do that before trying the application. It is strange that changing the line out jack to a headphone jack did not have the desired effect. Could you submit an alsa-info ( https://wiki.ubuntu.com/Audio/AlsaInfo ) after you have applied the pin override? Thanks!

Bayan Rafeh (bayan-rafeh92) wrote :

No David the thing is I can't the option is not available for any of the jacks these are the options the application provides:

Black Mic, Front Side:
PIN ID: 0x0b
Options: Microphone, Line in, Internal Mic, Not Connected.
Default: Microphone

Internal Speaker
PIN ID: 0x0d
Options: Line Out(Front), Line Out(Center/LFE), Line Out(Back), Line Out(Side), Internal Speaker, Not Connected
Default: Internal Speaker

Green Line Out, Front Side
PIN ID: 0x0f
Options: Line Out(Front), Line Out(Center/LFE), Line Out(Back), Line Out(Side), Internal Speaker, Not Connected
Default: Line OUt(Front)

Internal Mic
Pin ID: 0x18
Options: Internal Mic, Not Connected
Default: Internal Mic

Black SPDIF Out, Front Side
PIN ID: 0x1e
Options: SPDIF Out, Not Connected
Default: SPDIF Out

Here is a screenshot of the app: https://docs.google.com/open?id=0B0p_t3_TxdVZYzUyZTk5NjgtMGU0OS00YTZhLTlhMWItY2E3OGY2YWM5NWMz

As you can see it is impossible to change the line out to headphones since the option does not actually exist. This is after resetting the conf file. I ran the alsainfo script and uploaded the results but since I didn't override it's probably the same as the initial dump. It's here if it helps: http://www.alsa-project.org/db/?f=5afb4bb280bddea75f7baa0f46441537a6672078

Daniel Letzeisen (dtl131) wrote :

You have to check the 'Override' box before the option becomse available.

Bayan Rafeh (bayan-rafeh92) wrote :

I did that, I listed the options I had for each override in my previous comment.

David Henningsson (diwic) wrote :

@Bayan, okay. Could you check the "Advanced Override" checkbox (on the right side), this should bring up a myriad of dropdowns on the left side. Look for the "Green line out, pin 0x0f" on the left side. One of the dropdowns below this heading should say "Line Out" - change this one to "Headphones". Leave all the others unchanged.
Then check "Override" for this pin and then "Apply now".

Bayan Rafeh (bayan-rafeh92) wrote :

It didn't work unfortunately. I tried applying it directly and setting it as boot default and restarting. Here is a screenshot of my advanced settings. https://docs.google.com/open?id=0B0p_t3_TxdVZM2QzMGI5YzAtNzY2OS00OGU1LThhZTAtOTI2MGRlZTJmMTYy

Changed in alsa-driver (Ubuntu):
status: Incomplete → Triaged
Xavier L. (xav0989) wrote :

Since the dv6 (and other dv#) do not seem to have a headphone pin but a line out pin, I found this little patch http://patchwork.ozlabs.org/patch/128666/ that might work (haven't tested yet)

Xavier L. (xav0989) wrote :

In the meantime, I downloaded the drivers from realtek and will update here with details.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers