hedgewars crashed with SIGFPE in Mix_FadeInMusicPos()

Bug #862748 reported by Francesco Muriana on 2011-09-29
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Medium
Unassigned

Bug Description

Hedgewars didn't start at mouse clic and this bug report appeared

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: hedgewars 0.9.15-4
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic-pae 3.0.4
Uname: Linux 3.0.0-12-generic-pae i686
ApportVersion: 1.23-0ubuntu2
Architecture: i386
Date: Thu Sep 29 22:18:58 2011
ExecutablePath: /usr/lib/hedgewars/bin/hedgewars
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta i386 (20110901)
ProcCmdline: hedgewars
Signal: 8
SourcePackage: hedgewars
StacktraceTop:
 Mix_FadeInMusicPos () from /usr/lib/libSDL_mixer-1.2.so.0
 Mix_FadeInMusic () from /usr/lib/libSDL_mixer-1.2.so.0
 SDLInteraction::StartMusic() ()
 HWForm::qt_metacall(QMetaObject::Call, int, void**) ()
 QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
Title: hedgewars crashed with SIGFPE in Mix_FadeInMusicPos()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Francesco Muriana (f-muriana) wrote :
security vulnerability: yes → no
visibility: private → public

StacktraceTop:
 Mix_FadeInMusicPos (music=0x882dcc0, loops=-1, ms=1750, position=0) at ./music.c:869
 Mix_FadeInMusic (music=0x882dcc0, loops=-1, ms=1750) at ./music.c:888
 SDLInteraction::StartMusic() ()
 HWForm::qt_metacall(QMetaObject::Call, int, void**) ()
 metacall (argv=0xbf872b48, idx=75, cl=QMetaObject::InvokeMetaMethod, object=0x882e710) at kernel/qmetaobject.cpp:237

Changed in hedgewars (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace

A new Hedgewars version (based on 0.9.17) in available in oneiric-proposed, could you give it a try and set again status to "new" if the problem persists?

thanks

Changed in hedgewars (Ubuntu):
status: New → Incomplete
Taneli (taneli-vahakangas) wrote :

This happens with 0.9.17-1~oneiric0.1 stack trace attached (as there were small differences).

I also tried setting sound=false and music=false in [audio] in .hedgewars/hedgewars.ini and completely removing .hedgewars, but neither made any difference.

Derek (bugs-m8y) wrote :

Taneli, please try this ini file
http://m8y.org/tmp/hedgewars.ini

The options you set disable the sound in-game, not in the Qt frontend.

Your error is typical of SDL failing to initialise the sound system.
One reason for that might be due to conflicting sound systems and a card that does not support software mixing.
Another possibility I guess is multiple users (same issue).

Derek (bugs-m8y) wrote :

Er. A card that does not support *hardware* mixing.

Anyway. Same point :)

Changed in hedgewars (Ubuntu):
status: Incomplete → New

so this seems to be alsa related and qt related.

Reassigning.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in alsa-driver (Ubuntu):
status: New → Confirmed
affects: hedgewars (Ubuntu) → alsa-driver (Ubuntu)
Changed in alsa-driver (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers