Ubuntu

[Lenovo Y300] Microphone is unable to record any audio

Reported by Rigved Rakshit on 2011-09-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Undecided
Unassigned

Bug Description

Description: Ubuntu oneiric (development branch)
Release: 11.10
pulseaudio:
  Installed: 1:0.99.3-0ubuntu3
  Candidate: 1:0.99.3-0ubuntu3
  Version table:
 *** 1:0.99.3-0ubuntu3 0
        500 http://in.archive.ubuntu.com/ubuntu/ oneiric/main i386 Packages
        100 /var/lib/dpkg/status
Expected Outcome: I should be able to record audio using my external microphone.
Actual Outcome: I do not have an internal microphone. I can record audio using the external microphone. I have used this same microphone earlier to record sound in Lucid, but in 11.10, I am unable to record any sound using the external microphone.

Here is a similar problem faced by someone using 11.04: http://askubuntu.com/questions/61289/how-to-verify-if-my-microphone-input-is-dead-or-ubuntu-not-detected-it-yet-i-can

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: pulseaudio 1:0.99.3-0ubuntu3
ProcVersionSignature: Ubuntu 3.0.0-10.16-generic 3.0.4
Uname: Linux 3.0.0-10-generic i686
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.22.1-0ubuntu2
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: rigved 1771 F.... pulseaudio
 /dev/snd/pcmC0D0p: rigved 1771 F...m pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xdc240000 irq 45'
   Mixer name : 'Conexant CX20549 (Venice)'
   Components : 'HDA:14f15045,17aa6666,00100100'
   Controls : 12
   Simple ctrls : 6
Date: Wed Sep 14 18:25:21 2011
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta i386 (20110831)
SourcePackage: pulseaudio
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 11/06/06
dmi.bios.vendor: Lenovo
dmi.bios.version: Q3B11W
dmi.board.name: Y300
dmi.board.vendor: L3000 Y300
dmi.board.version: Not Applicable
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Lenovo
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnLenovo:bvrQ3B11W:bd11/06/06:svnL3000Y300:pnY300:pvrRev1.0:rvnL3000Y300:rnY300:rvrNotApplicable:cvnLenovo:ct10:cvrN/A:
dmi.product.name: Y300
dmi.product.version: Rev 1.0
dmi.sys.vendor: L3000 Y300

Rigved Rakshit (rigved) wrote :
Rigved Rakshit (rigved) wrote :
Rigved Rakshit (rigved) wrote :
description: updated
Rigved Rakshit (rigved) wrote :
David Henningsson (diwic) wrote :

Hmm, there seems to be problem seems to be that this volume control:

Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch penum
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 23
  Front Left: Capture 23 [100%] [34.50dB] [on]
  Front Right: Capture 23 [100%] [34.50dB] [on]

Does not control this codec:

Node 0x1a [Audio Input] wcaps 0x100d0b: Stereo Amp-In R/L
  Control: name="Capture Volume", index=0, device=0
    ControlAmp: chs=3, dir=In, idx=1, ofs=0
  Control: name="Capture Switch", index=0, device=0
    ControlAmp: chs=3, dir=In, idx=1, ofs=0
  Device: name="CONEXANT Analog", type="Audio", device=0
  Amp-In caps: ofs=0x00, nsteps=0x17, stepsize=0x05, mute=1
  Amp-In vals: [0x80 0x80] [0x00 0x00] [0x00 0x00] [0x00 0x00] [0x00 0x00]
                                                           ^^^^^^^^ here should be 0x17 if the above level is 23

...which is clearly a bug. I've tried running it in an emulator with the oneiric kernel, and the error does not appear there, so I'm not sure what to do about it. Does changing the capture level help?

Rigved Rakshit (rigved) wrote :

I have tried that too as it was mentioned in the askubuntu answers. I have even tried to mute one of the capture Front Left/Right and tried to keep the other at maximum. I am still unable to record any audio.

If the problem is with the values, is there some way to force alsa and pulseaudio to recheck them again. Like when alsa/pulseaudio are installed for the first time, they make some checks to adjust the values based on input from the audio driver. Is it possible to redo these steps?

I cannot un-install and then re-install pulseaudio/alsa as there are many applications that depend on it.

David Henningsson (diwic) wrote :

Is this also a problem if you run Ubuntu from a Live-CD (or USB stick)? If not, we can conclude that the problem is with the actual installation.

affects: pulseaudio (Ubuntu) → alsa-driver (Ubuntu)
Changed in alsa-driver (Ubuntu):
status: New → Incomplete
Rigved Rakshit (rigved) wrote :

I could not find my Oneiric Beta 1 CD, so I tested the microphone using a Lucid LiveCD. The microphone does work in the LiveCD. So, I feel that there is some problem with the driver in my Oneiric install, like the wrong Amp-In values pointed out above.

I will soon repeat this test using a Oneiric LiveCD and post the results here.

David Henningsson (diwic) wrote :

There has been some interesting findings upstream for the CX20549 chip, where it does not have individual amps for input but only one for all inputs. http://mailman.alsa-project.org/pipermail/alsa-devel/2011-October/045152.html

Changed in alsa-driver (Ubuntu):
status: Incomplete → Triaged
Rigved Rakshit (rigved) wrote :

I have tested the external microphone using the Oneiric Beta 1 LiveCD. The microphone does not work.

But like I pointed out, in a Lucid LiveCD, the microphone works.

The URL of the alsa-devel mailing list archive mentions a patch. I cannot find the link to download the patch on that mailing list page. How do I download this patch? Or do I have to use an upstream version which contains the patch?

David Henningsson (diwic) wrote :

If you would like to try compiling this yourself, here's how I would have done it:

bzr branch lp:~ubuntu-audio-dev/alsa-driver/dkms-packaging
make fetch-src-from-tarball
patch the source in buildroot/src/alsa-hda-0.1
make dkms-mkdeb-source-only

...install buildroot/*.deb and reboot.

Rigved Rakshit (rigved) wrote :

Sorry, I do not understand here which files are the patches and which files need to be patched.

Should I patch buildroot/src/alsa-hda-0.1/snd_hda_intel.c using the patches from patches-oneiric?

David Henningsson (diwic) wrote :

Hi Rigved and sorry for the late reply.

There was a patch added upstream in the end of October. This means that as of today, you can follow the instructions here: https://wiki.ubuntu.com/Audio/UpgradingAlsa/DKMS and see if it resolves your problem. Please report back when you've done so. Thanks!

Changed in alsa-driver (Ubuntu):
status: Triaged → Incomplete
Rigved Rakshit (rigved) wrote :

Hello David.

I followed the instructions that you posted. I can confirm that the patch works.

I can hear audio. My microphone is also being detected and I can hear my voice clearly (in programs like Skype).

Thank you for fixing this problem.

Changed in alsa-driver (Ubuntu):
status: Incomplete → Fix Committed
Rigved Rakshit (rigved) on 2011-12-19
Changed in alsa-driver (Ubuntu):
status: Fix Committed → Fix Released
zeppelinux87 (belussif) wrote :

I have a notebook Asus K53SC with an Intel HDA sound card with Realtek ALC269 codec: my speakers work fine, but mic not work!
I search in more forums and web tutorial: I control my setting in alsamixer, I uninstall/reinstall PulseAudio, I modified my /etc/modprobe/alsa-base.conf with some settings, I patched dkms audio driver, but mic not work again!
I heard only swish sound when I move control mic up in alsamixer play, but nothing else.
Here I post my alsamixer config:

And Here my output of Alsa-info.sh

I need use internal mic, not tested with an external mic.

Can someone help me???
Thanks a lot of...

Daniel Letzeisen (dtl131) wrote :

@zeppelinux87, please file a new bug since you have different hardware/codec.

zeppelinux87 (belussif) wrote :

Sorry very much!!!

To post a comment you must log in.