[ICH4 - Intel ICH6] ALSA test tone not correctly played back

Bug #826081 reported by MUHAMMAD KHURRAM KHAN on 2011-08-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Undecided
Unassigned
alsa-utils (Ubuntu)
Undecided
Unassigned

Bug Description

I have Installed Ubuntu 10.04 but there is no sound at all, secondly everything was working well in windows.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: alsa-base 1.0.22.1+dfsg-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.32-33.72-generic 2.6.32.41+drm33.18
Uname: Linux 2.6.32-33-generic i686
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: khurram 1229 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'ICH6'/'Intel ICH6 with AD1981B at irq 21'
   Mixer name : 'Analog Devices AD1981B'
   Components : 'AC97a:41445374'
   Controls : 34
   Simple ctrls : 23
Date: Sun Aug 14 06:58:42 2011
InstallationMedia: Ubuntu 10.04.3 LTS "Lucid Lynx" - Release i386 (20110720.1)
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SelectedCard: 0 ICH6 ICH4 - Intel ICH6
SourcePackage: alsa-driver
Symptom: audio
Title: [ICH4 - Intel ICH6] ALSA test tone not correctly played back
dmi.bios.date: 12/01/2004
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: 786C2 v01.02
dmi.board.name: 09E8h
dmi.board.vendor: Hewlett-Packard
dmi.chassis.type: 4
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: dmi:bvnHewlett-Packard:bvr786C2v01.02:bd12/01/2004:svnHewlett-Packard:pnHPCompaqdc5100SFF(PT003AW):pvr:rvnHewlett-Packard:rn09E8h:rvr:cvnHewlett-Packard:ct4:cvr:
dmi.product.name: HP Compaq dc5100 SFF(PT003AW)
dmi.sys.vendor: Hewlett-Packard

Daniel T Chen (crimsun) wrote :

There are a couple mixer controls that you can try adjusting:

Simple mixer control 'Headphone Jack Sense',0
  Capabilities: pswitch pswitch-joined penum
  Playback channels: Mono
  Mono: Playback [off]

Simple mixer control 'External Amplifier',0
  Capabilities: pswitch pswitch-joined penum
  Playback channels: Mono
  Mono: Playback [on]

Changed in alsa-driver (Ubuntu):
status: New → Incomplete
Daniel T Chen (crimsun) wrote :

I forgot:

Simple mixer control 'Master Mono',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined penum
  Playback channels: Mono
  Limits: Playback 0 - 31
  Mono: Playback 31 [100%] [0.00dB] [off]

Can you please explain simply I cannot undersatnd that technical wordings...

secondly If this does not work then?

Please open a Terminal and use `alsamixer' to adjust those volumes.

I cannot understand what to do. I have opened alsamixer then cannot understand more, I am new to ubuntu.

Daniel T Chen (crimsun) wrote :

Press 'm' to unmute/mute; use the left and right arrow keys to scroll
through the mixer elements; use the up and down arrows to adjust
volumes (if applicable).

If possible remotely connect to me, tell me the procedure.

It worked I have unmuted and maximized everything there.

Thank you very much.

Daniel T Chen (crimsun) wrote :

Can you hear sound now? If you can hear sound, please see
https://wiki.ubuntu.com/Audio/AlsaInfo.

Yes I can hear the sound in players as well as in internet.

This happens after doing the steps....

Daniel T Chen (crimsun) wrote :

Please run the alsa-info.sh as outlined in comment #12.

Daniel T Chen (crimsun) wrote :

Yes, that's fine. I've submitted a patch upstream to resolve this issue.

Thanks.

I have to set the volume at every reboot and start to listen sound?

Daniel T Chen (crimsun) on 2011-08-21
Changed in alsa-utils (Ubuntu):
status: New → Invalid

How to add and where to add?

What's the meaning of these

Changed in alsa-driver (Ubuntu):
status: Incomplete → Fix Committed

Changed in alsa-utils (Ubuntu):
status: New → Invalid ???

The problem is that system is not saving the settings I have done to alsamixer and at every new start up I have to unmute and increase value of "MASTER M"

Daniel T Chen (crimsun) wrote :

The fix will be available in the next point release of the kernel.
Alsa-utils is not affected.

Herton R. Krzesinski (herton) wrote :

The commit for this issue came in via a stable upstream release. As such it is not subject to the standard bug verification process.

tags: added: verification-done-lucid
Andy Whitcroft (apw) on 2012-01-16
Changed in alsa-driver (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers