ATI Technologies Inc SBx00 Azalia (Intel HDA) [1002:4383] crackling on audio capture with microphone

Bug #810693 reported by mihai on 2011-07-14
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Undecided
Unassigned

Bug Description

the bug is similar to #525328 but...
- it occurred after upgrading to Ubuntu natty, and only when booting with kernel 2.6.38
- if choosing an older kernel, like 2.6.35 - the sound is crystal clear.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: alsa-base 1.0.24+dfsg-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-10.46-generic 2.6.38.7
Uname: Linux 2.6.38-10-generic x86_64
NonfreeKernelModules: nvidia
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: amd64
Card0.Amixer.info:
 Card hw:0 'SB'/'HDA ATI SB at 0xfe024000 irq 16'
   Mixer name : 'Realtek ALC889A'
   Components : 'HDA:10ec0885,1458a002,00100101'
   Controls : 39
   Simple ctrls : 22
Card1.Amixer.info:
 Card hw:1 'Live'/'SB Live! 5.1 [SB0220] (rev.10, serial:0x80651102) at 0xcf00, irq 20'
   Mixer name : 'SigmaTel STAC9708,11'
   Components : 'AC97a:83847608'
   Controls : 224
   Simple ctrls : 45
Date: Thu Jul 14 16:33:34 2011
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: alsa-driver
Symptom: audio
UpgradeStatus: Upgraded to natty on 2011-04-29 (76 days ago)
dmi.bios.date: 09/19/2008
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: FA
dmi.board.name: GA-MA78GM-S2H
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.board.version: x.x
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrFA:bd09/19/2008:svnGigabyteTechnologyCo.,Ltd.:pnGA-MA78GM-S2H:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnGA-MA78GM-S2H:rvrx.x:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
dmi.product.name: GA-MA78GM-S2H
dmi.sys.vendor: Gigabyte Technology Co., Ltd.

mihai (mihai71237) wrote :
mihai (mihai71237) wrote :

About this bug I forgot to say that it affects only the Card hw:0 'SB'/'HDA ATI SB.
With the other card the recorded sound is clean.

komputes (komputes) wrote :

Could you check your audio levels using Sound Preferences as well as "alsamixer" to make sure that the capture level is not set too high.

Is this using HDMI on the ATI Technologies Inc SBx00 Azalia (Intel HDA) [1002:4383] (PCI ID seems wrong, do you have a model number)?
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

affects: ubuntu → alsa-driver (Ubuntu)
summary: - crackling on audio capture with microphone (skype, audacity)
+ ATI Technologies Inc SBx00 Azalia (Intel HDA) [1002:4383] crackling on
+ audio capture with microphone
komputes (komputes) wrote :

Also does this affect you in gnome-sound-recorder?
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

komputes (komputes) wrote :

Bug #741825 seems to affect this model of sound card. It is marked Fixed Committed. I will mark it as a duplicate but if this bug is marked Fixed Released for Natty and it does not correct the issue, we can separate the two bugs.
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

mihai (mihai71237) wrote :

Hi komputes,
Yes, it occurs also in gnome-sound-recorder.

The level of crackling noise is proportional with the level of the recorded sound:
- on low/high capture levels it is as low (or high) as the recorded voice.
- when recording just the background noise (no speaking in microphone) the crackling is not audible.

I'm not using HDMI.
The controller is AMD SB700, and audio is Realtek ALC889A codec (information from motherboard user's manual).
Besides this and info from "lspci -vvnn" I don't know how to get.

As for this bug being a duplicate of #741825:
- it does not meet the criteria for being a duplicate of it: I can record with mic but the quality is not good.
- I've installed the deb package proposed as a fix for that bug, but this bug is still there.

xandre (ondrej-michal) wrote :

Hi mihai,
I had exactly the same problem and now I have found solution.

https://answers.launchpad.net/ubuntu/+source/alsa-driver/+question/131814

Add "options snd-hda-intel position_fix=1" in /etc/modprobe.d/alsa-base.conf and restart PC.

mihai (mihai71237) wrote :

Hi xandre,
Your solution doesn't work for me. Actually it's worse: it's creating crackling sounds during capture also with the older kernel 2.6.35

Also the -proposed kernel 2.6.38-11 as solution for #741825 doesn't fix this bug.

mihai (mihai71237) wrote :

Hi again xandre,
Thanks to your suggestion I found a fix for this bug!!!

For me works "options snd-hda-intel position_fix=3".

I found this in
http://wiki.sabayon.org/index.php?title=HOWTO:_Resolve_Problems_with_HDA-Intel_Sound_Cards

       position_fix - Fix DMA pointer (0 = auto, 1 = none, 2 = POSBUF, 3 = FIFO size)

I tried all values: 0 and 1 create crackling during capture; 2 - creates huge interruptions also in the playback sound; 3 - sound is good in capture and playback.

Changed in alsa-driver (Ubuntu):
status: New → Confirmed
Ben Kinsey (bkinsey) wrote :

mihai's solution works for me. Thanks!

Rien Post (rien-x) wrote :

Had the same problem in LinuxMint 16 (64 bit Cinnamon), and Mihai's solution fixed it there too. Thanks a lot!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers