Ubuntu

[IDT ID 76e7] Dell Latitude E5520 - No sound through internal speakers, sound is only from headphones output with Ubuntu 10.04.2 and 10.10 - update Lucid ALSA LBM to latest release (1.0.24)

Reported by Mantas Kriaučiūnas on 2011-06-03
40
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Baltix
Undecided
Unassigned
alsa-driver (Ubuntu)
Undecided
Unassigned

Bug Description

Dell Latitude E5520 has sound through headphone jack but no sound through built-in speakers on Ubuntu 10.04.2 and 10.10

Dell Latitude E5520 contains the following sound controller (output from lspci):
Audio device: Intel Corporation Cougar Point High Definition Audio Controller (rev 04)
PCI ID: 8086:1c20

Problem can be solved by installing linux-alsa-driver-modules-$(uname -r) package from ppa:ubuntu-audio-dev or from Baltix GNU/Linux repository (https://launchpad.net/~baltix-members/+archive/ ). Installing official linux-backports-modules-alsa-lucid-generic package doesn't fix this problem :(
Sound works fine with Ubuntu 11.04, so installing linux-image-generic-lts-backport-natty package from ppa:kernel-ppa also fixes this problem.

SOLUTION for Ubuntu 10.04 LTS: Please update linux-backports-modules-alsa-lucid-generic package to include the latest ALSA drivers (1.0.24) from http://alsa-project.org or include linux-image-generic-lts-backport-natty package into official Ubuntu 10.04 backports or updates repository.
ALSA 1.0.24 released on 2011-01-30, see http://alsa-project.org/main/index.php/Changes_v1.0.23_v1.0.24 for list of improvements.

I found a similar bug #582506 but with different audio hardware. I think the latest ALSA drivers would fix that bug also.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: alsa-base 1.0.22.1+dfsg-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.32-32.62-generic 2.6.32.38+drm33.16
Uname: Linux 2.6.32-32-generic i686
NonfreeKernelModules: wl
AlsaVersion:
 Advanced Linux Sound Architecture Driver Version 1.0.23.
 Compiled on Apr 21 2011 for kernel 2.6.32-32-generic (SMP).
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: HDA Generic [HDA Generic]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: HDA Generic [HDA Generic]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: oem 1492 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0x93d40000 irq 30'
   Mixer name : 'Intel ID 2805'
   Components : 'HDA:111d76e7,1028049a,00100102 HDA:80862805,80860101,00100000'
   Controls : 5
   Simple ctrls : 3
Date: Fri Jun 3 10:07:52 2011
InstallationMedia: Ubuntu-Baltix 10.04.2 LTS "Baltix Linux 2011-02" - Release i386 (20110211.1)
PackageArchitecture: all
ProcEnviron:
 LANG=lt_LT.UTF-8
 SHELL=/bin/bash
SelectedCard: 0 PCH HDA-Intel - HDA Intel PCH
SourcePackage: alsa-driver
Symptom: audio
Title: [IDT ID 76e7] ALSA test tone not correctly played back
dmi.bios.date: 02/22/2011
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A00
dmi.board.name: 03PH4G
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 9
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA00:bd02/22/2011:svnDellInc.:pnLatitudeE5520:pvr01:rvnDellInc.:rn03PH4G:rvrA00:cvnDellInc.:ct9:cvr:
dmi.product.name: Latitude E5520
dmi.product.version: 01
dmi.sys.vendor: Dell Inc.

Mantas Kriaučiūnas (mantas) wrote :
Changed in alsa-driver (Ubuntu):
status: New → Confirmed
Changed in alsa-driver (Ubuntu):
assignee: nobody → Prashant (prashantgirase21)
assignee: Prashant (prashantgirase21) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions