Ubuntu

[NV79, Realtek ALC272X, Black SPDIF Out, Left] Playback problem

Reported by jazz41408 on 2011-04-15
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Undecided
David Henningsson

Bug Description

Whenever I plug headphones into my laptop I hear sound through the both the headphones and on the computer built in speakers. In order to listen to music or anything through the headphones I have to change the sound manually from the sound menu. (I change it from analog speakers to analog headphones).

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: alsa-base 1.0.24+dfsg-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic i686
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC272X Analog [ALC272X Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: dina 1436 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xd4400000 irq 43'
   Mixer name : 'Intel IbexPeak HDMI'
   Components : 'HDA:10ec0272,1025031d,00100001 HDA:14f12c06,1025031c,00100000 HDA:80862804,80860101,00100000'
   Controls : 30
   Simple ctrls : 16
Date: Fri Apr 15 11:05:15 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta i386 (20110330)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: alsa-driver
Symptom: audio
Symptom_AlsaPlaybackTest: ALSA playback test through plughw:Intel successful
Symptom_Card: Internal Audio - HDA Intel
Symptom_Jack: Black SPDIF Out, Left
Symptom_PulsePlaybackTest: PulseAudio playback test successful
Symptom_Type: None of the above
Title: [NV79, Realtek ALC272X, Black SPDIF Out, Left] Playback problem
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 01/05/2010
dmi.bios.vendor: Gateway
dmi.bios.version: V1.05
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: NV79
dmi.board.vendor: Gateway
dmi.board.version: V1.05
dmi.chassis.type: 10
dmi.chassis.vendor: Gateway
dmi.chassis.version: V1.05
dmi.modalias: dmi:bvnGateway:bvrV1.05:bd01/05/2010:svnGateway:pnNV79:pvrV1.05:rvnGateway:rnNV79:rvrV1.05:cvnGateway:ct10:cvrV1.05:
dmi.product.name: NV79
dmi.product.version: V1.05
dmi.sys.vendor: Gateway

jazz41408 (newviolinist) wrote :
David Henningsson (diwic) wrote :

Hi jazz41408 and thanks for the bug report.
This is an invalid SKU value. I'll prepare a patch and send it upstream.

Changed in alsa-driver (Ubuntu):
assignee: nobody → David Henningsson (diwic)
status: New → In Progress
David Henningsson (diwic) wrote :

Upstream has now accepted the patch.

Changed in alsa-driver (Ubuntu):
status: In Progress → Fix Committed
madbiologist (me-again) wrote :

This patch is included upstream in kernel 2.6.39-rc6, and has been cc'd to the stable kernel series (2.6.38+).

Herton R. Krzesinski (herton) wrote :

The commit for this issue came in via a stable upstream release. As such it is not subject to the standard bug verification process.

tags: added: verification-done-natty
madbiologist (me-again) wrote :

This patch is included upstream in kernel 2.6.38.6, and is currently available for testing in natty-proposed in 2.6.38-10.44.

Julian Wiedmann (jwiedmann) wrote :

For Natty, this should be fixed now with 2.6.38-10.46.
Please reopen the Natty task if you still experience this issue.

Changed in alsa-driver (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers