Ubuntu

plugging in headphones doesn't turn off all speakers on Acer Aspire 8942G

Reported by Hans Peter on 2011-02-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Undecided
David Henningsson

Bug Description

When plugging in headphones they start playing sound, but not every speaker is muted two or one remain playing sound, maybe it is the subwoofer hard to tell. I am on an Acer Aspire 8942G and using Ubuntu 10.10 Maverick. I am using the following alsa-drivers: 1.0.23+dfsg-1ubuntu4 (alsa-base).

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: alsa-base 1.0.23+dfsg-1ubuntu4
ProcVersionSignature: Ubuntu 2.6.35-26.46-generic 2.6.35.10
Uname: Linux 2.6.35-26-generic x86_64
NonfreeKernelModules: fglrx
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC670 Analog [ALC670 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: oem 1847 F.... pulseaudio
 /dev/snd/pcmC0D0p: oem 1847 F...m pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf8a00000 irq 51'
   Mixer name : 'Realtek ALC670'
   Components : 'HDA:10ec0670,10250308,00100002'
   Controls : 23
   Simple ctrls : 13
Card1.Amixer.info:
 Card hw:1 'Generic'/'HD-Audio Generic at 0xf8420000 irq 52'
   Mixer name : 'ATI R6xx HDMI'
   Components : 'HDA:1002aa01,00aa0100,00100200'
   Controls : 4
   Simple ctrls : 1
Card1.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Date: Wed Feb 9 17:17:21 2011
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=ru:ru_RU:en_US:en
 LANG=ru_RU.utf8
 SHELL=/bin/bash
SourcePackage: alsa-driver
dmi.bios.date: 05/21/2010
dmi.bios.vendor: Phoenix
dmi.bios.version: V1.3212
dmi.board.name: SM82-CP
dmi.board.vendor: Acer
dmi.board.version: Not Applicable
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnPhoenix:bvrV1.3212:bd05/21/2010:svnAcer:pnAspire8942G:pvrNotApplicable:rvnAcer:rnSM82-CP:rvrNotApplicable:cvnAcer:ct10:cvrN/A:
dmi.product.name: Aspire 8942G
dmi.product.version: Not Applicable
dmi.sys.vendor: Acer

Hans Peter (meinungscash) wrote :
tags: added: 8942g acer alsa-driver aspire headphones jack
David Henningsson (diwic) wrote :

Hmm, I remember a bug like this a while ago. If you have the time and experience, can you have a look at bug 611803 and bug 656625 and see if the instructions there on how to find the subwoofer pin can help you as well?

Changed in alsa-driver (Ubuntu):
status: New → Incomplete
Hans Peter (meinungscash) wrote :

If I go to Node[0x15] PIN and Mute Val[0] and Val[1] at "Output Amplifier" in hda_analyzer the speakers which normally remain playing sound mute and all I hear is the sound coming from my headphones.

David Henningsson (diwic) wrote :

Thanks, that's what I needed to know. I've made a patch and sent it to upstream.

Changed in alsa-driver (Ubuntu):
assignee: nobody → David Henningsson (diwic)
status: Incomplete → In Progress
Hans Peter (meinungscash) wrote :

Thank you so much. When will I be able to get that patch?

David Henningsson (diwic) wrote :

The patch is here: http://mailman.alsa-project.org/pipermail/alsa-devel/2011-February/036840.html
If you don't want to compile it in yourself, either wait until Takashi's applied it (might take a few days, haven't seen him around this week) + wait one day + https://wiki.ubuntu.com/Audio/InstallingLinuxAlsaDriverModules
Or in a few weeks, it should be in Natty.

David Henningsson (diwic) wrote :

Takashi just applied it so 24 hours from now it should be in https://wiki.ubuntu.com/Audio/InstallingLinuxAlsaDriverModules .

Changed in alsa-driver (Ubuntu):
status: In Progress → Fix Committed
Hans Peter (meinungscash) wrote :

Still not there. What happened?

David Henningsson (diwic) wrote :

Hmm. Wait another day, if it's still not in, please file an alsa-info (wiki.ubuntu.com/Alsa/AlsaInfo) so we can determine what went wrong. Thanks!

David Henningsson (diwic) wrote :

And just because of Murphy's law or something, the build of linux-alsa-driver-modules failed this morning so no test today either... :-(

Hans Peter (meinungscash) wrote :

Damn so will there a build tomorrow or will I have to wait until monday?

Hans Peter (meinungscash) wrote :

I just compiled the latest tarball from Takashi using following commands:

>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
cd ~
mkdir src
cd src
mkdir alsa
cd alsa
wget ftp://ftp.kernel.org/pub/linux/kernel/people/tiwai/snapshot/alsa-driver-snapshot.tar.gz
tar -xvpf alsa-driver-snapshot.tar.gz
cd alsa-driver
sudo ./configure
sudo make
sudo make install-modules

sudo reboot
<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

But the problem did not disappear. Did I something wrong while compilation, or do I have to do something else to make my system use the new driver?

David Henningsson (diwic) wrote :

I just tried your codec in an emulator, where it seems to work fine. If you run this command in a terminal: "modinfo snd-hda-codec-realtek"
Look at the filename on the first line - it should correspond to the path/file with Takashi's snapshot in. If you can't get it to work, let me know and I'll try making a dkms package for you to test.

Hans Peter (meinungscash) wrote :

filename: /lib/modules/2.6.35-26-generic/updates/alsa/snd-hda-codec-realtek.ko

It compiles fine I guess and no errors show up on installation, but the problem just is it does not load the new modules, but the old ones which are in this folder:

/lib/modules/2.6.35-26-generic/updates/alsa/

There appear new modules in the folder "modules" in the source directory of the extracted tarball.
How can I make the system load the new drivers? When I execute "sudo make install-modules" the new compiled modules should go straight to the direcory mentioned above where the old ones are and the system should load them, but why is that not the case?

Hans Peter (meinungscash) wrote :

I tried everything, but I just can't get it to work.
I really would appreciate your help.

David Henningsson (diwic) wrote :

Ok, I have now made a dkms package for you.

However first make sure you have no overrides installed. i e, "modinfo snd-hda-codec-realtek" should say:

/lib/modules/2.6.35-26-generic/kernel/sound/pci/hda/snd-hda-codec-realtek.ko

...as long as it says something else, you have something installed that overrides this which you must remove/uninstall. Exactly how to do that depends on what you installed and how.

After making sure of that, try:
http://people.canonical.com/~diwic/temp/alsa-hda-diwic-dkms_1.0.23.diwic_all.deb
Download, install, reboot and test.

After installation of the dkms package (and reboot), here's what it should say:

/lib/modules/2.6.35-26-generic/updates/dkms/snd-hda-codec-realtek.ko

Hans Peter (meinungscash) wrote :

Thank you very much. It works perfectly now. The support is awesome here.

Changed in alsa-driver (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers