Ubuntu

No automute on Lenovo Edge 14

Reported by David Henningsson on 2010-12-15
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Undecided
David Henningsson
Nominated for Maverick by Ayan George
Nominated for Natty by Ayan George

Bug Description

In Maverick, the internal speakers keep outputting sound although headphones are plugged in. This is on a Lenovo Edge 14.

Triagers, please do not triage this bug, it is being taken care of. Thanks.

Changed in alsa-driver (Ubuntu):
status: New → In Progress
assignee: nobody → David Henningsson (diwic)
David Henningsson (diwic) wrote :

Patch accepted upstream.

Changed in alsa-driver (Ubuntu):
status: In Progress → Fix Committed
Chris Van Hoof (vanhoof) on 2010-12-15
tags: added: hwe-blocker
madbiologist (me-again) wrote :

The abovementioned patch has been included upstream in kernel 2.6.37-rc7. From the changelog:

commit fe67b24010c66a14d84117ac67d23ed1bcb18a71
Author: David Henningsson
Date: Wed Dec 15 08:01:46 2010 +0100

    ALSA: HDA: Fix auto-mute on Lenovo Edge 14

    BugLink: http://launchpad.net/bugs/690530

    The SKU value of this machine dictates that auto-mute should be
    disabled. Since the SKU value is similar to the PCI SSID, the most
    likely conclusion is that the SKU value should be ignored.

    Signed-off-by: David Henningsson
    Signed-off-by: Takashi Iwai

David Henningsson (diwic) wrote :

Fixed in Natty as of 2.6.38-rc4 / linux-2.6.38-3.30.

Changed in alsa-driver (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers