[Realtek ALC1200] No sound at all. Ubuntu 10.10x64.Works fine on dual boot windows 7

Bug #688174 reported by Scott Cameron Gamble
This bug affects 2 people
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)

Bug Description

I have just installed the latest Ubuntu 10.10 x64 desktop release. This is a dual boot an my Asus Laptop With Windows 7,
Windows 7 was installed first. Sound is fine on Windows 7 but I have nothing on Ubuntu. I can here a small clicking sound
when I boot into Ubuntu like unplugging a headphone jack. Everything else works fine but no sound, from headphones or speakers. There are 5 sneakers on this laptop. I have tried all the combinations on the sound property tab. There are a lot of options hdmi audo etc...but no luck at all. I will try to find help on the forums ect. Perhaps the drivers are not installed? I am new to Linux and have not found a device manager like in windows where i can isolate my sound card and try to update the drivers.
Please help...
Thank you

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: alsa-base 1.0.23+dfsg-1ubuntu4
ProcVersionSignature: Ubuntu 2.6.35-23.41-generic
Uname: Linux 2.6.35-23-generic x86_64
NonfreeKernelModules: fglrx
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: amd64
 /dev/snd/controlC0: scott 1598 F.... pulseaudio
 Card hw:0 'Intel'/'HDA Intel at 0xfbaf8000 irq 48'
   Mixer name : 'Realtek ALC1200'
   Components : 'HDA:10ec0888,10431873,00100101 HDA:11c11040,10431636,00100200'
   Controls : 34
   Simple ctrls : 18
 Card hw:1 'HDMI'/'HDA ATI HDMI at 0xfbbfc000 irq 49'
   Mixer name : 'ATI R6xx HDMI'
   Components : 'HDA:1002aa01,00aa0100,00100100'
   Controls : 4
   Simple ctrls : 1
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
 Card hw:2 'HDMI_1'/'HDA ATI HDMI at 0xfbcfc000 irq 50'
   Mixer name : 'ATI R6xx HDMI'
   Components : 'HDA:1002aa01,00aa0100,00100100'
   Controls : 4
   Simple ctrls : 1
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Date: Thu Dec 9 10:59:35 2010
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
PackageArchitecture: all
SelectedCard: 0 Intel HDA-Intel - HDA Intel
SourcePackage: alsa-driver
Symptom: audio
Title: [Realtek ALC1200] ALSA test tone not correctly played back
dmi.bios.date: 06/05/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0001
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: W90VP
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: 1.00
dmi.chassis.asset.tag: 0x00000000
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTek Computer INC.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0001:bd06/05/2009:svnASUSTeKComputerINC.:pnW90VP:pvr1.0:rvnASUSTeKComputerINC.:rnW90VP:rvr1.00:cvnASUSTekComputerINC.:ct10:cvr1.0:
dmi.product.name: W90VP
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK Computer INC.

Revision history for this message
Scott Cameron Gamble (gamblesc) wrote :
Revision history for this message
Daniel T Chen (crimsun) wrote :
Changed in alsa-driver (Ubuntu):
status: New → Incomplete
Revision history for this message
Scott Cameron Gamble (gamblesc) wrote :

I followed the steps from the https://wiki.ubuntu.com/Audio/InstallingLinuxAlsaDriverModules
link you posted. after the final reboot still no sound.....
Thank you for your response what should I do now?

Revision history for this message
Daniel T Chen (crimsun) wrote :
Revision history for this message
Scott Cameron Gamble (gamblesc) wrote :
Download full text (87.3 KiB)

here is a copy of my AlsaInfo
Thank you,

!!ALSA Information Script v 0.4.59

!!Script ran on: Thu Dec 9 21:15:20 UTC 2010

!!Linux Distribution

Ubuntu 10.10 \n \l DISTRIB_ID=Ubuntu DISTRIB_DESCRIPTION="Ubuntu 10.10"

!!DMI Information

Manufacturer: ASUSTeK Computer INC.
Product Name: W90VP

!!Kernel Information

Kernel release: 2.6.35-23-generic
Operating System: GNU/Linux
Architecture: x86_64
Processor: unknown
SMP Enabled: Yes

!!ALSA Version

Driver version: 1.0.23
Library version: 1.0.23
Utilities version: 1.0.23

!!Loaded ALSA modules


!!Sound Servers on this system

      Installed - Yes (/usr/bin/pulseaudio)
      Running - Yes

ESound Daemon:
      Installed - Yes (/usr/bin/esd)
      Running - No

!!Soundcards recognised by ALSA

 0 [Intel ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xfbaf8000 irq 48
 1 [HDMI ]: HDA-Intel - HDA ATI HDMI
                      HDA ATI HDMI at 0xfbbfc000 irq 49
 2 [HDMI_1 ]: HDA-Intel - HDA ATI HDMI
                      HDA ATI HDMI at 0xfbcfc000 irq 50

!!PCI Soundcards installed in the system

00:1b.0 Audio device: Intel Corporation 82801JI (ICH10 Family) HD Audio Controller
01:00.1 Audio device: ATI Technologies Inc HD48x0 audio
02:00.1 Audio device: ATI Technologies Inc HD48x0 audio

!!Advanced information - PCI Vendor/Device/Susbsystem ID's

00:1b.0 0403: 8086:3a3e
 Subsystem: 1043:1873
01:00.1 0403: 1002:aa30
 Subsystem: 1043:aa30
02:00.1 0403: 1002:aa30
 Subsystem: 1043:aa30

!!Modprobe options (Sound related)

snd-atiixp-modem: index=-2
snd-intel8x0m: index=-2
snd-via82xx-modem: index=-2
snd-usb-audio: index=-2
snd-usb-caiaq: index=-2
snd-usb-ua101: index=-2
snd-usb-us122l: index=-2
snd-usb-usx2y: index=-2
snd-cmipci: mpu_port=0x330 fm_port=0x388
snd-pcsp: index=-2
snd-usb-audio: index=-2

!!Loaded sound module options

!!Module: snd_hda_intel
 bdl_pos_adj : 1,32,32,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1
 beep_mode : 1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1
 enable : Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y
 enable_msi : -1
 id : (null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null)
 index : -1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1
 model : (null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(nul...

Revision history for this message
Scott Cameron Gamble (gamblesc) wrote :

Well still no sound
I posted on the Ubuntu Web forums
but have gotten no replys,
Daniel if you see this please
advise what my next steps should be
to get sound working in Ubunto 10.10
Thank you

Revision history for this message
Daniel T Chen (crimsun) wrote :

(Please be patient; I can only contribute during non-work hours.)

Please attach output of `pactl stat` in a Terminal.

Revision history for this message
Scott Cameron Gamble (gamblesc) wrote :

here is the output for `pactl stat`
I will be patient just wanted to know you were there...

scott@scott-W90VP:~$ pactl stat
Currently in use: 1 blocks containing 63.9 KiB bytes total.
Allocated during whole lifetime: 3353 blocks containing 17.4 MiB bytes total.
Sample cache size: 0 B
User name: scott
Host Name: scott-W90VP
Server Name: pulseaudio
Server Version: 0.9.22
Default Sample Specification: s16le 2ch 44100Hz
Default Channel Map: front-left,front-right
Default Sink: alsa_output.pci-0000_00_1b.0.analog-stereo
Default Source: alsa_input.pci-0000_00_1b.0.analog-stereo
Cookie: 2aa45577

Revision history for this message
Daniel T Chen (crimsun) wrote :

What Profile is selected in Sound Preferences > Hardware tab, and what Connector is selected in Output tab?

Revision history for this message
Scott Cameron Gamble (gamblesc) wrote :

I have tried all the different profiles in the hardware tab and the
output tabs using the test speaker buttons also playing a video
no sound at all with the speakers or headphones
I am not sure what are the correct profiles to get the
sound working?
profiles are as follows:
HD48x0 audio
1 Output
Digital Stero(HDMI) output

Internal Audio
1 output / 1 input

There are two 1 output hdmi
and the internal audio

the connector in the output tab has ether
analog output or analog headphones?

Revision history for this message
Scott Cameron Gamble (gamblesc) wrote :

Well after spending many days trying to sort this out in the forums and following all the many
sound trouble shooting guides I gave up...
I did a fresh install of Ubuntu 10.4 after finding out that the sound worked right away from the live disc.
I installed 10.04 to my hard drive and after doing a full update sound still works perfectly right out of the
box. i do not know what is going on with the perfect 10? i guess it is not a stable release?
Still early days with 10.04 but my first impressions is that 10.4 is much more stable.

Revision history for this message
Launchpad Janitor (janitor) wrote :

[Expired for alsa-driver (Ubuntu) because there has been no activity for 60 days.]

Changed in alsa-driver (Ubuntu):
status: Incomplete → Expired
Revision history for this message
Nanodesu (nan0desu) wrote :

Confirmed this in many distribution with a modern kernel. This is not ubuntu, but alsa problem.
It seems to be broken between and (diff is attached)
You can fix this by reversing attached patch and recompiling the kernel.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.