ThinkPad Edge 11 no sound record with internal mic

Bug #683926 reported by ssabchew on 2010-12-01
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Undecided
Unassigned

Bug Description

I did not tried external mic, but build in does not work.
I tried with few options of snd-hda-intel:

#options snd-hda-intel model=laptop power_save=1
#options snd-hda-intel model=auto power_save=1 probe_mask=1
#options snd-hda-intel model="olpc-xo-1_5" power_save=1 probe_mask=1

no success so far

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: alsa-base 1.0.23+dfsg-1ubuntu4
ProcVersionSignature: Ubuntu 2.6.35-23.41~phc0-generic-phc 2.6.35.7
Uname: Linux 2.6.35-23-generic-phc x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 0/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: annipul 2392 F.... pulseaudio
 /dev/snd/pcmC0D0c: annipul 2392 F...m pulseaudio
 /dev/snd/pcmC0D0p: annipul 2392 F...m pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf0700000 irq 48'
   Mixer name : 'Intel IbexPeak HDMI'
   Components : 'HDA:14f15066,17aa21c8,00100302 HDA:80862804,80860101,00100000'
   Controls : 22
   Simple ctrls : 13
Card29.Amixer.info:
 Card hw:29 'ThinkPadEC'/'ThinkPad Console Audio Control at EC reg 0x30, fw 86HT21WW-1.167000'
   Mixer name : 'ThinkPad EC 86HT21WW-1.167000'
   Components : ''
   Controls : 1
   Simple ctrls : 1
Card29.Amixer.values:
 Simple mixer control 'Console',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Date: Thu Dec 2 01:41:01 2010
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: alsa-driver
dmi.bios.date: 08/10/2010
dmi.bios.vendor: LENOVO
dmi.bios.version: 86ET19WW (1.03 )
dmi.board.name: 03283JG
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr86ET19WW(1.03):bd08/10/2010:svnLENOVO:pn03283JG:pvrThinkPadEdge:rvnLENOVO:rn03283JG:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 03283JG
dmi.product.version: ThinkPad Edge
dmi.sys.vendor: LENOVO

ssabchew (ssabchew) wrote :
Benjamin Schmid (benbuntu) wrote :

Appending
  options snd-hda-intel model=ideapad
in the file
  /etc/modprobe.d/alsa-base.conf
solved both problems for me on a Thinkpad Edge 11" AMD Neo II K325: Audio Jack and internal mic. working with Skype.

Only the audio recorder seems to ignore the internal mic,. ?!

Xwarman (xwarman) wrote :

I tryed that on my thinkpad edge 11. I think that works. I only tested skype but before, I had problems with the mic. Now it works. Thank you! Maybe that could be a default entery in future?

David Henningsson (diwic) wrote :

The fix is upstream, and it is already in Natty. It wasn't sent to stable, so I don't think it'll reach Maverick without some action being taken.

Changed in alsa-driver (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers