Inbuilt microphone not working on Thinkpad Edge 13 0196CTO

Bug #683487 reported by Ben on 2010-12-01
40
This bug affects 7 people
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Undecided
Unassigned

Bug Description

Per https://wiki.ubuntu.com/DebuggingSoundProblems, reporting that the builtin/onboard microphone does not work "out of the box" on a Thinkpad Edge 13 0196CTO. An external mic plugged in to the "combo" headphone/mic jack does work. Builtin speakers and also headphones work fine, and switch back and forth when the mic/phones are plugged in.

From http://ubuntuforums.org/showthread.php?t=1609411, I tried using 'options snd-hda-intel model=laptop' in /etc/modprobe.d/alsa-base.conf, which after rebooting enabled the internal microphone, however disabled the switching between the internal mic+speakers and the external jack (i.e. plugging in the external mic/phones had no effect, audio in & out was still from the builtin devices). I don't see any option in /usr/share/doc/alsa-base/driver/HD-Audio-Models.txt.gz that matches this hardware.

Output from ubuntu-bug audio attached.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: alsa-base 1.0.23+dfsg-1ubuntu4
ProcVersionSignature: Ubuntu 2.6.35-23.40-generic-pae 2.6.35.7
Uname: Linux 2.6.35-23-generic-pae i686
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ben 1981 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf0800000 irq 48'
   Mixer name : 'Intel Cantiga HDMI'
   Components : 'HDA:14f15066,17aa21b4,00100300 HDA:80862802,80860101,00100000'
   Controls : 10
   Simple ctrls : 5
Card29.Amixer.info:
 Card hw:29 'ThinkPadEC'/'ThinkPad Console Audio Control at EC reg 0x30, fw 6YHT26WW-1.171000'
   Mixer name : 'ThinkPad EC 6YHT26WW-1.171000'
   Components : ''
   Controls : 1
   Simple ctrls : 1
Card29.Amixer.values:
 Simple mixer control 'Console',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Date: Wed Dec 1 17:14:47 2010
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, user)
 LANG=en_AU.utf8
 SHELL=/bin/bash
SourcePackage: alsa-driver
Symptom: audio
Title: Soundcard not detected
dmi.bios.date: 09/10/2010
dmi.bios.vendor: LENOVO
dmi.bios.version: 6YET33WW (1.16 )
dmi.board.name: 0196CTO
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr6YET33WW(1.16):bd09/10/2010:svnLENOVO:pn0196CTO:pvrThinkPadEdge:rvnLENOVO:rn0196CTO:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 0196CTO
dmi.product.version: ThinkPad Edge
dmi.sys.vendor: LENOVO

Ben (ben-bdlow) wrote :

Please remove all model quirks, and install (then reboot) the latest daily
linux-alsa-driver-modules sound driver build from the ppa as outlined at
https://wiki.ubuntu.com/Audio.

Ben (ben-bdlow) wrote :

Thanks. I restored the original /etc/modprobe.d/alsa-base.conf and installed the "Crack of the day" drivers per https://wiki.ubuntu.com/Audio/InstallingLinuxAlsaDriverModules. Alas, no change. Builtin mic does not work, builtin speakers and external mic/headphones do work. I'm testing this by looking at the Sound Preferences "Input level" and also via Sound Recorder.

ben@tp:~$ dpkg -l linux-alsa-driver'*'

ii linux-alsa-driver-modules-2. 2.6.35-23.201011301600 Ubuntu-supplied Linux modules for version 2.6.35-23-generic-pae ALSA sna

Ben (ben-bdlow) wrote :

Done, output attached.

Benjamin Schmid (benbuntu) wrote :

Appending
  options snd-hda-intel model=ideapad
in the file
  /etc/modprobe.d/alsa-base.conf
solved both problems for me: Audio Jack and internal mic. working with Skype.

Only the audio recorder seems to ignore the internal mic,. ?!

William DeMeo (williamdemeo) wrote :

Hi! My new Thinkpad Edge 13 just arrived yesterday, so of course I installed ubuntu immediately (version 11.04). I'm happy to report that almost everything seems to be working great! ..even the webcam! However, I'm having the same problem with the internal microphone as Benjamin. I tried his solutions with these results:

First, I installed the "Crack of the day" drivers as per https://wiki.ubuntu.com/Audio/InstallingLinuxAlsaDriverModules

Then I tried adding the following to /etc/modprobe.d/alsa-base.conf

options snd-hda-intel model=laptop

I rebooted (since I've forgotten how to use the modprobe, lsmod, etc commands to reload modules! ..sadly(?) it has been many years since I've had to do this sort of thing.)

The result was that I could use the internal mic, however, the headphone jack was disabled. Even when headphones are plugged into the jack, the sound still comes out the internal laptop speakers. (I think this was also Ben's experience.) So, I tried Ben's second solution:

2. Append
  options snd-hda-intel model=ideapad
in the file
  /etc/modprobe.d/alsa-base.conf

The result is that I'm back to where I started: sound comes out the internal speakers, or the headphones when they are plugged into the jack, but the internal microphone is disabled.

I'm not sure why this worked for Benjamin and not me. I tried comparing our respective outputs from alsa-info, but I'm afraid I don't really know what to look for. Well, if someone could suggest something (anything), I'd be very grateful.

(I'll attach the output of the alsa-info command run on my machine, in case it helps.)

Thank you!!

Benjamin Schmid (benbuntu) wrote :

William, just a few hints:
1. Only add one option line (the one with ideapad), not both to modprobe.d/alsa-base.conf

2. After changing the options and rebooting, the mic. was not immediately working. I had to start the audio panel and flip the input/output devices to digital and output only and then back to the analog stereo/duplex settings. This unselected the input port. After selecting the input port it started to work.

3. This works somehow "reliable" on my machine with the new kernel and newest snapshot drivers. A identical machine for my mother using only the maverick-proposed kernel seems to loose this setting on every reboot. Even worse: Most of the times the mic only records some nasty noise instead of real input. In that case the playing with the settings as mentioned above does not help. This is very frustrating.

Conclusion: At least you should be able to somehow get the mic running on playing with the input settings. Nevertheless for a daily usage i.e. like Skype currently this does not work stable/satisfying enough. Hope this helps, anyways

William DeMeo (williamdemeo) wrote :

Ben, Thanks for kindly suggesting these solutions. Unfortunately, none of them worked for me. However, just when I was about to give up, I took a shot in the dark and tried the following:

options snd-hda-intel model=thinkpad

I had nothing to base this on. I searched for a list of possible snd-hda-intel model options, but could not find it. So, I just took a wild guess and was almost certain it wouldn't work. Amazingly, it works!

The mic works, the speakers work and, when I plug headphones into the audio jack, the headphones work AND they mute the internal speakers. Finally, audio recording also works (which resolves the problem you were having, Ben, so you might want to try the model=thinkpad option).

-William

Peter Selinger (selinger) wrote :

I would like to confirm that William's solution
options snd-hda-intel model=thinkpad
also works for me. If no headphones are plugged in, the internal microphone and internal speaker works. If headphones are plugged in, the internal speakers are off, sound is in the headphones, and the internal microphones still work (my headphones don't have a microphone). Thinkpad Edge 13, Ubuntu 10.10 "out of the box". Thanks! -- Peter

Ben (ben-bdlow) wrote :

Yes, I've finally had a chance to check the model=thinkpad option and can confirm it works (obvious, really, given this is a thinkpad model :-).

Testing w/ sound recorder: without external phones plugged in, inbuilt audio output and input works. With a combo headphone/mic phones plugged in, inbuilt mic+speakers are muted and the external phones/mic work.

Thanks Daniel, William, Benjamin, Peter.

BTW, the "mic mute" / F4 key does not function but I expect that's not an audio driver issue (ditto camera mute for that matter).

Changed in alsa-driver (Ubuntu):
status: New → Confirmed
Suneel Kanuri (suneel-kanuri) wrote :

I can vouch this worked on Edge 14 Lenova Thinkpad. I am talking of the "thinkpad" options. Who would have thought !! Anyhow thanks guys for the valuable input. I was going crazy with options like basic/auto/laptop-amic/laptop-dmic and so on :(

Suneel K

The only solution to make microphone work is to install linux-backports-modules-alsa-generic...

Just go to:

Menu / System / Administration / Synaptic Package Manager

And search and mark for installation:

linux-backports-modules-alsa-generic

tip: if you have multiple versions click on the first and read the description which should inform what name to install...

If after the reboot and mic mute is off, still does not work, just go to terminal and type:

sudo nano /etc/modprobe.d/alsa-base.conf

and add or change the following:

options snd-hda-intel model=auto enable=yes

Then Ctrl+X, type Y to write and exit, reboot and mic will work.

Bye and have lots of fun with Ubuntu (the best).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers