Ubuntu

ALC883_MEDION_MD2 is incorrect model quirk for MEDION MD2 as of Maverick

Reported by Daniel T Chen on 2010-11-27
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Low
Unassigned

Bug Description

I just spent a couple hours assisting a user (burningphantom1 on irc) get audible audio on his machine's speakers and headphones using Maverick (2.6.35) and the latest daily build of alsa-driver (2010-11-27). It seems that his machine's pci ssid, 0x17c04071, was added to the ALC883 quirk table (alc883_cfg_tbl[] in sound/pci/hda/patch_realtek.c) in commit 272a527c04 of sound-2.6.git (Mon May 14 11:00:38 2007 +0200, [ALSA] hda-codec - Fix ALC882/861VD codec support on some laptops). During the time of that commit, bios autoparsing was suboptimal, but the current driver (at least in 2.6.35 and newer) has much improved support. We've verified that playback, capture, and jack sense work correctly without the existing quirk entry, so we should just remove the one line for his machine's pci ssid.

Daniel T Chen (crimsun) wrote :

Use bios auto-parsing instead of existing quirk entry

tags: added: patch-forwarded-upstream
Changed in alsa-driver (Ubuntu):
status: New → In Progress
importance: Undecided → Low
Daniel T Chen (crimsun) wrote :
tags: added: patch-accepted-upstream
removed: patch-forwarded-upstream
Changed in alsa-driver (Ubuntu):
status: In Progress → Fix Committed

Accepted into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Steve Conklin (sconklin) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed' to 'verification-done'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

Brad Figg (brad-figg) wrote :

This patch was applied to Maverick as part of an upstream stable update, therefore it doesn't require individual verification.

tags: added: verification-done
removed: verification-needed
Andy Whitcroft (apw) on 2011-02-10
Changed in alsa-driver (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers