Headphones don't work and don't mute speakers

Bug #677652 reported by Joan Creus on 2010-11-19
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
alsa-driver (Ubuntu)
Low
Unassigned

Bug Description

I have an Asus A52J laptop and it's got several problems. On Lucid Lynx, the headphones worked, but they didn't mute the speakers. Now, on Maverick, the headphones don't work, nor do they mute the speakers. I have a dual boot into Windows, and there, the headphones work as expected.

alsa-oss is on version 1.0.17-4 and alsa-base is on 1.0.23+dfsg-1ubuntu4

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: alsa-base 1.0.23+dfsg-1ubuntu4
ProcVersionSignature: Ubuntu 2.6.35-22.35-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: joanc 2823 F.... pulseaudio
 /dev/snd/pcmC0D0p: joanc 2823 F...m pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xd7400000 irq 46'
   Mixer name : 'Intel IbexPeak HDMI'
   Components : 'HDA:14f15069,104313f3,00100302 HDA:80862804,80860101,00100000'
   Controls : 20
   Simple ctrls : 12
Date: Fri Nov 19 20:02:56 2010
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
PackageArchitecture: all
ProcEnviron:
 LANG=ca_AD.utf8
 SHELL=/bin/bash
SelectedCard: 0 Intel HDA-Intel - HDA Intel
SourcePackage: alsa-driver
Symptom: audio
Title: [Conexant CX20585] Playback problem
dmi.bios.date: 03/16/2010
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: K52Jc.205
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: K52Jc
dmi.board.vendor: ASUSTeK Computer Inc.
dmi.board.version: 1.0
dmi.chassis.asset.tag: ATN12345678901234567
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK Computer Inc.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrK52Jc.205:bd03/16/2010:svnASUSTeKComputerInc.:pnK52Jc:pvr1.0:rvnASUSTeKComputerInc.:rnK52Jc:rvr1.0:cvnASUSTeKComputerInc.:ct10:cvr1.0:
dmi.product.name: K52Jc
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK Computer Inc.
---
AlsaVersion:
 Advanced Linux Sound Architecture Driver Version 1.0.23.
 Compiled on Nov 21 2010 for kernel 2.6.35-22-generic (SMP).
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: joanc 1929 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xd7400000 irq 46'
   Mixer name : 'Intel IbexPeak HDMI'
   Components : 'HDA:14f15069,104313f3,00100302 HDA:80862804,80860101,00100000'
   Controls : 22
   Simple ctrls : 13
DistroRelease: Ubuntu 10.10
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
Package: alsa-driver (not installed)
ProcEnviron:
 LANG=ca_AD.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.35-22.35-generic 2.6.35.4
Tags: maverick
Uname: Linux 2.6.35-22-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 03/16/2010
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: K52Jc.205
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: K52Jc
dmi.board.vendor: ASUSTeK Computer Inc.
dmi.board.version: 1.0
dmi.chassis.asset.tag: ATN12345678901234567
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK Computer Inc.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrK52Jc.205:bd03/16/2010:svnASUSTeKComputerInc.:pnK52Jc:pvr1.0:rvnASUSTeKComputerInc.:rnK52Jc:rvr1.0:cvnASUSTeKComputerInc.:ct10:cvr1.0:
dmi.product.name: K52Jc
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK Computer Inc.

Joan Creus (joan-creus) wrote :
Daniel T Chen (crimsun) wrote :

(Just a note: the alsa-oss package is irrelevant to your symptom.)

Is the symptom reproducible after following https://wiki.ubuntu.com/Audio/InstallingLinuxAlsaDriverModules?

Changed in alsa-driver (Ubuntu):
status: New → Incomplete
Joan Creus (joan-creus) wrote :

Yes, it doesn't make any difference.

Daniel T Chen (crimsun) wrote :

Please use apport-collect 677652 while using the updated daily build of the sound drivers.

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Joan Creus (joan-creus) wrote :

Done!

Daniel T Chen (crimsun) wrote :

Can you try model=hp-laptop, please (as so)?

options snd-hda-intel model=hp-laptop

should be appended to /etc/modprobe.d/alsa-base.conf, and you should reboot.

Joan Creus (joan-creus) wrote :

It works!

What's next? Shall I keep the configuration when the official fix comes out?

Daniel T Chen (crimsun) wrote :

I've pushed a patch for this issue to the kernel subsystem maintainer, and it should be applied "shortly." Someone will probably follow up shortly to confirm after it has been applied in an upstream kernel and is available (upstream, and separately, in an Ubuntu kernel update).

Changed in alsa-driver (Ubuntu):
importance: Undecided → Low
status: Incomplete → In Progress
Daniel T Chen (crimsun) wrote :
tags: added: patch-forwarded-upstream
Daniel T Chen (crimsun) wrote :
tags: added: patch-accepted-upstream
removed: patch-forwarded-upstream
Changed in alsa-driver (Ubuntu):
status: In Progress → Fix Committed
madbiologist (me-again) wrote :

The abovementioned patch has been included upstream in kernel 2.6.37 and in kernel 2.6.36.2. PPAs of these kernels are available at http://kernel.ubuntu.com/~kernel-ppa/mainline/

Accepted into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Steve Conklin (sconklin) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed' to 'verification-done'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

Joan Creus (joan-creus) wrote :

I have tested the proposed patch, and it works. I have even commented out the

options snd-hda-intel model=hp-laptop

line, and it still works.

I don't see how I can change the verification-needed tag, though. Can you do it for me?

tags: added: verification-done
removed: verification-needed
Andy Whitcroft (apw) wrote :
Download full text (3.2 KiB)

This bug was fixed in the package linux - 2.6.38-1.27

---------------
linux (2.6.38-1.27) natty; urgency=low

  [ Andy Whitcroft ]

  * ubuntu: AUFS -- update aufs-update to track new locations of headers
  * ubuntu: AUFS -- update to c5021514085a5d96364e096dbd34cadb2251abfd
  * SAUCE: ensure root is ready before running usermodehelpers in it
  * correct the Vcs linkage to point to natty
  * rebase to linux tip e78bf5e6cbe837daa6ab628a5f679548742994d3
  * [Config] update configs following rebase
    e78bf5e6cbe837daa6ab628a5f679548742994d3
  * SAUCE: Yama: follow changes to generic_permission
  * ubuntu: compcache -- follow changes to bd_claim/bd_release
  * ubuntu: iscsitarget -- follow changes to open_bdev_exclusive
  * ubuntu: ndiswrapper -- fix interaction between __packed and packed
  * ubuntu: AUFS -- update to 806051bcbeec27748aae2b7957726a4e63ff308e
  * update package version to match payload version
  * rebase to e6f597a1425b5af64917be3448b29e2d5a585ac8
  * rebase to v2.6.38-rc1
  * [Config] updateconfigs following rebase to v2.6.38-rc1
  * SAUCE: x86 fix up jiffies/jiffies_64 handling
  * rebase to linus tip 2b1caf6ed7b888c95a1909d343799672731651a5
  * [Config] updateconfigs following rebase to
    2b1caf6ed7b888c95a1909d343799672731651a5
  * [Config] disable CONFIG_TRANSPARENT_HUGEPAGE to fix i386 boot crashes
  * ubuntu: AUFS -- suppress benign plink warning messages
    - LP: #621195
  * [Config] CONFIG_NR_CPUS=256 for amd64 -server flavour
  * rebase to v2.6.38-rc2
  * rebase to mainline d315777b32a4696feb86f2a0c9e9f39c94683649
  * rebase to c723fdab8aa728dc2bf0da6a0de8bb9c3f588d84
  * [Config] update configs following rebase to
    c723fdab8aa728dc2bf0da6a0de8bb9c3f588d84
  * [Config] disable CONFIG_AD7152 to fix FTBS on armel versatile
  * [Config] disable CONFIG_AD7150 to fix FTBS on armel versatile
  * [Config] disable CONFIG_RTL8192CE to fix FTBS on armel omap
  * [Config] disable CONFIG_MANTIS_CORE to fix FTBS on armel versatile

  [ Kees Cook ]

  * SAUCE: kernel: make /proc/kallsyms mode 400 to reduce ease of attacking

  [ Stefan Bader ]

  * Temporarily disable RODATA for virtual i386
    - LP: #699828

  [ Tim Gardner ]

  * [Config] CONFIG_NLS_DEFAULT=utf8
    - LP: #683690
  * [Config] CONFIG_HIBERNATION=n
  * update bnx2 firmware files in d-i/firmware/nic-modules

  [ Upstream Kernel Changes ]

  * Revert "drm/radeon/bo: add some fallback placements for VRAM only
    objects."
  * packaging: make System.map mode 0600
  * thinkpad_acpi: Always report scancodes for hotkeys
    - LP: #702407
  * sched: tg->se->load should be initialised to tg->shares
  * Input: sysrq -- ensure sysrq_enabled and __sysrq_enabled are consistent
  * brcm80211: include linux/slab.h for kfree
  * pch_dma: add include/slab.h for kfree
  * i2c-eg20t: include linux/slab.h for kfree
  * gpio/ml_ioh_gpio: include linux/slab.h for kfree
  * tty: include linux/slab.h for kfree
  * winbond: include linux/delay.h for mdelay et al

  [ Upstream Kernel Changes ]

  * mark the start of v2.6.38 versioning
  * rebase v2.6.37 to v2.6.38-rc2 + c723fdab8aa728dc2bf0da6a0de8bb9c3f588d84
    - LP: #689886
    - LP: #702125
    - LP: #608775
    - LP: #215802
...

Read more...

Changed in alsa-driver (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.